aboutsummaryrefslogtreecommitdiffstats
path: root/dns/nsd/Makefile
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2013-11-12 21:24:45 +0800
committererwin <erwin@FreeBSD.org>2013-11-12 21:24:45 +0800
commit616086afd3df7bf081a38b13b7b343b77b46deca (patch)
tree36044afc0129b56dee79730becdc8faf8fc61a16 /dns/nsd/Makefile
parent2f008ebd7ec2e48cbe2b9edd7421ae19f71eadc8 (diff)
downloadfreebsd-ports-gnome-616086afd3df7bf081a38b13b7b343b77b46deca.tar.gz
freebsd-ports-gnome-616086afd3df7bf081a38b13b7b343b77b46deca.tar.zst
freebsd-ports-gnome-616086afd3df7bf081a38b13b7b343b77b46deca.zip
Please welcome NSD 4.0.0
For all new features, see http://www.nlnetlabs.nl/svn/nsd/tags/NSD_4_0_0_REL/doc/NSD-4-features This version replaces the nsdc control program with nsd-control. This requires some manual setup with nsd-control-setup and editing of the config files. nsd-control is incompatible with nsdc so when that is used in scripts, these should be adapted. NSD 3 is still supported as dns/nsd3. PR: 183888 Submitted by: Jaap Akkerhuis <jaap@NLnetLabs.nl>
Diffstat (limited to 'dns/nsd/Makefile')
-rw-r--r--dns/nsd/Makefile35
1 files changed, 15 insertions, 20 deletions
diff --git a/dns/nsd/Makefile b/dns/nsd/Makefile
index 632b340bed5d..4b01a5dde577 100644
--- a/dns/nsd/Makefile
+++ b/dns/nsd/Makefile
@@ -2,15 +2,15 @@
# $FreeBSD$
PORTNAME= nsd
-PORTVERSION= 3.2.16
+PORTVERSION= 4.0.0
CATEGORIES= dns ipv6
MASTER_SITES= http://www.nlnetlabs.nl/downloads/nsd/ \
ftp://ftp.rhnet.is/pub/nsd/
MAINTAINER= jaap@NLnetLabs.nl
-COMMENT= Authoritative only non-recursive name server
+COMMENT= An authoritative only non-recursive name server
-CONFLICTS= nsd-[0-2]*
+CONFLICTS= nsd-[0-]* nsd3-*
USE_RC_SUBR= nsd
@@ -22,7 +22,8 @@ NSDRUNDIR= /var/run/nsd
NSDMAX_IPS?= 512
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-user=${NSDUSER} \
+CONFIGURE_ARGS= --with-libevent=${LOCALBASE} \
+ --with-user=${NSDUSER} \
--with-configdir=${PREFIX}/etc/nsd \
--localstatedir=${NSDLSDIR} \
--with-dbfile=${NSDDBDIR}/nsd.db \
@@ -36,23 +37,22 @@ SUB_LIST+= NSDUSER=${NSDUSER} \
USE_OPENSSL= yes
-MAN5= nsd.conf.5
-MAN8= nsd.8 nsdc.8 zonec.8 nsd-checkconf.8 nsd-notify.8 nsd-patch.8 \
- nsd-xfer.8
+MAN5= nsd.conf.5
+MAN8= nsd.8 nsd-checkconf.8 nsd-control.8
PORTDOCS= CREDITS ChangeLog LICENSE NSD-DATABASE NSD-DIFFFILE \
- NSD-FOR-BIND-USERS README README.icc RELNOTES \
+ NSD-4-features NSD-FOR-BIND-USERS README README.icc RELNOTES \
REQUIREMENTS TESTPLAN TODO UPGRADING coding-style \
differences.tex
-OPTIONS_DEFINE= ROOT_SERVER LARGEFILE IPV6 BIND8_STATS ZONE_STATS CHECKING \
- MINRESPSIZE NSEC3 NSEC3PREHASH MMAP MAXIPS DOCS RRL EUI_RRTYPES
-OPTIONS_DEFAULT= LARGEFILE IPV6 NSEC3 NSEC3PREHASH MINRESPSIZE
+OPTIONS_DEFINE= ROOT_SERVER LARGEFILE IPV6 BIND8_STATS CHECKING \
+ MINRESPSIZE NSEC3 NSEC3PREHASH MMAP MAXIPS DOCS EUI_RRTYPES
+OPTIONS_DEFAULT= LARGEFILE IPV6 NSEC3 NSEC3PREHASH MINRESPSIZE RRL \
+ EUI_RRTYPES
ROOT_SERVER_DESC= Configure as a root server
LARGEFILE_DESC= Largefile support
BIND8_STATS_DESC= BIND8-like NSTATS & XSTATS
-ZONE_STATS_DESC= Per-zone BIND8 stats
CHECKING_DESC= Internal run-time checks
NSEC3_DESC= NSEC3 support
NSEC3PREHASH_DESC= Full NSEC3 pre-hashing
@@ -62,9 +62,11 @@ MAXIPS_DESC= Raise max-ips from 8 to ${NSDMAX_IPS}
RRL_DESC= Response Rate Limiting
EUI_RRTYPES_DESC= EUI48 and EUI64 RRtypes support
-NO_STAGE= yes
+NO_STAGE= yes
.include <bsd.port.options.mk>
+LIB_DEPENDS+= event-1:${PORTSDIR}/devel/libevent
+
.if ${PORT_OPTIONS:MROOT_SERVER}
CONFIGURE_ARGS+= --enable-root-server
.endif
@@ -81,13 +83,6 @@ CONFIGURE_ARGS+= --disable-ipv6
CONFIGURE_ARGS+= --enable-bind8-stats
.endif
-.if ${PORT_OPTIONS:MZONE_STATS}
-. if empty(PORT_OPTIONS:MBIND8_STATS)
-CONFIGURE_ARGS+= --enable-bind8-stats
-. endif
-CONFIGURE_ARGS+= --enable-zone-stats
-.endif
-
.if ${PORT_OPTIONS:MCHECKING}
CONFIGURE_ARGS+= --enable-checking
.endif