aboutsummaryrefslogtreecommitdiffstats
path: root/dns/odsclient
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-02-19 20:19:30 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-02-19 20:19:30 +0800
commitfc0cc9c041cb78efab8fa010c021f2244ef84b73 (patch)
tree4795b85828c785f1468c4ade33d7177818c0c9b1 /dns/odsclient
parenta1d5fc66dc502edcdb0b07ee8c467d8b59320680 (diff)
downloadfreebsd-ports-gnome-fc0cc9c041cb78efab8fa010c021f2244ef84b73.tar.gz
freebsd-ports-gnome-fc0cc9c041cb78efab8fa010c021f2244ef84b73.tar.zst
freebsd-ports-gnome-fc0cc9c041cb78efab8fa010c021f2244ef84b73.zip
- Support staging
- Respect CC - Respect CFLAGS - Fix build with clang
Diffstat (limited to 'dns/odsclient')
-rw-r--r--dns/odsclient/Makefile15
-rw-r--r--dns/odsclient/files/patch-Makefile15
2 files changed, 19 insertions, 11 deletions
diff --git a/dns/odsclient/Makefile b/dns/odsclient/Makefile
index 78b043ffd419..8d9216b16eb3 100644
--- a/dns/odsclient/Makefile
+++ b/dns/odsclient/Makefile
@@ -11,18 +11,11 @@ COMMENT= ODS Dynamic DNS Client
ALL_TARGET= odsclient
-NO_STAGE= yes
-post-patch:
- @${REINPLACE_CMD} -e "s/^(CC|CFLAGS).+//g" ${WRKSRC}/Makefile
+OPTIONS_DEFINE= DOCS
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/odsclient ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/README
-.endif
-
-post-install:
- @${CAT} ${PKGMESSAGE}
+ ${INSTALL_PROGRAM} ${WRKSRC}/odsclient ${STAGEDIR}${PREFIX}/bin
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}/README
.include <bsd.port.mk>
diff --git a/dns/odsclient/files/patch-Makefile b/dns/odsclient/files/patch-Makefile
new file mode 100644
index 000000000000..0013f01aa53e
--- /dev/null
+++ b/dns/odsclient/files/patch-Makefile
@@ -0,0 +1,15 @@
+--- ./Makefile.orig 2014-02-19 13:17:44.470074950 +0100
++++ ./Makefile 2014-02-19 13:18:23.437075941 +0100
+@@ -1,10 +1,9 @@
+-CC=gcc -Wall
+-CFLAGS=-O2
++CC?=gcc
+ DNSLIB=#-lresolv
+ OBJS=client.o memmem.o vasprintf.o socket.o
+
+ odsclient: $(OBJS)
+- $(CC) -o odsclient $(OBJS) $(DNSLIB)
++ $(CC) $(CFLAGS) -o odsclient $(OBJS) $(DNSLIB)
+
+ clean:
+ rm -rf $(OBJS) odsclient *~