aboutsummaryrefslogtreecommitdiffstats
path: root/dns/p5-DNS-Config
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-04-29 15:25:58 +0800
committeredwin <edwin@FreeBSD.org>2003-04-29 15:25:58 +0800
commit05d997ff0837e931aba713b9fef66e57ad4cc68c (patch)
tree193470890ce741c31d4eccdd7ab1c1735f60ed1c /dns/p5-DNS-Config
parent4ac0df3c1b4f84ece3047e793fc13caf39b0ccfb (diff)
downloadfreebsd-ports-gnome-05d997ff0837e931aba713b9fef66e57ad4cc68c.tar.gz
freebsd-ports-gnome-05d997ff0837e931aba713b9fef66e57ad4cc68c.tar.zst
freebsd-ports-gnome-05d997ff0837e931aba713b9fef66e57ad4cc68c.zip
[new port] : net/p5-DNS-Config Perl modules to manipulate DNS stuff
5-DNS-Config Perl modules to manipulate name service configurations. Needed by (future new) ZoneMaster port (see below/later) PR: ports/48562 Submitted by: Clement Laforet <sheepkiller@cultdeadsheep.org>
Diffstat (limited to 'dns/p5-DNS-Config')
-rw-r--r--dns/p5-DNS-Config/Makefile30
-rw-r--r--dns/p5-DNS-Config/distinfo1
-rw-r--r--dns/p5-DNS-Config/pkg-descr9
-rw-r--r--dns/p5-DNS-Config/pkg-plist17
4 files changed, 57 insertions, 0 deletions
diff --git a/dns/p5-DNS-Config/Makefile b/dns/p5-DNS-Config/Makefile
new file mode 100644
index 000000000000..5c90f44c1344
--- /dev/null
+++ b/dns/p5-DNS-Config/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-DNS-Config
+# Date created: 22 February 2003
+# Whom: Clement Laforet <sheepkiller@cultdeadsheep.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DNS-Config
+PORTVERSION= 0.66
+PORTREVISION= 0
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= DNS
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sheepkiller@cultdeadsheep.org
+COMMENT= DNS::Config is set of perl modules for name service configurations
+
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+DOCSDIR= ${PREFIX}/share/doc/p5-DNS-Zone
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/dns/p5-DNS-Config/distinfo b/dns/p5-DNS-Config/distinfo
new file mode 100644
index 000000000000..af18b0b68f61
--- /dev/null
+++ b/dns/p5-DNS-Config/distinfo
@@ -0,0 +1 @@
+MD5 (DNS-Config-0.66.tar.gz) = 71309d67930fe356c860bbb96289c0d4
diff --git a/dns/p5-DNS-Config/pkg-descr b/dns/p5-DNS-Config/pkg-descr
new file mode 100644
index 000000000000..e31bfeb62b2f
--- /dev/null
+++ b/dns/p5-DNS-Config/pkg-descr
@@ -0,0 +1,9 @@
+DNS::Config is a collection of Perl modules which provide an
+abstraction of name service zones as well as server specific
+adaptors for concrete file representations.
+The modules origin is the ZoneMaster project which make heavy
+use of the module for comprehensive zone file management. Go to
+http://www.zonemaster.org for further information.
+
+WWW: http://search.cpan.org/author/WOLF/
+Author: Andy Wolf <zonemaster@users.sourceforge.net>
diff --git a/dns/p5-DNS-Config/pkg-plist b/dns/p5-DNS-Config/pkg-plist
new file mode 100644
index 000000000000..f9faf437dddb
--- /dev/null
+++ b/dns/p5-DNS-Config/pkg-plist
@@ -0,0 +1,17 @@
+lib/perl5/site_perl/%%PERL_VER%%/mach/auto/DNS-Config/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/DNS/Config.pm
+lib/perl5/site_perl/%%PERL_VER%%/DNS/Config/Server.pm
+lib/perl5/site_perl/%%PERL_VER%%/DNS/Config/File.pm
+lib/perl5/site_perl/%%PERL_VER%%/DNS/Config/Statement.pm
+lib/perl5/site_perl/%%PERL_VER%%/DNS/Config/File/Bind9.pm
+lib/perl5/site_perl/%%PERL_VER%%/DNS/Config/File/Nsd.pm
+lib/perl5/site_perl/%%PERL_VER%%/DNS/Config/Statement/Key.pm
+lib/perl5/site_perl/%%PERL_VER%%/DNS/Config/Statement/Zone.pm
+lib/perl5/site_perl/%%PERL_VER%%/DNS/Config/Statement/Options.pm
+%%PORTDOCS%%share/doc/p5-DNS-Zone/README
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/mach/auto/DNS-Config
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/DNS/Config/File
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/DNS/Config/Statement
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/DNS/Config
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/DNS 2>/dev/null || true
+%%PORTDOCS%%@dirrm share/doc/p5-DNS-Zone