aboutsummaryrefslogtreecommitdiffstats
path: root/dns/p5-DNS-EasyDNS/Makefile
diff options
context:
space:
mode:
authoraaron <aaron@FreeBSD.org>2006-05-29 04:10:52 +0800
committeraaron <aaron@FreeBSD.org>2006-05-29 04:10:52 +0800
commit1cc8a93a3f17d46471b85112b83d0e9464d70dc5 (patch)
tree8f81151c0c3efc76b236732647ef1d335e4630da /dns/p5-DNS-EasyDNS/Makefile
parentdd6214b8e126778fb8f623e96000404a5e67fe39 (diff)
downloadfreebsd-ports-gnome-1cc8a93a3f17d46471b85112b83d0e9464d70dc5.tar.gz
freebsd-ports-gnome-1cc8a93a3f17d46471b85112b83d0e9464d70dc5.tar.zst
freebsd-ports-gnome-1cc8a93a3f17d46471b85112b83d0e9464d70dc5.zip
Adding port dns/p5-DNS-EasyDNS, Update your EasyDNS dynamic DNS entries.
Approved by: tobez (implicit)
Diffstat (limited to 'dns/p5-DNS-EasyDNS/Makefile')
-rw-r--r--dns/p5-DNS-EasyDNS/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/dns/p5-DNS-EasyDNS/Makefile b/dns/p5-DNS-EasyDNS/Makefile
new file mode 100644
index 000000000000..d101325271fc
--- /dev/null
+++ b/dns/p5-DNS-EasyDNS/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: p5-DNS-EasyDNS
+# Date created: 28 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DNS-EasyDNS
+PORTVERSION= 0.04
+CATEGORIES= dns perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= DNS
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Update your EasyDNS dynamic DNS entries
+
+BUILD_DEPENDS= ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/HTTP/Request/Common.pm:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= DNS::EasyDNS.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6 due to dependencies. Please install lang/perl5.8 and try again
+.endif
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.post.mk>