aboutsummaryrefslogtreecommitdiffstats
path: root/dns/p5-Net-DNS-SEC
diff options
context:
space:
mode:
authorleeym <leeym@FreeBSD.org>2009-05-03 04:26:11 +0800
committerleeym <leeym@FreeBSD.org>2009-05-03 04:26:11 +0800
commitc2f57e6267674de6e1882d09b32ed707aa704e8c (patch)
tree3350313b72cb876f1a647f30a2b4852cddfc358f /dns/p5-Net-DNS-SEC
parent03084d87e8a0b3bb720b5cc286384783b616ecc7 (diff)
downloadfreebsd-ports-gnome-c2f57e6267674de6e1882d09b32ed707aa704e8c.tar.gz
freebsd-ports-gnome-c2f57e6267674de6e1882d09b32ed707aa704e8c.tar.zst
freebsd-ports-gnome-c2f57e6267674de6e1882d09b32ed707aa704e8c.zip
- add missing dependency [1]
- update pkg-descr - bump PORTREVISION PR: 134154 Submitted by: Geoffrey Sisson <geoff@geoff.co.uk> and Cezary Morga <cm@therek.net>
Diffstat (limited to 'dns/p5-Net-DNS-SEC')
-rw-r--r--dns/p5-Net-DNS-SEC/Makefile27
-rw-r--r--dns/p5-Net-DNS-SEC/pkg-descr21
2 files changed, 33 insertions, 15 deletions
diff --git a/dns/p5-Net-DNS-SEC/Makefile b/dns/p5-Net-DNS-SEC/Makefile
index 8d0c6f057e9d..0d01d1af291f 100644
--- a/dns/p5-Net-DNS-SEC/Makefile
+++ b/dns/p5-Net-DNS-SEC/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Net-DNS-SEC
PORTVERSION= 0.15
+PORTREVISION= 1
CATEGORIES= dns perl5
MASTER_SITES= CPAN \
http://www.ripe.net/ripencc/pub-services/np/DISI/SRC/
@@ -15,13 +16,14 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= DNSSEC extensions to Net::DNS
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Net/DNS.pm:${PORTSDIR}/dns/p5-Net-DNS \
- ${SITE_PERL}/${PERL_ARCH}/Crypt/OpenSSL/RSA.pm:${PORTSDIR}/security/p5-Crypt-OpenSSL-RSA \
- ${SITE_PERL}/${PERL_ARCH}/Crypt/OpenSSL/DSA.pm:${PORTSDIR}/security/p5-Crypt-OpenSSL-DSA \
- ${SITE_PERL}/${PERL_ARCH}/Crypt/OpenSSL/Bignum.pm:${PORTSDIR}/security/p5-Crypt-OpenSSL-Bignum \
- ${SITE_PERL}/${PERL_ARCH}/Digest/SHA.pm:${PORTSDIR}/security/p5-Digest-SHA \
- ${SITE_PERL}/Digest/BubbleBabble.pm:${PORTSDIR}/security/p5-Digest-BubbleBabble
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS= p5-Crypt-OpenSSL-Bignum>=0.03:${PORTSDIR}/security/p5-Crypt-OpenSSL-Bignum \
+ p5-Crypt-OpenSSL-DSA>=0.1:${PORTSDIR}/security/p5-Crypt-OpenSSL-DSA \
+ p5-Crypt-OpenSSL-RSA>=0.19:${PORTSDIR}/security/p5-Crypt-OpenSSL-RSA \
+ p5-Digest-BubbleBabble>=0.01:${PORTSDIR}/security/p5-Digest-BubbleBabble \
+ p5-Digest-SHA1>=0:${PORTSDIR}/security/p5-Digest-SHA1 \
+ p5-MIME-Base32>=0:${PORTSDIR}/converters/p5-MIME-Base32 \
+ p5-Net-DNS>=0.64:${PORTSDIR}/dns/p5-Net-DNS
+BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
@@ -34,11 +36,12 @@ MAN3= Net::DNS::Keyset.3 Net::DNS::RR::DS.3 Net::DNS::RR::KEY.3 \
.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} < 500800
-BUILD_DEPENDS+= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
- ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64
-RUN_DEPENDS+= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
- ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64
+.if ${PERL_LEVEL} < 500903
+RUN_DEPENDS+= p5-Digest-SHA>=5.23:${PORTSDIR}/security/p5-Digest-SHA
+.endif
+
+.if ${PERL_LEVEL} < 500703
+RUN_DEPENDS+= p5-MIME-Base64>=0:${PORTSDIR}/converters/p5-MIME-Base64
.endif
.include <bsd.port.post.mk>
diff --git a/dns/p5-Net-DNS-SEC/pkg-descr b/dns/p5-Net-DNS-SEC/pkg-descr
index bf6b354d441d..8ecdc7d559fa 100644
--- a/dns/p5-Net-DNS-SEC/pkg-descr
+++ b/dns/p5-Net-DNS-SEC/pkg-descr
@@ -1,4 +1,19 @@
-This module implements DNSSEC (RFC 2535), SIG(0) (RFC 2931) and
-draft-ietf-dnsext-delegation-signer-07.txt.
+The Net::DSN::SEC suite provides the resource records that are needed for
+DNSSEC (RFC 4033, 4034 and 4035). In addition the DLV RR, a clone of the DS
+RR is supported (RFC 4431)
-WWW: http://www.ripe.net/disi/#NetDNS
+It also provides support for SIG0. That later is useful for dynamic updates
+using key-pairs.
+
+RSA and DSA crypto routines are supported.
+
+For details see Net::DNS::RR::RRSIG, Net::DNS::RR::DNSKEY,
+Net::DNS::RR::NSEC, Net::DNS::RR:DS, Net::DNS::RR::DLV, and see
+Net::DNS::RR::SIG and Net::DNS::RR::KEY for the use with SIG0.
+
+Net::DNS contains all needed hooks to load the Net::DNS::SEC extensions when
+they are available.
+
+See Net::DNS for general help.
+
+WWW: http://search.cpan.org/dist/Net-DNS-SEC/