aboutsummaryrefslogtreecommitdiffstats
path: root/dns/p5-pgeodns/Makefile
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2009-05-17 08:23:40 +0800
committerpgollucci <pgollucci@FreeBSD.org>2009-05-17 08:23:40 +0800
commitd44cef0adc1f63184e5c5e1038144f391868e4ee (patch)
tree7ed663f578bf0a7c1c603e44ad89116cb72af108 /dns/p5-pgeodns/Makefile
parent3ff49ddb245af849c9e5c18a87c20f26919a4a11 (diff)
downloadfreebsd-ports-gnome-d44cef0adc1f63184e5c5e1038144f391868e4ee.tar.gz
freebsd-ports-gnome-d44cef0adc1f63184e5c5e1038144f391868e4ee.tar.zst
freebsd-ports-gnome-d44cef0adc1f63184e5c5e1038144f391868e4ee.zip
pgeodns is a simple DNS server that can distribute load for a
hostname to the nearest mirrors (as defined by geography; on the country / continent level). It is used for search.cpan.org/cpansearch.perl.org and for ftp.perl.org/ftp.cpan.org; to provide nearby-ish servers for the NTP Pool; and to balance svn.apache.org to svn.us.apache.org and svn.eu.apache.org. WWW: http://geo.bitnames.com/
Diffstat (limited to 'dns/p5-pgeodns/Makefile')
-rw-r--r--dns/p5-pgeodns/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/dns/p5-pgeodns/Makefile b/dns/p5-pgeodns/Makefile
new file mode 100644
index 000000000000..786626567f6e
--- /dev/null
+++ b/dns/p5-pgeodns/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: pgeodns
+# Date created: 16 May 2009
+# Whom: Phillip M. Gollucci <pgollucci@p6m7g8.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pgeodns
+PORTVERSION= 1.32
+CATEGORIES= dns
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= pgollucci@FreeBSD.org
+COMMENT= A Geographic NameServer
+
+BUILD_DEPENDS= p5-Geo-IP>=0:${PORTSDIR}/net/p5-Geo-IP \
+ p5-JSON>=0:${PORTSDIR}/converters/p5-JSON \
+ p5-Net-DNS>=0:${PORTSDIR}/dns/p5-Net-DNS
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN1= pgeodns.pl.1
+
+.include <bsd.port.mk>