aboutsummaryrefslogtreecommitdiffstats
path: root/dns/powerdns-devel/Makefile
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2003-08-27 18:26:10 +0800
committerdinoex <dinoex@FreeBSD.org>2003-08-27 18:26:10 +0800
commit9f9c40fb6b0c3f37482217d393cbf4817e1d3b72 (patch)
tree75b35987ec3edbdf9e4e66666d8658c93473a978 /dns/powerdns-devel/Makefile
parentd8d66237810e55aebd72fa6be9083737fbe65961 (diff)
downloadfreebsd-ports-gnome-9f9c40fb6b0c3f37482217d393cbf4817e1d3b72.tar.gz
freebsd-ports-gnome-9f9c40fb6b0c3f37482217d393cbf4817e1d3b72.tar.zst
freebsd-ports-gnome-9f9c40fb6b0c3f37482217d393cbf4817e1d3b72.zip
- Update to 2.9.11
- Fixes overwrite of config file (wrong order in Makefile) PR: 55935 Submitted by: tremere@cainites.net
Diffstat (limited to 'dns/powerdns-devel/Makefile')
-rw-r--r--dns/powerdns-devel/Makefile34
1 files changed, 17 insertions, 17 deletions
diff --git a/dns/powerdns-devel/Makefile b/dns/powerdns-devel/Makefile
index ee7704e780bd..5515bf40ac8c 100644
--- a/dns/powerdns-devel/Makefile
+++ b/dns/powerdns-devel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= powerdns
-PORTVERSION= 2.9.10
+PORTVERSION= 2.9.11
CATEGORIES= net ipv6
MASTER_SITES= http://downloads.powerdns.com/releases/
DISTNAME= pdns-${PORTVERSION}
@@ -62,17 +62,6 @@ MAN8= pdns_control.8 pdns_server.8 zone2sql.8
pre-everything::
@ ${SETENV} ${SCRIPTS_ENV} ${SH} ${FILESDIR}/configure.powerdns
-post-install:
-.if !exists(${PREFIX}/etc/pdns.conf)
- ${INSTALL_DATA} ${PREFIX}/etc/pdns.conf-dist ${PREFIX}/etc/pdns.conf
-.endif
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${EXAMPLESDIR}
-.for i in pdns.conf pdns_mysql.sql pdns_postgresql.sql
- ${INSTALL_DATA} ${FILESDIR}/$i ${EXAMPLESDIR}/
-.endfor
-.endif
-
post-clean:
@ ${RM} -f ${WRKDIRPREFIX}${.CURDIR}/Makefile.inc
@@ -86,6 +75,13 @@ describe:
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 500000 && defined(POWERDNS_WITH_RECURSOR)
+CONFIGURE_ARGS+= --enable-recursor
+PLIST_SUB+= RECURSOR=""
+.else
+PLIST_SUB+= RECURSOR="@comment "
+.endif
+
.if ${OSVERSION} >= 500043 && defined(WITH_LDAP)
LIB_DEPENDS+= ldap.2:${PORTSDIR}/${LDAP_PORT}
LIB_DEPENDS+= lber.2:${PORTSDIR}/${LDAP_PORT}
@@ -100,11 +96,15 @@ post-patch:
${WRKSRC}/pdns/Makefile.in
.endif
-.if ${OSVERSION} >= 500000 && defined(POWERDNS_WITH_RECURSOR)
-CONFIGURE_ARGS+= --enable-recursor
-PLIST_SUB+= RECURSOR=""
-.else
-PLIST_SUB+= RECURSOR="@comment "
+post-install:
+.if !exists(${PREFIX}/etc/pdns.conf)
+ ${INSTALL_DATA} ${PREFIX}/etc/pdns.conf-dist ${PREFIX}/etc/pdns.conf
+.endif
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${EXAMPLESDIR}
+.for i in pdns.conf pdns_mysql.sql pdns_postgresql.sql
+ ${INSTALL_DATA} ${FILESDIR}/$i ${EXAMPLESDIR}/
+.endfor
.endif
.include <bsd.port.post.mk>