aboutsummaryrefslogtreecommitdiffstats
path: root/dns/powerdns-devel/Makefile
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2003-03-23 12:53:39 +0800
committerdinoex <dinoex@FreeBSD.org>2003-03-23 12:53:39 +0800
commitc1af577b0c46aa2311035aeb8619707703b31f32 (patch)
tree9c346e26a973c119dd56d54652218abc8b9b8d4a /dns/powerdns-devel/Makefile
parentbcbcfa62ae7a97c42d1d9bb7880348d6971c4bbc (diff)
downloadfreebsd-ports-gnome-c1af577b0c46aa2311035aeb8619707703b31f32.tar.gz
freebsd-ports-gnome-c1af577b0c46aa2311035aeb8619707703b31f32.tar.zst
freebsd-ports-gnome-c1af577b0c46aa2311035aeb8619707703b31f32.zip
- Update to 2.9.6
- make ports work as a master port - add support for LDAP, submitted by richard@unixguru.nl - add build for recursor
Diffstat (limited to 'dns/powerdns-devel/Makefile')
-rw-r--r--dns/powerdns-devel/Makefile31
1 files changed, 28 insertions, 3 deletions
diff --git a/dns/powerdns-devel/Makefile b/dns/powerdns-devel/Makefile
index f6ac5e578899..7f0e688d97b6 100644
--- a/dns/powerdns-devel/Makefile
+++ b/dns/powerdns-devel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= powerdns
-PORTVERSION= 2.9.4
+PORTVERSION= 2.9.6
CATEGORIES= net ipv6
MASTER_SITES= http://downloads.powerdns.com/releases/
DISTNAME= pdns-${PORTVERSION}
@@ -16,6 +16,7 @@ COMMENT= An advanced DNS server with SQL backend
USE_GMAKE= YES
USE_SUBMAKE= YES
+USE_REINPLACE= YES
GNU_CONFIGURE= YES
CONFIGURE_ARGS+= --with-modules="${CONFIGURE_MODULES} pipe" \
--with-dynmodules=""
@@ -50,7 +51,7 @@ CONFIGURE_ARGS+= --disable-mysql
.endif
SCRIPTS_ENV= WRKDIRPREFIX="${WRKDIRPREFIX}" \
- CURDIR="${.CURDIR}" \
+ CURDIR2="${.CURDIR}" \
MKDIR="${MKDIR}" \
DISTNAME="${DISTNAME}" \
POWERDNS_OPTIONS="${POWERDNS_OPTIONS}"
@@ -60,6 +61,14 @@ MAN8= pdns_control.8 pdns_server.8 zone2sql.8
pre-everything::
@ ${SETENV} ${SCRIPTS_ENV} ${SH} ${FILESDIR}/configure.powerdns
+post-patch:
+ ${REINPLACE_CMD} -e 's;-I. ;-I. -I${LOCALBASE}/include ;' \
+ -e 's;la_LDFLAGS =;la_LDFLAGS = -L${LOCALBASE}/lib;' \
+ ${WRKSRC}/modules/ldapbackend/Makefile.in
+ ${REINPLACE_CMD} -e 's;@LIBDL@;@LIBDL@ -L${LOCALBASE}/lib;' \
+ -e 's;@modulelibs@;@modulelibs@ -llber;' \
+ ${WRKSRC}/pdns/Makefile.in
+
post-install:
.if !exists(${PREFIX}/etc/pdns.conf)
${INSTALL_DATA} ${PREFIX}/etc/pdns.conf-dist ${PREFIX}/etc/pdns.conf
@@ -82,4 +91,20 @@ describe:
@cd ${.CURDIR} && ${MAKE} ${__softMAKEFLAGS} BATCH=yes ${.TARGET}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500043
+CONFIGURE_ARGS+= --enable-recursor
+PLIST_SUB+= RECURSOR=""
+
+.if defined(WITH_LDAP)
+LIB_DEPENDS+= ldap.2:${PORTSDIR}/net/openldap20
+LIB_DEPENDS+= lber.2:${PORTSDIR}/net/openldap20
+CONFIGURE_MODULES+= "ldap"
+.endif
+
+.else
+PLIST_SUB+= RECURSOR="@comment "
+.endif
+
+.include <bsd.port.post.mk>