aboutsummaryrefslogtreecommitdiffstats
path: root/dns/py-adns/Makefile
diff options
context:
space:
mode:
authorperky <perky@FreeBSD.org>2002-06-26 03:19:54 +0800
committerperky <perky@FreeBSD.org>2002-06-26 03:19:54 +0800
commit45c4096ac3bafb84ac0896e90df7400532506572 (patch)
tree8f74e293967a39b9668314105c9c506695ed6145 /dns/py-adns/Makefile
parent2b80a3a05aa67894c356407e1b02c9be1537834d (diff)
downloadfreebsd-ports-gnome-45c4096ac3bafb84ac0896e90df7400532506572.tar.gz
freebsd-ports-gnome-45c4096ac3bafb84ac0896e90df7400532506572.tar.zst
freebsd-ports-gnome-45c4096ac3bafb84ac0896e90df7400532506572.zip
Use REINPLACE_CMD as well as USE_REINPLACE
Diffstat (limited to 'dns/py-adns/Makefile')
-rw-r--r--dns/py-adns/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/dns/py-adns/Makefile b/dns/py-adns/Makefile
index 795a7fcb628f..242602098e3c 100644
--- a/dns/py-adns/Makefile
+++ b/dns/py-adns/Makefile
@@ -18,11 +18,12 @@ LIB_DEPENDS= adns.1:${PORTSDIR}/net/adns
USE_PYTHON= yes
USE_PYDISTUTILS= yes
+USE_REINPLACE= yes
PLIST_SUB+= PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR:S/^${LOCALBASE}\///g}
post-patch:
- @${PERL} -pi -e 's|^(include_dirs = ).*$$|\1\["${LOCALBASE}/include"\]|g; \
- s|^(library_dirs = ).*$$|\1\["${LOCALBASE}/lib"\]|g' \
+ @${REINPLACE_CMD} -e 's|^\(include_dirs = \).*$$|\1\["${LOCALBASE}/include"\]|g' \
+ -e 's|^\(library_dirs = \).*$$|\1\["${LOCALBASE}/lib"\]|g' \
${WRKSRC}/setup.py
.include <bsd.port.mk>