aboutsummaryrefslogtreecommitdiffstats
path: root/dns/py-pywdns
diff options
context:
space:
mode:
authortruckman <truckman@FreeBSD.org>2015-04-03 07:40:29 +0800
committertruckman <truckman@FreeBSD.org>2015-04-03 07:40:29 +0800
commit1f011bfc687d80531f0e4217f79a0ced2a1ac112 (patch)
tree4fa702cf4896830186bc5fc7e2d145023fd25e36 /dns/py-pywdns
parentd244a41086d6b02e180f7d66b91e41b0226ee39c (diff)
downloadfreebsd-ports-gnome-1f011bfc687d80531f0e4217f79a0ced2a1ac112.tar.gz
freebsd-ports-gnome-1f011bfc687d80531f0e4217f79a0ced2a1ac112.tar.zst
freebsd-ports-gnome-1f011bfc687d80531f0e4217f79a0ced2a1ac112.zip
Add new port dns/py-pywdns.
This is pywdns, a Python extension module implemented in Cython for the wdns C library. Differential Revision: https://reviews.freebsd.org/D2200 Approved by: mat (mentor) Sponsored by: Farsight Security, Inc.
Diffstat (limited to 'dns/py-pywdns')
-rw-r--r--dns/py-pywdns/Makefile27
-rw-r--r--dns/py-pywdns/distinfo2
-rw-r--r--dns/py-pywdns/pkg-descr5
3 files changed, 34 insertions, 0 deletions
diff --git a/dns/py-pywdns/Makefile b/dns/py-pywdns/Makefile
new file mode 100644
index 000000000000..bd97a52e1f3e
--- /dev/null
+++ b/dns/py-pywdns/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= pywdns
+PORTVERSION= 0.6.0
+CATEGORIES= dns python
+MASTER_SITES= FARSIGHT LOCAL/truckman/farsight
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= truckman@FreeBSD.org
+COMMENT= Python wrapper for dns/wdns
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/COPYRIGHT
+
+LIB_DEPENDS= libwdns.so:${PORTSDIR}/dns/wdns
+
+USE_PYTHON= distutils autoplist
+
+USES= pkgconfig python
+
+post-patch:
+ ${REINPLACE_CMD} -e "1s+ python+ ${PYTHON_CMD}+" ${WRKSRC}/gen_pywdns_constants
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}/${PREFIX}/lib/python2.7/site-packages/wdns.so
+
+.include <bsd.port.mk>
diff --git a/dns/py-pywdns/distinfo b/dns/py-pywdns/distinfo
new file mode 100644
index 000000000000..adab2c9d0f9d
--- /dev/null
+++ b/dns/py-pywdns/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pywdns-0.6.0.tar.gz) = 3e0d7b520793835c1be34a679bbbb5cefdfc28d6ef9b6e2759e175d0571e405d
+SIZE (pywdns-0.6.0.tar.gz) = 60166
diff --git a/dns/py-pywdns/pkg-descr b/dns/py-pywdns/pkg-descr
new file mode 100644
index 000000000000..21f60946b673
--- /dev/null
+++ b/dns/py-pywdns/pkg-descr
@@ -0,0 +1,5 @@
+This is pywdns, a Python extension module implemented in Cython for
+the wdns C library.
+
+
+WWW: https://github.com/farsightsec/pywdns