aboutsummaryrefslogtreecommitdiffstats
path: root/dns/sleuth/Makefile
diff options
context:
space:
mode:
authormarkp <markp@FreeBSD.org>2001-06-15 20:46:45 +0800
committermarkp <markp@FreeBSD.org>2001-06-15 20:46:45 +0800
commitabc46811e1aba64551ecf661cc2cadbbcac3ff00 (patch)
tree677be1cdbaed5cf5c406cd5bcaf2d9c1fcc8227d /dns/sleuth/Makefile
parenta7f0a5a04efeadae90a5165233dfd5debd2ed572 (diff)
downloadfreebsd-ports-gnome-abc46811e1aba64551ecf661cc2cadbbcac3ff00.tar.gz
freebsd-ports-gnome-abc46811e1aba64551ecf661cc2cadbbcac3ff00.tar.zst
freebsd-ports-gnome-abc46811e1aba64551ecf661cc2cadbbcac3ff00.zip
Add sleuth 1.2, a tool for checking DNS zones.
Diffstat (limited to 'dns/sleuth/Makefile')
-rw-r--r--dns/sleuth/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/dns/sleuth/Makefile b/dns/sleuth/Makefile
new file mode 100644
index 000000000000..285126aada1f
--- /dev/null
+++ b/dns/sleuth/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: sleuth
+# Date created: Jun 15, 2001
+# Whom: Mark Pulford <mark@kyne.com.au>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sleuth
+PORTVERSION= 1.2
+CATEGORIES= net
+MASTER_SITES= ftp://atrey.karlin.mff.cuni.cz/pub/local/mj/net/
+
+MAINTAINER= markp@FreeBSD.org
+
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Net/DNS.pm:${PORTSDIR}/net/p5-Net-DNS
+
+USE_PERL5= yes
+
+post-patch:
+ ${PERL} -pi -e "s|/etc/sleuth.conf|${PREFIX}/etc/sleuth.conf|g; \
+ s|#!/usr/bin/perl|#!${PERL}|g;" ${WRKSRC}/sleuth
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/sleuth ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/sleuth.conf ${PREFIX}/etc/sleuth.conf.sample
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>