aboutsummaryrefslogtreecommitdiffstats
path: root/dns/unbound
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-07-24 21:32:58 +0800
committerbapt <bapt@FreeBSD.org>2014-07-24 21:32:58 +0800
commita8844613fabe6f02880be5a2bbab4d9af2853c2d (patch)
treeffddb673c48038e781d69f6c3d08ec8855ad33a5 /dns/unbound
parent12f33c255d02d5e8b350ff2daf6aa8ed112b6508 (diff)
downloadfreebsd-ports-gnome-a8844613fabe6f02880be5a2bbab4d9af2853c2d.tar.gz
freebsd-ports-gnome-a8844613fabe6f02880be5a2bbab4d9af2853c2d.tar.zst
freebsd-ports-gnome-a8844613fabe6f02880be5a2bbab4d9af2853c2d.zip
Only use libevent2
Remove libevent as libevent2 is providing a good compatibility interface as well as providing better performances. Remove custom patches from libevent2 and install libevent2 the regular way Mark ports abusing private fields of the libevent1 API as broken Import a patch from fedora to have honeyd working with libevent2 Remove most of the patches necessary to find the custom installation we used to have for libevent2 With hat: portmgr
Diffstat (limited to 'dns/unbound')
-rw-r--r--dns/unbound/Makefile18
1 files changed, 5 insertions, 13 deletions
diff --git a/dns/unbound/Makefile b/dns/unbound/Makefile
index 309bd89f40a2..7878bc94188a 100644
--- a/dns/unbound/Makefile
+++ b/dns/unbound/Makefile
@@ -29,15 +29,11 @@ PORTDOCS= CREDITS Changelog FEATURES LICENSE README README.svn \
ietf67-design-02.pdf requirements.txt
PLIST_SUB+= PYTHON=${PYTHON} MUNIN=${MUNIN}
-OPTIONS_DEFINE= THREADS PYTHON GOST ECDSA MUNIN DOCS
+OPTIONS_DEFINE= THREADS PYTHON GOST ECDSA MUNIN DOCS LIBEVENT
OPTIONS_DEFAULT=THREADS ECDSA
-OPTIONS_RADIO= LIBEVENT
-OPTIONS_RADIO_LIBEVENT= LIBEVENT14 LIBEVENT20
-LIBEVENT_DESC= Enable whenever using many (10000) outgoing ports
-LIBEVENT14_DESC=Build against libevent-1.4 (devel/libevent)
-LIBEVENT20_DESC=Build against libevent-2.0 (devel/libevent2)
+LIBEVENT_DESC= Build against libevent (devel/libevent2)
GOST_DESC= Enable GOST support (requires OpenSSL >= 1.0)
ECDSA_DESC= Enable ECDSA (elliptic curve) support (OpenSSL >= 1.0)
MUNIN_DESC= Install Munin plugin
@@ -83,14 +79,10 @@ MUNIN=
MUNIN= "@comment "
.endif
-.if ${PORT_OPTIONS:MLIBEVENT14}
-LIB_DEPENDS+= libevent-1.4.so:${PORTSDIR}/devel/libevent
-CONFIGURE_ARGS+=--with-libevent=${LOCALBASE}
-.elif ${PORT_OPTIONS:MLIBEVENT20}
-LIB_DEPENDS+= libevent-2.0.so:${PORTSDIR}/devel/libevent2
+.if ${PORT_OPTIONS:MLIBEVENT}
+LIB_DEPENDS+= libevent.so:${PORTSDIR}/devel/libevent2
USES+= pkgconfig
-CONFIGURE_ARGS+=--with-libevent=${NONEXISTENT}
-CONFIGURE_ENV+= found_libevent=yes
+CONFIGURE_ARGS+=--with-libevent
CPPFLAGS+= $$(pkg-config libevent --cflags-only-I)
LDFLAGS+= $$(pkg-config libevent --libs-only-L)
.else