aboutsummaryrefslogtreecommitdiffstats
path: root/dns/vizone
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2007-08-14 05:37:31 +0800
committerehaupt <ehaupt@FreeBSD.org>2007-08-14 05:37:31 +0800
commit75ccc83362786cf4454ef29df8e65e1cc00944fb (patch)
treed3265c65d0939f3072e324bc77ccd0027e8714c2 /dns/vizone
parentb1c32ca2b675bd6aba9e7fd59b529f1f524f32f4 (diff)
downloadfreebsd-ports-gnome-75ccc83362786cf4454ef29df8e65e1cc00944fb.tar.gz
freebsd-ports-gnome-75ccc83362786cf4454ef29df8e65e1cc00944fb.tar.zst
freebsd-ports-gnome-75ccc83362786cf4454ef29df8e65e1cc00944fb.zip
Add vizone, a script that updates the serialnumber in one or more dns zonefiles.
Diffstat (limited to 'dns/vizone')
-rw-r--r--dns/vizone/Makefile35
-rw-r--r--dns/vizone/distinfo3
-rw-r--r--dns/vizone/pkg-descr4
3 files changed, 42 insertions, 0 deletions
diff --git a/dns/vizone/Makefile b/dns/vizone/Makefile
new file mode 100644
index 000000000000..764ee7ec75aa
--- /dev/null
+++ b/dns/vizone/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: vizone
+# Date created: 13 Aug 2007
+# Whom: Emanuel Haupt <ehaupt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= vizone
+PORTVERSION= 0.1
+CATEGORIES= dns
+MASTER_SITES= http://critical.ch/distfiles/ \
+ http://energy.critical.ch/distfiles/
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= Updates the serialnumber in one or more zonefiles
+
+USE_PERL5_RUN= yes
+NO_BUILD= yes
+
+PORTEXAMPLES= example.tld
+PLIST_FILES= bin/vizone bin/updserial
+
+post-patch:
+ @${REINPLACE_CMD} -e '1s|.*|#!${PERL}|' ${WRKSRC}/updserial
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/updserial ${PREFIX}/bin
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/example.tld ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/dns/vizone/distinfo b/dns/vizone/distinfo
new file mode 100644
index 000000000000..ec97b90727cb
--- /dev/null
+++ b/dns/vizone/distinfo
@@ -0,0 +1,3 @@
+MD5 (vizone-0.1.tar.gz) = 152d5d8732ed77d7c0e1eef90dc2c97d
+SHA256 (vizone-0.1.tar.gz) = bec9e3b986fbcf6ad2148ab6bf1791907a8b318ccfa983377afc626cce68517b
+SIZE (vizone-0.1.tar.gz) = 1583
diff --git a/dns/vizone/pkg-descr b/dns/vizone/pkg-descr
new file mode 100644
index 000000000000..058ffb02406c
--- /dev/null
+++ b/dns/vizone/pkg-descr
@@ -0,0 +1,4 @@
+A script that tries to update the serial inside a DNS zonefile with sane values
+if the file has changed during edit.
+
+WWW: http://www.netswarm.net/