aboutsummaryrefslogtreecommitdiffstats
path: root/dns/walker
diff options
context:
space:
mode:
authorjohans <johans@FreeBSD.org>2013-12-29 17:06:42 +0800
committerjohans <johans@FreeBSD.org>2013-12-29 17:06:42 +0800
commit8d6885734052212484a471c1ca363d670f07aab9 (patch)
tree9a0028c19d1927c7693edde7bd81677076ea806b /dns/walker
parent3e5a58f11c518f02e50f3296911d108191fd8107 (diff)
downloadfreebsd-ports-gnome-8d6885734052212484a471c1ca363d670f07aab9.tar.gz
freebsd-ports-gnome-8d6885734052212484a471c1ca363d670f07aab9.tar.zst
freebsd-ports-gnome-8d6885734052212484a471c1ca363d670f07aab9.zip
- Fix perl shebang path
- Enable stage support - Bump PORTREVISION
Diffstat (limited to 'dns/walker')
-rw-r--r--dns/walker/Makefile22
1 files changed, 12 insertions, 10 deletions
diff --git a/dns/walker/Makefile b/dns/walker/Makefile
index e1445f21f3aa..8dcea7b4e8d5 100644
--- a/dns/walker/Makefile
+++ b/dns/walker/Makefile
@@ -3,8 +3,9 @@
PORTNAME= walker
PORTVERSION= 3.8
+PORTREVISION= 1
CATEGORIES= dns
-MASTER_SITES= http://josefsson.org/${PORTNAME}/releases/
+MASTER_SITES= http://josefsson.org/walker/releases/
MAINTAINER= johans@FreeBSD.org
COMMENT= Recover zone file information from servers that use DNSSEC
@@ -12,20 +13,21 @@ COMMENT= Recover zone file information from servers that use DNSSEC
RUN_DEPENDS= p5-Net-DNS>=0:${PORTSDIR}/dns/p5-Net-DNS \
p5-Net-DNS-SEC>=0:${PORTSDIR}/dns/p5-Net-DNS-SEC
-USES= perl5
+USES= perl5 shebangfix
+SHEBANG_FILES= walker
NO_BUILD= yes
-MAN1= walker.1
-PLIST_FILES= bin/walker
+PLIST_FILES= bin/walker man/man1/walker.1.gz
PORTDOCS= index.html
-NO_STAGE= yes
+.include <bsd.port.options.mk>
+
do-install:
- @${INSTALL_SCRIPT} ${WRKSRC}/walker ${PREFIX}/bin
- @${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MAN1PREFIX}/man/man1
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/index.html ${DOCSDIR}
+ @${INSTALL_SCRIPT} ${WRKSRC}/walker ${STAGEDIR}${PREFIX}/bin
+ @${INSTALL_MAN} ${WRKSRC}/walker.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/index.html ${STAGEDIR}${DOCSDIR}
.endif
.include <bsd.port.mk>