aboutsummaryrefslogtreecommitdiffstats
path: root/dns/wrapsrv
diff options
context:
space:
mode:
authortruckman <truckman@FreeBSD.org>2015-01-12 04:44:39 +0800
committertruckman <truckman@FreeBSD.org>2015-01-12 04:44:39 +0800
commited5840b232f5ead6bd0822b11a2a8d04f7b44a2e (patch)
tree385f0ac53f71bee1ddc8c629acb9dc7b74b21179 /dns/wrapsrv
parentb4f04bcd66cf44db561bac109b03847bd5b941b9 (diff)
downloadfreebsd-ports-gnome-ed5840b232f5ead6bd0822b11a2a8d04f7b44a2e.tar.gz
freebsd-ports-gnome-ed5840b232f5ead6bd0822b11a2a8d04f7b44a2e.tar.zst
freebsd-ports-gnome-ed5840b232f5ead6bd0822b11a2a8d04f7b44a2e.zip
New port: dns/wrapsrv
DNS SRV record command line wrapper ----------------------------------- wrapsrv adds support for connecting to a network service based on DNS SRV record lookups to commands that do not support the DNS SRV record. wrapsrv implements the weighted priority client connection algorithm in RFC 2782. The specified command line will be invoked one or more times with %h and %p sequences in the command line substituted for the hostname and port elements of the selected SRV record. WWW: https://github.com/farsightsec/wrapsrv Differential Revision: https://reviews.freebsd.org/D1488 Approved by: mat (mentor) Sponsored by: Farsight Security, Inc.
Diffstat (limited to 'dns/wrapsrv')
-rw-r--r--dns/wrapsrv/Makefile21
-rw-r--r--dns/wrapsrv/distinfo2
-rw-r--r--dns/wrapsrv/files/patch-Makefile33
-rw-r--r--dns/wrapsrv/pkg-descr11
4 files changed, 67 insertions, 0 deletions
diff --git a/dns/wrapsrv/Makefile b/dns/wrapsrv/Makefile
new file mode 100644
index 000000000000..d15202818ec4
--- /dev/null
+++ b/dns/wrapsrv/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= wrapsrv
+PORTVERSION= 1.0.0
+CATEGORIES= dns
+MASTER_SITES= https://dl.farsightsecurity.com/dist/wrapsrv/ \
+ LOCAL/truckman/farsight
+
+MAINTAINER= truckman@FreeBSD.org
+COMMENT= DNS SRV record command line wrapper
+
+LICENSE= APACHE20
+
+BUILD_DEPENDS= docbook2mdoc:${PORTSDIR}/textproc/docbook2mdoc
+
+PLIST_FILES= bin/wrapsrv man/man1/wrapsrv.1.gz
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/wrapsrv
+
+.include <bsd.port.mk>
diff --git a/dns/wrapsrv/distinfo b/dns/wrapsrv/distinfo
new file mode 100644
index 000000000000..edb314b873b2
--- /dev/null
+++ b/dns/wrapsrv/distinfo
@@ -0,0 +1,2 @@
+SHA256 (wrapsrv-1.0.0.tar.gz) = 7d0c20540388dd467d7a596a74657eca3795cc0f065aa7f49024afa7e1e598d0
+SIZE (wrapsrv-1.0.0.tar.gz) = 9347
diff --git a/dns/wrapsrv/files/patch-Makefile b/dns/wrapsrv/files/patch-Makefile
new file mode 100644
index 000000000000..df5b30399864
--- /dev/null
+++ b/dns/wrapsrv/files/patch-Makefile
@@ -0,0 +1,33 @@
+--- Makefile.orig 2014-07-30 21:21:46 UTC
++++ Makefile
+@@ -1,25 +1,22 @@
+-CC = gcc
+-WARN = -Wall -Wextra -Werror
+-CFLAGS = -O2 -g $(WARN)
+ INCLUDE =
+-LDFLAGS = -lresolv
++LDFLAGS =
+ DESTDIR ?=
+-PREFIX = /usr/local
++PREFIX ?= /usr/local
+
+ BINDIR ?= $(DESTDIR)$(PREFIX)/bin
+-MANDIR ?= $(DESTDIR)$(PREFIX)/share/man/man1
++MANDIR ?= $(DESTDIR)$(PREFIX)/man/man1
+
+ BIN = wrapsrv
+ MAN = wrapsrv.1
+ SRC = wrapsrv.c
+
+-all: $(BIN) $(DOC)
++all: $(BIN) $(MAN)
+
+ $(BIN): $(SRC)
+ $(CC) $(CFLAGS) -o $@ $(SRC) $(INCLUDE) $(LDFLAGS)
+
+ $(MAN): wrapsrv.docbook
+- docbook2x-man $<
++ docbook2mdoc $< > $@
+
+ clean:
+ rm -f $(BIN)
diff --git a/dns/wrapsrv/pkg-descr b/dns/wrapsrv/pkg-descr
new file mode 100644
index 000000000000..62272c186129
--- /dev/null
+++ b/dns/wrapsrv/pkg-descr
@@ -0,0 +1,11 @@
+DNS SRV record command line wrapper
+-----------------------------------
+
+wrapsrv adds support for connecting to a network service based on DNS SRV
+record lookups to commands that do not support the DNS SRV record. wrapsrv
+implements the weighted priority client connection algorithm in RFC 2782.
+The specified command line will be invoked one or more times with %h and %p
+sequences in the command line substituted for the hostname and port elements
+of the selected SRV record.
+
+WWW: https://github.com/farsightsec/wrapsrv