aboutsummaryrefslogtreecommitdiffstats
path: root/dns/zonenotify
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2005-10-16 16:42:05 +0800
committerehaupt <ehaupt@FreeBSD.org>2005-10-16 16:42:05 +0800
commite70075ffec07e872252fde29afcf0321af6f1392 (patch)
tree8fdcd1547d0216e1e5b55d9724fa5c9620f70f9b /dns/zonenotify
parent0f058ea63bb08e9e6a2530eb38e49d304c2dfca9 (diff)
downloadfreebsd-ports-gnome-e70075ffec07e872252fde29afcf0321af6f1392.tar.gz
freebsd-ports-gnome-e70075ffec07e872252fde29afcf0321af6f1392.tar.zst
freebsd-ports-gnome-e70075ffec07e872252fde29afcf0321af6f1392.zip
Make port respect PREFIX.
Submitted by: pointyhat via kris Approved by: novel (mentor) (implicit)
Diffstat (limited to 'dns/zonenotify')
-rw-r--r--dns/zonenotify/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/dns/zonenotify/Makefile b/dns/zonenotify/Makefile
index 3e106d2a646d..e5c8a484f8ba 100644
--- a/dns/zonenotify/Makefile
+++ b/dns/zonenotify/Makefile
@@ -14,9 +14,15 @@ MASTER_SITES= http://morettoni.net/bsd/ \
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= A dns notify sender written in C
+USE_REINPLACE= yes
+
PLIST_FILES= bin/zonenotify
WRKSRC= ${WRKDIR}/${PORTNAME}
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|' \
+ ${WRKSRC}/Makefile
+
do-build:
${CC} -o ${WRKSRC}/${PORTNAME} ${CFLAGS} ${WRKSRC}/zonenotify.c