aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authorriggs <riggs@FreeBSD.org>2016-11-29 19:00:35 +0800
committerriggs <riggs@FreeBSD.org>2016-11-29 19:00:35 +0800
commitea0727b899459dc34aa88d49f7010cba3fdc121c (patch)
tree5613c6b0425ab6e6272c82fe42e8e9248e199582 /dns
parent7c87dc76e78d82a16a58f5d110973781c5d2ac17 (diff)
downloadfreebsd-ports-gnome-ea0727b899459dc34aa88d49f7010cba3fdc121c.tar.gz
freebsd-ports-gnome-ea0727b899459dc34aa88d49f7010cba3fdc121c.tar.zst
freebsd-ports-gnome-ea0727b899459dc34aa88d49f7010cba3fdc121c.zip
Fix build on FreeBSD 9.3
PR: 214816 Submitted by: tremere@cainites.net (maintainer) MFH: 2016Q4
Diffstat (limited to 'dns')
-rw-r--r--dns/powerdns-recursor/Makefile17
1 files changed, 14 insertions, 3 deletions
diff --git a/dns/powerdns-recursor/Makefile b/dns/powerdns-recursor/Makefile
index 103d71fc8368..5a26743b298f 100644
--- a/dns/powerdns-recursor/Makefile
+++ b/dns/powerdns-recursor/Makefile
@@ -18,10 +18,10 @@ BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:devel/boost-libs
LIB_DEPENDS= libboost_context.so:devel/boost-libs
BROKEN_sparc64= Does not compile on sparc64
-BROKEN_FreeBSD_9= linker error
-USES= compiler:c++11-lib cpe gmake pkgconfig ssl tar:bzip2
+USES= compiler:c++11-lib cpe gmake localbase pkgconfig ssl tar:bzip2
GNU_CONFIGURE= YES
+CXXFLAGS+= -D_GLIBCXX_USE_C99
CPE_VENDOR= powerdns
@@ -54,4 +54,15 @@ USERS= pdns_recursor
GROUPS= pdns
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${SSL_DEFAULT} == base
+BROKEN_FreeBSD_9= FreeBSD 9.x requires SSL from ports
+.endif
+
+.if ${OSVERSION} < 1000000 && ${ARCH} == i386
+#BUILD_DEPENDS= ${LOCALBASE}/lib/libatomic_ops.a:devel/libatomic_ops
+LDFLAGS+= -latomic
+.endif
+
+.include <bsd.port.post.mk>