aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>2005-04-11 16:04:41 +0800
committerobrien <obrien@FreeBSD.org>2005-04-11 16:04:41 +0800
commit6b02d1b35c173832c085697cf76aa156d04ad843 (patch)
tree195cb55f1eda849521409154920849cf102b91fa /dns
parent93ea51bfc3219265c52c39374430d10201b8f436 (diff)
downloadfreebsd-ports-gnome-6b02d1b35c173832c085697cf76aa156d04ad843.tar.gz
freebsd-ports-gnome-6b02d1b35c173832c085697cf76aa156d04ad843.tar.zst
freebsd-ports-gnome-6b02d1b35c173832c085697cf76aa156d04ad843.zip
Assist getting more ports working on AMD64 by obeying the
Ports Collection documentation and use 'ARCH' rather than 'MACHINE_ARCH'.
Diffstat (limited to 'dns')
-rw-r--r--dns/dnrd/Makefile2
-rw-r--r--dns/nsd/Makefile2
-rw-r--r--dns/posadis/Makefile2
-rw-r--r--dns/updatedd/Makefile2
4 files changed, 4 insertions, 4 deletions
diff --git a/dns/dnrd/Makefile b/dns/dnrd/Makefile
index 4576bd595125..8863ca3003a8 100644
--- a/dns/dnrd/Makefile
+++ b/dns/dnrd/Makefile
@@ -18,7 +18,7 @@ USE_GMAKE= yes
USE_REINPLACE= yes
USE_RC_SUBR= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= PTHREAD_CFLAGS=${PTHREAD_CFLAGS} PTHREAD_LIBS=${PTHREAD_LIBS}
.if defined(WITH_TCP)
diff --git a/dns/nsd/Makefile b/dns/nsd/Makefile
index ee191c80b20a..4ff12f8d9fb3 100644
--- a/dns/nsd/Makefile
+++ b/dns/nsd/Makefile
@@ -33,7 +33,7 @@ CONFIGURE_ARGS= --with-user=${NSDUSER} \
--with-pidfile=/var/run/nsd.pid \
--with-dbfile=${NSDDBFILE} \
--with-libwrap
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
SED_SCRIPT= -e 's,%%NSDUSER%%,${NSDUSER},g' \
-e 's,%%NSDDIR%%,${NSDDIR},g' \
diff --git a/dns/posadis/Makefile b/dns/posadis/Makefile
index bcd290a24dbf..1ff4a42fe287 100644
--- a/dns/posadis/Makefile
+++ b/dns/posadis/Makefile
@@ -21,7 +21,7 @@ USE_AUTOCONF_VER= 259
USE_LIBTOOL_VER= 15
USE_LIBLTDL= yes
INSTALLS_SHLIB= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
.if defined(WITH_FAM) || exists(${LOCALBASE}/lib/libfam.so)
diff --git a/dns/updatedd/Makefile b/dns/updatedd/Makefile
index b2b1ff2d1288..fd2eef31fa41 100644
--- a/dns/updatedd/Makefile
+++ b/dns/updatedd/Makefile
@@ -18,7 +18,7 @@ COMMENT= Dynamic DNS Update Client supporting multiple services
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
LIBDIR= ${PREFIX}/lib/${PORTNAME}