aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2010-06-27 09:21:47 +0800
committerwen <wen@FreeBSD.org>2010-06-27 09:21:47 +0800
commit9547d430d264c6332c931da96132f40f4cd5a521 (patch)
tree3773222cb7a91f7d961f433b9fcbf4504b2032df /dns
parent5758ffdf4989f33c9edbdba0a20da2a243504b78 (diff)
downloadfreebsd-ports-gnome-9547d430d264c6332c931da96132f40f4cd5a521.tar.gz
freebsd-ports-gnome-9547d430d264c6332c931da96132f40f4cd5a521.tar.zst
freebsd-ports-gnome-9547d430d264c6332c931da96132f40f4cd5a521.zip
Class to setup a number of nameservers that respond to specific DNS queries
(QNAME,QTYPE) by prespecified answers. This class is to be used in test suites where you want to have servers to show predefined behavior. If the server will do a lookup based on QNAME,QTYPE and return the specified data. If there is no QNAME, QTYPE match the server will return a SERVFAIL. A log will be written to STDERR it contains time, IP/PORT, QNAME, QTYPE, RCODE. WWW: http://search.cpan.org/dist/Net-DNS-TestNS/ PR: ports/148161 Submitted by: Sunpoet Po-Chuan Hsieh <sunpoet@sunpoet.net> Feature safe: yes
Diffstat (limited to 'dns')
-rw-r--r--dns/Makefile1
-rw-r--r--dns/p5-Net-DNS-TestNS/Makefile25
-rw-r--r--dns/p5-Net-DNS-TestNS/distinfo3
-rw-r--r--dns/p5-Net-DNS-TestNS/pkg-descr10
-rw-r--r--dns/p5-Net-DNS-TestNS/pkg-plist9
5 files changed, 48 insertions, 0 deletions
diff --git a/dns/Makefile b/dns/Makefile
index fc01f9c2dccc..81bd36562523 100644
--- a/dns/Makefile
+++ b/dns/Makefile
@@ -99,6 +99,7 @@
SUBDIR += p5-Net-DNS-RR-SRV-Helper
SUBDIR += p5-Net-DNS-Resolver-Programmable
SUBDIR += p5-Net-DNS-SEC
+ SUBDIR += p5-Net-DNS-TestNS
SUBDIR += p5-Net-DNS-ToolKit
SUBDIR += p5-Net-DNS-ZoneCheck
SUBDIR += p5-Net-DNS-ZoneFile
diff --git a/dns/p5-Net-DNS-TestNS/Makefile b/dns/p5-Net-DNS-TestNS/Makefile
new file mode 100644
index 000000000000..adde526dd728
--- /dev/null
+++ b/dns/p5-Net-DNS-TestNS/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Net-DNS-TestNS
+# Date created: 2010-06-26
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@sunpoet.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-DNS-TestNS
+PORTVERSION= 1.10
+CATEGORIES= dns perl5
+MASTER_SITES= CPAN/../../authors/id/O/OL/OLAF/
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@sunpoet.net
+COMMENT= Perl extension for simulating simple Nameservers
+
+BUILD_DEPENDS= p5-Net-DNS>0.64:${PORTSDIR}/dns/p5-Net-DNS \
+ p5-XML-LibXML>1.53:${PORTSDIR}/textproc/p5-XML-LibXML
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::DNS::TestNS.3 Net::DNS::TestNS::DTD.3
+
+.include <bsd.port.mk>
diff --git a/dns/p5-Net-DNS-TestNS/distinfo b/dns/p5-Net-DNS-TestNS/distinfo
new file mode 100644
index 000000000000..34d5a7204c15
--- /dev/null
+++ b/dns/p5-Net-DNS-TestNS/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-DNS-TestNS-1.10.tar.gz) = f227f6dadadbed28d32b4c8b7ff83a16
+SHA256 (Net-DNS-TestNS-1.10.tar.gz) = 8126573ff1c94891f7225d5a1cbf058b5fc0d65fbfa00fbbb037928fc3f4559f
+SIZE (Net-DNS-TestNS-1.10.tar.gz) = 16905
diff --git a/dns/p5-Net-DNS-TestNS/pkg-descr b/dns/p5-Net-DNS-TestNS/pkg-descr
new file mode 100644
index 000000000000..cadee5257eaf
--- /dev/null
+++ b/dns/p5-Net-DNS-TestNS/pkg-descr
@@ -0,0 +1,10 @@
+Class to setup a number of nameservers that respond to specific DNS queries
+(QNAME,QTYPE) by prespecified answers. This class is to be used in test suites
+where you want to have servers to show predefined behavior.
+
+If the server will do a lookup based on QNAME,QTYPE and return the specified
+data. If there is no QNAME, QTYPE match the server will return a SERVFAIL.
+
+A log will be written to STDERR it contains time, IP/PORT, QNAME, QTYPE, RCODE.
+
+WWW: http://search.cpan.org/dist/Net-DNS-TestNS/
diff --git a/dns/p5-Net-DNS-TestNS/pkg-plist b/dns/p5-Net-DNS-TestNS/pkg-plist
new file mode 100644
index 000000000000..9dfec8898d0a
--- /dev/null
+++ b/dns/p5-Net-DNS-TestNS/pkg-plist
@@ -0,0 +1,9 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/Net/DNS/TestNS.pm
+%%SITE_PERL%%/Net/DNS/TestNS/DTD.pm
+%%SITE_PERL%%/Net/DNS/TestNS/Nameserver.pm
+%%SITE_PERL%%/Net/DNS/TestNS/Packet.pm
+%%SITE_PERL%%/mach/auto/Net/DNS/TestNS/.packlist
+@dirrm %%SITE_PERL%%/mach/auto/Net/DNS/TestNS
+@dirrm %%SITE_PERL%%/Net/DNS/TestNS
+@dirrmtry %%SITE_PERL%%/Net/DNS