aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authortimur <timur@FreeBSD.org>2013-10-19 05:14:20 +0800
committertimur <timur@FreeBSD.org>2013-10-19 05:14:20 +0800
commita5a2fd45d6757dfe865df9a0c5d443fd7770f0fe (patch)
tree0d25e05e805da6b8a55ec4e0bc53518353e3de5f /dns
parentc70c1db72c992a6e38c55d0a4283f028fb6a9e34 (diff)
downloadfreebsd-ports-gnome-a5a2fd45d6757dfe865df9a0c5d443fd7770f0fe.tar.gz
freebsd-ports-gnome-a5a2fd45d6757dfe865df9a0c5d443fd7770f0fe.tar.zst
freebsd-ports-gnome-a5a2fd45d6757dfe865df9a0c5d443fd7770f0fe.zip
Sync port with bind98. Fix(?) gssapi_krb5 detection.
Diffstat (limited to 'dns')
-rw-r--r--dns/samba-nsupdate/Makefile8
-rw-r--r--dns/samba-nsupdate/distinfo4
-rw-r--r--dns/samba-nsupdate/files/patch-configure.in21
3 files changed, 28 insertions, 5 deletions
diff --git a/dns/samba-nsupdate/Makefile b/dns/samba-nsupdate/Makefile
index 9e9ec57d7320..fc9c575f99be 100644
--- a/dns/samba-nsupdate/Makefile
+++ b/dns/samba-nsupdate/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= nsupdate
-PORTVERSION= 9.8.4.1
+PORTVERSION= 9.8.6
CATEGORIES= dns net ipv6
MASTER_SITES= ${MASTER_SITE_ISC}
MASTER_SITE_SUBDIR= bind9/${ISCVERSION}
@@ -14,10 +14,11 @@ COMMENT= An nsupdate utility with GSS-TSIG support
LICENSE= ISCL
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.8.4-P1
+ISCVERSION= 9.8.6
MAKE_JOBS_UNSAFE= yes
+USE_AUTOTOOLS= autoconf autoheader
USE_OPENSSL= yes
GNU_CONFIGURE= yes
@@ -35,7 +36,8 @@ CONFIGURE_ARGS+= \
--without-idn \
--with-randomdev=/dev/random
-NO_STAGE= yes
+NO_STAGE= yes
+
.include <bsd.port.options.mk>
.include <bsd.port.pre.mk>
diff --git a/dns/samba-nsupdate/distinfo b/dns/samba-nsupdate/distinfo
index 9122c6b12485..15b15ced0050 100644
--- a/dns/samba-nsupdate/distinfo
+++ b/dns/samba-nsupdate/distinfo
@@ -1,2 +1,2 @@
-SHA256 (bind-9.8.4-P1.tar.gz) = 60c979575bf6288570cb4e3e9ab9d99bb93a55d2a4946ce277f6e6e642dda21f
-SIZE (bind-9.8.4-P1.tar.gz) = 7129321
+SHA256 (bind-9.8.6.tar.gz) = 01cc3a0105b47833b99e61b69acd824be4eeefd6557fffa26eced8e03f1249cd
+SIZE (bind-9.8.6.tar.gz) = 7275769
diff --git a/dns/samba-nsupdate/files/patch-configure.in b/dns/samba-nsupdate/files/patch-configure.in
new file mode 100644
index 000000000000..b0a9e2c84f9a
--- /dev/null
+++ b/dns/samba-nsupdate/files/patch-configure.in
@@ -0,0 +1,21 @@
+--- configure.in.orig 2013-09-05 05:19:53.000000000 +0000
++++ configure.in 2013-10-18 14:30:21.711727438 +0000
+@@ -1013,7 +1013,8 @@
+ "-lgssapi" \
+ "-lgssapi -lkrb5 -ldes -lcrypt -lasn1 -lroken -lcom_err" \
+ "-lgssapi -lkrb5 -lcrypto -lcrypt -lasn1 -lroken -lcom_err" \
+- "-lgss -lkrb5"
++ "-lgss -lkrb5" \
++ "-lgssapi_krb5 -lgssapi -lheimntlm -lkrb5 -lhx509 -lcom_err -lcrypto -lasn1 -lroken -lcrypt"
+ do
+ # Note that this does not include $saved_libs, because
+ # on FreeBSD machines this configure script has added
+@@ -1027,7 +1028,7 @@
+ LIBS="-L$use_gssapi/lib $TRY_LIBS"
+ fi
+ AC_MSG_CHECKING(linking as $TRY_LIBS)
+- AC_TRY_LINK( , [gss_acquire_cred();krb5_init_context()],
++ AC_TRY_LINK( , [gss_acquire_cred();krb5_init_context();gsskrb5_register_acceptor_identity("krb5");],
+ gssapi_linked=yes, gssapi_linked=no)
+ case $gssapi_linked in
+ yes) AC_MSG_RESULT(yes); break ;;