aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2012-03-02 00:34:33 +0800
committerswills <swills@FreeBSD.org>2012-03-02 00:34:33 +0800
commiteb0b401394dfbb12da93cb64d32171e0ba5ffc70 (patch)
tree4d395faf499e8506f46efed7cd47a4140c68c617 /dns
parentdcd147bc82c9778c6d9c00ae98870d2d5f886759 (diff)
downloadfreebsd-ports-gnome-eb0b401394dfbb12da93cb64d32171e0ba5ffc70.tar.gz
freebsd-ports-gnome-eb0b401394dfbb12da93cb64d32171e0ba5ffc70.tar.zst
freebsd-ports-gnome-eb0b401394dfbb12da93cb64d32171e0ba5ffc70.zip
A Perl POE component that provides non-blocking DNSBL lookups
WWW: http://search.cpan.org/dist/POE-Component-Client-DNSBL/
Diffstat (limited to 'dns')
-rw-r--r--dns/Makefile1
-rw-r--r--dns/p5-POE-Component-Client-DNSBL/Makefile26
-rw-r--r--dns/p5-POE-Component-Client-DNSBL/distinfo2
-rw-r--r--dns/p5-POE-Component-Client-DNSBL/pkg-descr3
-rw-r--r--dns/p5-POE-Component-Client-DNSBL/pkg-plist3
5 files changed, 35 insertions, 0 deletions
diff --git a/dns/Makefile b/dns/Makefile
index 98424b8c8713..3d5263b2fa50 100644
--- a/dns/Makefile
+++ b/dns/Makefile
@@ -112,6 +112,7 @@
SUBDIR += p5-Net-RBLClient
SUBDIR += p5-POE-Component-Client-DNS
SUBDIR += p5-POE-Component-Client-DNS-Recursive
+ SUBDIR += p5-POE-Component-Client-DNSBL
SUBDIR += p5-POE-Component-Resolver
SUBDIR += p5-POE-Component-Server-DNS
SUBDIR += p5-Stanford-DNSserver
diff --git a/dns/p5-POE-Component-Client-DNSBL/Makefile b/dns/p5-POE-Component-Client-DNSBL/Makefile
new file mode 100644
index 000000000000..eb8b1ac631d5
--- /dev/null
+++ b/dns/p5-POE-Component-Client-DNSBL/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-POE-Component-Client-DNSBL
+# Date created: 2012-03-01
+# Whom: Steve Wills <swills@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= POE-Component-Client-DNSBL
+PORTVERSION= 1.08
+CATEGORIES= dns perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= A Perl POE component that provides non-blocking DNSBL lookups
+
+BUILD_DEPENDS= p5-POE>=1.004:${PORTSDIR}/devel/p5-POE \
+ p5-Net-IP-Minimal>=0:${PORTSDIR}/net/p5-Net-IP-Minimal \
+ p5-POE-Component-Client-DNS>=0:${PORTSDIR}/dns/p5-POE-Component-Client-DNS
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= POE::Component::Client::DNSBL.3
+
+.include <bsd.port.mk>
diff --git a/dns/p5-POE-Component-Client-DNSBL/distinfo b/dns/p5-POE-Component-Client-DNSBL/distinfo
new file mode 100644
index 000000000000..8729b3d941ac
--- /dev/null
+++ b/dns/p5-POE-Component-Client-DNSBL/distinfo
@@ -0,0 +1,2 @@
+SHA256 (POE-Component-Client-DNSBL-1.08.tar.gz) = 4006f4d377e5c012fc183ee4ea7396c43b5544ac8f07060daaf8880908e104b5
+SIZE (POE-Component-Client-DNSBL-1.08.tar.gz) = 15107
diff --git a/dns/p5-POE-Component-Client-DNSBL/pkg-descr b/dns/p5-POE-Component-Client-DNSBL/pkg-descr
new file mode 100644
index 000000000000..660efc9d58bd
--- /dev/null
+++ b/dns/p5-POE-Component-Client-DNSBL/pkg-descr
@@ -0,0 +1,3 @@
+A Perl POE component that provides non-blocking DNSBL lookups
+
+WWW: http://search.cpan.org/dist/POE-Component-Client-DNSBL/
diff --git a/dns/p5-POE-Component-Client-DNSBL/pkg-plist b/dns/p5-POE-Component-Client-DNSBL/pkg-plist
new file mode 100644
index 000000000000..531d1d364af9
--- /dev/null
+++ b/dns/p5-POE-Component-Client-DNSBL/pkg-plist
@@ -0,0 +1,3 @@
+%%SITE_PERL%%/POE/Component/Client/DNSBL.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/Client/DNSBL/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/Client/DNSBL