aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2010-01-07 14:25:07 +0800
committerwen <wen@FreeBSD.org>2010-01-07 14:25:07 +0800
commit067f3f1d96e1cb7089ac165e3c5b91cca0673873 (patch)
tree2b81c3f38045bf167225550b36e83543192a7a32 /dns
parent82575fecc5da2545b78e79eacedc6db2dc1e33ca (diff)
downloadfreebsd-ports-gnome-067f3f1d96e1cb7089ac165e3c5b91cca0673873.tar.gz
freebsd-ports-gnome-067f3f1d96e1cb7089ac165e3c5b91cca0673873.tar.zst
freebsd-ports-gnome-067f3f1d96e1cb7089ac165e3c5b91cca0673873.zip
OpenDNSSEC was created as an open-source turn-key solution for
DNSSEC. It secures zone data just before it is published in an authoritative name server. WWW: http://www.opendnssec.org PR: ports/142103 Submitted by: Jaap Akkerhuis <jaap@NLnetLabs.nl>
Diffstat (limited to 'dns')
-rw-r--r--dns/Makefile1
-rw-r--r--dns/opendnssec/Makefile33
-rw-r--r--dns/opendnssec/distinfo3
-rw-r--r--dns/opendnssec/pkg-descr5
-rw-r--r--dns/opendnssec/pkg-plist99
5 files changed, 141 insertions, 0 deletions
diff --git a/dns/Makefile b/dns/Makefile
index 75853558c6f2..80fab19cbb9f 100644
--- a/dns/Makefile
+++ b/dns/Makefile
@@ -81,6 +81,7 @@
SUBDIR += nss_resinit
SUBDIR += odsclient
SUBDIR += opendd
+ SUBDIR += opendnssec
SUBDIR += openresolv
SUBDIR += p5-BIND-Conf_Parser
SUBDIR += p5-DNS-Config
diff --git a/dns/opendnssec/Makefile b/dns/opendnssec/Makefile
new file mode 100644
index 000000000000..e863ebad94b3
--- /dev/null
+++ b/dns/opendnssec/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: opendnssec
+# Date created: 28 December 2009
+# Whom: Jaap Akkerhuis <jaap@NLnetLabs.nl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= opendnssec
+PORTVERSION= 1.0.0
+CATEGORIES= dns
+MASTER_SITES= http://www.opendnssec.org/files/source/
+DISTNAME= ${PORTNAME}-${PORTVERSION}rc1
+
+MAINTAINER= jaap@NLnetLabs.nl
+COMMENT= Tool suite for maintaining DNSSEC
+
+BUILD_DEPENDS+= ldns>=1.6.3:${PORTSDIR}/dns/ldns
+BUILD_DEPENDS+= ${PYTHON_SITELIBDIR}/Ft/Xml/__init__.py:${PORTSDIR}/textproc/py-4suite-xml
+BUILD_DEPENDS+= rubygem-dnsruby>=${DNSRUBY_VER}:${PORTSDIR}/dns/rubygem-dnsruby
+LIB_DEPENDS= xml2:${PORTSDIR}/textproc/libxml2
+LIB_DEPENDS+= ldns:${PORTSDIR}/dns/ldns
+LIB_DEPENDS+= sqlite3:${PORTSDIR}/databases/sqlite3
+
+GNU_CONFIGURE= yes
+USE_PERL5= yes
+USE_PYTHON= 2.4+
+USE_RUBY= yes
+USE_LDCONFIG= yes
+
+pre-configure:
+ @${REINPLACE_CMD} -e 's/ Ft.Xml.XPath//' ${WRKSRC}/signer/configure
+
+.include <bsd.port.mk>
diff --git a/dns/opendnssec/distinfo b/dns/opendnssec/distinfo
new file mode 100644
index 000000000000..9450c813ccd3
--- /dev/null
+++ b/dns/opendnssec/distinfo
@@ -0,0 +1,3 @@
+MD5 (opendnssec-1.0.0rc1.tar.gz) = fa940add6f48d851e62eb6ba894b62eb
+SHA256 (opendnssec-1.0.0rc1.tar.gz) = 0bf020c2262e331fdc9f3093870b2c83375d6bc3b5df79a61287285e1a961492
+SIZE (opendnssec-1.0.0rc1.tar.gz) = 2032245
diff --git a/dns/opendnssec/pkg-descr b/dns/opendnssec/pkg-descr
new file mode 100644
index 000000000000..147cc627fd96
--- /dev/null
+++ b/dns/opendnssec/pkg-descr
@@ -0,0 +1,5 @@
+OpenDNSSEC was created as an open-source turn-key solution for
+DNSSEC. It secures zone data just before it is published in an
+authoritative name server.
+
+WWW: http://www.opendnssec.org
diff --git a/dns/opendnssec/pkg-plist b/dns/opendnssec/pkg-plist
new file mode 100644
index 000000000000..49292e88000d
--- /dev/null
+++ b/dns/opendnssec/pkg-plist
@@ -0,0 +1,99 @@
+bin/hsmspeed
+bin/hsmutil
+bin/ksmutil
+bin/ods-auditor
+bin/ods-control
+bin/ods-hsmspeed
+bin/ods-hsmutil
+bin/ods-ksmutil
+bin/ods-kaspcheck
+bin/ods-signer
+%%ETCDIR%%/conf.xml
+%%ETCDIR%%/conf.xml.sample
+%%ETCDIR%%/kasp.xml
+%%ETCDIR%%/kasp.xml.sample
+%%ETCDIR%%/zonefetch.xml
+%%ETCDIR%%/zonefetch.xml.sample
+%%ETCDIR%%/zonelist.xml
+%%ETCDIR%%/zonelist.xml.sample
+include/hsmtest.h
+include/libhsm.h
+include/libhsmdns.h
+lib/libhsm.a
+lib/libhsm.la
+lib/libhsm.so
+lib/libhsm.so.1
+lib/opendnssec/kasp_auditor/auditor.rb
+lib/opendnssec/kasp_auditor/config.rb
+lib/opendnssec/kasp_auditor/key_tracker.rb
+lib/opendnssec/kasp_auditor/parse.rb
+lib/opendnssec/kasp_auditor/preparser.rb
+lib/opendnssec/kasp_auditor.rb
+lib/opendnssec/kasp_checker.rb
+lib/opendnssec/signer/Engine.py
+lib/opendnssec/signer/Engine.pyc
+lib/opendnssec/signer/Engine.pyo
+lib/opendnssec/signer/EngineConfig.py
+lib/opendnssec/signer/EngineConfig.pyc
+lib/opendnssec/signer/EngineConfig.pyo
+lib/opendnssec/signer/Util.py
+lib/opendnssec/signer/Util.pyc
+lib/opendnssec/signer/Util.pyo
+lib/opendnssec/signer/Worker.py
+lib/opendnssec/signer/Worker.pyc
+lib/opendnssec/signer/Worker.pyo
+lib/opendnssec/signer/Zone.py
+lib/opendnssec/signer/Zone.pyc
+lib/opendnssec/signer/Zone.pyo
+lib/opendnssec/signer/ZoneConfig.py
+lib/opendnssec/signer/ZoneConfig.pyc
+lib/opendnssec/signer/ZoneConfig.pyo
+lib/opendnssec/signer/ZoneList.py
+lib/opendnssec/signer/ZoneList.pyc
+lib/opendnssec/signer/ZoneList.pyo
+lib/opendnssec/time_shift.rb
+libexec/opendnssec/create_dnskey
+libexec/opendnssec/finalizer
+libexec/opendnssec/get_class
+libexec/opendnssec/get_serial
+libexec/opendnssec/nsec3er
+libexec/opendnssec/nseccer
+libexec/opendnssec/signer
+libexec/opendnssec/signer_threads
+libexec/opendnssec/sorter
+libexec/opendnssec/zone_fetcher
+libexec/opendnssec/zone_reader
+sbin/ods-enforcerd
+sbin/ods-signerd
+%%DATADIR%%.spec
+%%DATADIR%%/conf.rnc
+%%DATADIR%%/conf.rng
+%%DATADIR%%/database_create.sqlite3
+%%DATADIR%%/kasp.rnc
+%%DATADIR%%/kasp.rng
+%%DATADIR%%/kasp2html.xsl
+%%DATADIR%%/signconf.rnc
+%%DATADIR%%/signconf.rng
+%%DATADIR%%/zonefetch.rnc
+%%DATADIR%%/zonefetch.rng
+%%DATADIR%%/zonelist.rnc
+%%DATADIR%%/zonelist.rng
+@dirrm var/run/opendnssec
+@dirrm var/run
+@dirrm var/opendnssec/unsigned
+@dirrm var/opendnssec/tmp
+@dirrm var/opendnssec/signed
+@dirrm var/opendnssec/signconf
+@dirrm var/opendnssec
+@dirrm var
+@dirrm %%DATADIR%%
+@dirrm libexec/opendnssec
+@dirrm lib/opendnssec/kasp_auditor
+@dirrm lib/opendnssec/signer
+@dirrm lib/opendnssec
+@dirrm %%ETCDIR%%
+@exec mkdir -p %D/var/run/opendnssec
+@exec mkdir -p %D/var/opendnssec/unsigned
+@exec mkdir -p %D/var/opendnssec/tmp
+@exec mkdir -p %D/var/opendnssec/signed
+@exec mkdir -p %D/var/opendnssec/signconf
rtions'>+1 * . update to version 4.3.9;bsam2009-11-141-3/+3 * - Update to 0.1.27wen2009-10-192-4/+4 * Update to 9.2. Multiple vulnerabilities which could cause thehrs2009-10-151-3/+3 * Update to 8.1.7. Multiple vulnerabilities which could cause thehrs2009-10-151-3/+3 * Update to version 4.3.8.bsam2009-10-131-3/+3 * Update to 9.1.3.hrs2009-10-101-3/+3 * Chase SeaMonkey's upgrade to 1.1.18.thierry2009-09-102-5/+4 * Update to version 4.3.7.1.bsam2009-09-061-3/+3 * The FreeBSD KDE is please to announce the release of KDE 4.3.1,tabthorpe2009-09-022-4/+5 * - Switch SourceForge ports to the new File Release System: categories startin...amdmi32009-08-223-4/+4 * clean upmakc2009-08-081-3/+0 * The KDE FreeBSD team is proud to announce the release of KDE 4.3.0miwi2009-08-054-27/+113 * . update to version 4.3.6;bsam2009-08-051-3/+3 * -Repocopy devel/libtool15 -> libtool22 and libltdl15 -> libltdl22.mezz2009-08-032-2/+2 * - bump all port that indirectly depends on libjpeg and have not yet been bump...dinoex2009-07-319-3/+9 * Make the port IGNORE for OSVERSION>800079 since it can'tbsam2009-07-221-1/+7 * Update to version 4.3.5.bsam2009-07-201-3/+3 * - update to jpeg7dinoex2009-07-181-2/+2 * Upgrade SeaMonkey's FLP to 1.1.17.thierry2009-06-282-4/+4 * Upgrade to 10.0.3-2.thierry2009-06-224-83/+191 * Chase Code_Aster's upgrade.thierry2009-06-223-7/+7 * Upgrade to 1.16.0.thierry2009-06-224-321/+19 * This port installs the documentation files of Eficas (See the portthierry2009-06-227-0/+348 * Update to 8.1.6 and 9.1.2.hrs2009-06-182-6/+6 * The KDE FreeBSD team is pleased to announce KDE 4.2.4, the last bugfixmiwi2009-06-032-3/+19 * Update to version 4.3.4.bsam2009-06-011-3/+3 * Update to 9.1.1. Two critical vulnerabilities have been fixed:hrs2009-05-131-3/+3 * Update to 8.1.5. Two critical vulnerabilities have been fixed:hrs2009-05-131-3/+3 * Update KDE ports to 4.2.3makc2009-05-102-3/+21 * Update to version 4.3.3.bsam2009-05-041-3/+3 * - USE_APACHE=yes is deprecatedthierry2009-04-222-9/+5 * Update to version 4.3.2.bsam2009-04-031-3/+3 * The KDE FreeBSD team is proud to announce the release of KDE 4.2.2miwi2009-04-023-12/+26 * Add acroread9, Adobe Reader 9.1.0. For changes since Adobe Readerhrs2009-03-293-0/+19 * Update to 8.1.4. This version includes serious security fixes.hrs2009-03-291-3/+3 * Upgrade SeaMonkey's FLP to 1.1.15.thierry2009-03-232-4/+4 * Welcome to the new linux ports infrastructure which allows usingbsam2009-03-202-2/+2 * - Update to 0.1.24miwi2009-03-142-5/+4 * Update KDE to 4.2.1.makc2009-03-092-3/+19 * Update to version 4.3.1.bsam2009-03-081-3/+3 * Fix compilation with gcc-43.thierry2009-02-108-0/+87 * - Add all manpages for kde4-l10n*miwi2009-02-091-0/+39 * The KDE FreeBSD team is proud to announce the release of KDE 4.2.0miwi2009-02-093-125/+201 * Here is the long awaited 4.3.0 release. It includes enhancementsbsam2009-02-091-3/+3 * - Update download locationpav2009-02-011-1/+1 * - Update X.org ports to 7.4+ (few ports are more recent than the katamari).flz2009-01-241-1/+1 * Chase Aster's main tarball. No change.thierry2009-01-214-8/+9 * Upgrade to 9.4.0-2.thierry2009-01-213-19/+10 * The tarball has been silently rerolled. Full diff atthierry2009-01-212-4/+5 * Chase Code_Aster's version.thierry2009-01-151-2/+2 * Upgrade to 9.5.1.thierry2009-01-153-139/+288 * Upgrade Code_Aster to 9.4.0.thierry2009-01-157-143/+972 * - Upgrade to 2.3.5;thierry2009-01-152-9/+21 * - Upgrade to 1.15.0-1;thierry2009-01-154-24/+100 * kde@freebsd team is pleased to announce KDE 4.1.4, the last bugfix release in...makc2009-01-143-21/+214 * - Replace literal gfortran42 with , fix buildpav2009-01-131-2/+2 * Update to version 4.2.5.bsam2009-01-081-3/+3 * - Remove conditional checks for FreeBSD 5.x and olderpav2009-01-061-3/+0 * Upgrade SeaMonkey French Language Pack to 1.1.14.thierry2009-01-052-4/+4 * Obtain a new license key.thierry2009-01-032-3/+3 * Update to version 4.2.4.bsam2008-12-081-3/+3 * Upgrade SeaMonkey French Language Pack to 1.1.13.thierry2008-11-202-4/+4 * Update to version 4.2.3.bsam2008-11-101-3/+3 * Update to Adobe Reader 8.1.3.hrs2008-11-081-3/+3 * - Update to 4jadawin2008-11-054-63/+99 * Chase Code_Aster's tarball re-rolling (no change for homard).thierry2008-10-252-4/+4 * The main tarball has been rerolled, but the included components have notthierry2008-10-224-8/+8 * Update to version 4.2.2a -- bug fix release.bsam2008-10-071-3/+3 * Update to version 4.2.2.bsam2008-10-061-3/+3 * Upgrade Seamonkey's french language pack to 1.1.12.thierry2008-10-032-4/+4 * Update to version 4.2.1.bsam2008-09-241-3/+3 * Remove ports of Adobe Reader 7 and the localized versions because ofhrs2008-09-063-22/+0 * The KDE FreeBSD team is proud to announce the release of KDE 4.1.1miwi2008-09-032-8/+71 * The KDE FreeBSD team is proud to announce the releasemiwi2008-08-292-3/+6 * - Respect NOPORTDOCS, NOPORTEXAMPLESamdmi32008-08-242-269/+7 * Update CONFIGURE_ARGS for how we pass CONFIGURE_TARGET to configure script.rafan2008-08-212-2/+0 * Conversion from (now defunct) autoconf-2.61 to autoconf-2.62ade2008-08-202-2/+2 * - Add optional Gnome supporttabthorpe2008-08-192-3/+17 * The KDE FreeBSD team is proud to announce the releasemiwi2008-08-182-10/+66 * Update to version 4.2.0.bsam2008-08-131-3/+3 * - Fix categoriemiwi2008-08-101-1/+1 * The KDE FreeBSD team is proud to announce the release of KDE 4.1.0miwi2008-08-105-977/+312 * - Mark BROKEN on FreeBSD 6.xpav2008-07-291-0/+3 * Fix USE_XORG for the upcoming bsd.port.mk changes (ports/122340).flz2008-07-231-1/+1 * Update to 8.1.2 Security Update 1. Quoted from the advisory:hrs2008-07-211-3/+3 * Chase SeaMonkey's upgrade to 1.1.11.thierry2008-07-182-5/+4 * Update to version 4.1.6 (bug fix release).bsam2008-07-181-3/+3 * Chase Code_Aster's upgrade.thierry2008-07-131-2/+2 * Upgrade Code_Aster to 9.3.0.thierry2008-07-137-144/+541 * - Upgrade to 8.11-2;thierry2008-07-132-6/+14 * - Upgrade to 1.14.0-1;thierry2008-07-133-43/+411 * - Now builds on amd64/6pav2008-06-231-4/+0 * Update to version 4.1.5.bsam2008-06-082-4/+3 * Bump portrevision due to upgrade of devel/gettext.edwin2008-06-069-4/+9 * - Update to 0.1.23tabthorpe2008-06-033-15/+14 * GIBI runs also on amd64.thierry2008-06-021-1/+1 * Homard runs on amd64.thierry2008-05-251-2/+2 * Provide a new license key, the previous one has expired.thierry2008-05-252-4/+4 * - Limit BROKEN status to 6.x onlypav2008-05-051-2/+4 * Update to version 4.1.3 (bug fix release).bsam2008-05-051-3/+3 * - Mark BROKEN: compilation of elements withpav2008-05-031-0/+2 * Reset jylefort's port maintainerships. portmgr has taken his commit bitlinimon2008-04-291-1/+1 * Upgrade to 2.3.4.thierry2008-04-244-353/+4 * - Remove unneeded dependency from gtk12/gtk20 [1]miwi2008-04-203-9/+10 * Chase a forgotten Code_Aster's upgrade.thierry2008-04-171-2/+2 * Update to 8.1.2. Bug fixes and enhancements can be found athrs2008-04-141-3/+3 * Update eric4 and langpacks to 4.1.2 (bug fixes).bsam2008-04-061-3/+3 * Upgrade SeaMonkey's French Language Pack to 1.1.9.thierry2008-03-312-5/+4 * - Chase shlib version of net-mgmt/net-snmp.kuriyama2008-03-271-2/+2 * Upgrade to 2.3.3.thierry2008-03-2319-120/+539 * - Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORGmiwi2008-03-221-2/+1 * - Update maintainer addressjadawin2008-03-121-1/+1 * Update to 4.1.1:bsam2008-03-021-3/+3 * Chase SeaMonkey's upgrade to 1.1.8.thierry2008-02-292-4/+4 * Make fetchable again.thierry2008-02-291-1/+1 * 2007-12-12 net-im/wildfire: Use net-im/openfire instead of this portmiwi2008-02-2818-266/+0 * My reference e-mail address as a ports maintainer is now gahr@FreeBSD.org.gahr2008-02-221-1/+1 * - Update to 0.1.22tabthorpe2008-02-194-16/+15 * Update to 4.1.0.bsam2008-02-061-3/+3 * Chase master-site's reorganization.thierry2008-01-193-3/+3 * Remove junk from plist.thierry2008-01-151-1/+0 * - Upgrade to 8.11-1;thierry2008-01-133-405/+403 * Upgrade Code_Aster to 9.2.0-2.thierry2008-01-137-94/+473 * Upgrade to 1.13.0-1.thierry2008-01-134-428/+276 * Add Adobe Reader 8.1.1 and localized versions (total 15hrs2008-01-053-0/+19 * Build seamonkey-flp by default, because mozilla is deprecated.thierry2007-12-291-6/+6 * - Known security vulnerabilities and no active development: mark for removal inpav2007-12-273-0/+11 * Pluxml is a tiny tool to generate blog based on php and xml.pav2007-12-274-46/+64 * - Update to 0.1.21tabthorpe2007-12-203-4/+6 * - Update MASTER_SITESmiwi2007-12-192-10/+51 * Update to version 4.0.4.bsam2007-12-171-3/+3 * Chase SeaMonkey's update to 1.1.7.thierry2007-12-042-4/+4 * Update to KDE 3.5.8lofi2007-10-304-8/+98 * Migration from bison 1.x to 2.xade2007-10-171-1/+2 * A theme for pluxml.miwi2007-10-107-0/+74 * Update to 4.0.3. This version fixes a bug, that could cause an endless loopbsam2007-10-041-3/+3 * . update to 4.0.2;bsam2007-10-031-3/+3 * A theme for pluxml.alepulver2007-10-036-0/+60 * Switch autoconf dependencies from 2.53 or 2.59 to 2.61.linimon2007-09-301-2/+2 * - Chase x11-toolkits/pmw renamed to x11-toolkits/py-Pmwrafan2007-09-021-1/+2 * force commit for missed file.tabthorpe2007-08-231-0/+15 * - Update to 0.1.20tabthorpe2007-08-236-63/+24 * Pluxml is a tiny tool to generate blog based on php and xml.thierry2007-08-2213-0/+241 * Upgrade Seamonkey's french language pack to 1.1.4.thierry2007-08-112-4/+4 * Upgrade fr-seamonkey-flp to 1.1.3.thierry2007-08-013-6/+9 * Update to the autotools new world order.ade2007-07-281-2/+3 * This port is a language translation file for devel/eric4.bsam2007-07-263-0/+16 * Those ports will be added soon to the ports tree with more adequate names.bsam2007-07-263-16/+0 * Now we use USE_FORTRAN=yes to use FORTRAN compiler.maho2007-07-141-4/+1 * Now we use USE_FORTRAN=yes to use FORTRAN compiler.maho2007-07-141-4/+1 * Update to KDE 3.5.7 / KOffice 1.6.3lofi2007-07-0415-25/+122