aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authorsem <sem@FreeBSD.org>2009-12-02 00:18:41 +0800
committersem <sem@FreeBSD.org>2009-12-02 00:18:41 +0800
commit6f79908e12236c1764148d45989643b6ab940f19 (patch)
tree936df70b27c19d4cfb9d3402e64b2767d756cc57 /dns
parent6c410a1bd8d2f570db13264844e9d5fcd88d4e66 (diff)
downloadfreebsd-ports-gnome-6f79908e12236c1764148d45989643b6ab940f19.tar.gz
freebsd-ports-gnome-6f79908e12236c1764148d45989643b6ab940f19.tar.zst
freebsd-ports-gnome-6f79908e12236c1764148d45989643b6ab940f19.zip
- A patch from developer
* Fix crash when iterator without validator used
Diffstat (limited to 'dns')
-rw-r--r--dns/unbound/Makefile1
-rw-r--r--dns/unbound/files/patch-validator-autotrust.c13
2 files changed, 14 insertions, 0 deletions
diff --git a/dns/unbound/Makefile b/dns/unbound/Makefile
index 9c392c8ee038..6c9414dcad90 100644
--- a/dns/unbound/Makefile
+++ b/dns/unbound/Makefile
@@ -7,6 +7,7 @@
PORTNAME= unbound
PORTVERSION= 1.4.0
+PORTREVISION= 1
CATEGORIES= dns
MASTER_SITES= http://unbound.net/downloads/
diff --git a/dns/unbound/files/patch-validator-autotrust.c b/dns/unbound/files/patch-validator-autotrust.c
new file mode 100644
index 000000000000..95de254dce4c
--- /dev/null
+++ b/dns/unbound/files/patch-validator-autotrust.c
@@ -0,0 +1,13 @@
+Index: validator/autotrust.c
+===================================================================
+--- validator/autotrust.c (revision 1923)
++++ validator/autotrust.c (revision 1924)
+@@ -100,6 +100,8 @@
+ autr_get_num_anchors(struct val_anchors* anchors)
+ {
+ size_t res = 0;
++ if(!anchors)
++ return 0;
+ lock_basic_lock(&anchors->lock);
+ if(anchors->autr)
+ res = anchors->autr->probe.count;