aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2018-02-19 19:10:43 +0800
committerantoine <antoine@FreeBSD.org>2018-02-19 19:10:43 +0800
commit16a04e9b881e61b48e43444a26db1c5e401d7efc (patch)
tree94eaef37ab07d82e499ae4cafabe202ea2ed0525 /dns
parenta7c90a608e4fee40a557fa793e68d2e26c67c1ed (diff)
downloadfreebsd-ports-gnome-16a04e9b881e61b48e43444a26db1c5e401d7efc.tar.gz
freebsd-ports-gnome-16a04e9b881e61b48e43444a26db1c5e401d7efc.tar.zst
freebsd-ports-gnome-16a04e9b881e61b48e43444a26db1c5e401d7efc.zip
Reduce dependency on the python2 metaport
PR: 225752 Submitted by: Yasuhiro KIMURA
Diffstat (limited to 'dns')
-rw-r--r--dns/py-dns/Makefile4
-rw-r--r--dns/py-idnkit2/Makefile3
-rw-r--r--dns/unbound/Makefile4
3 files changed, 6 insertions, 5 deletions
diff --git a/dns/py-dns/Makefile b/dns/py-dns/Makefile
index 0b62a8745ee0..489c3e7af095 100644
--- a/dns/py-dns/Makefile
+++ b/dns/py-dns/Makefile
@@ -3,7 +3,7 @@
PORTNAME= dns
PORTVERSION= 2.3.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= dns python
MASTER_SITES= SF/py${PORTNAME}/py${PORTNAME}/py${PORTNAME}-${PORTVERSION}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -17,7 +17,7 @@ LICENSE_NAME= CNRI LICENSE AGREEMENT
LICENSE_FILE= ${WRKSRC}/LICENSE
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-USES= python:2
+USES= python:2.7
USE_PYTHON= distutils autoplist
PORTDOCS= README.txt README-guido.txt
diff --git a/dns/py-idnkit2/Makefile b/dns/py-idnkit2/Makefile
index 605dc9e7aee5..8f213dcf0925 100644
--- a/dns/py-idnkit2/Makefile
+++ b/dns/py-idnkit2/Makefile
@@ -3,6 +3,7 @@
PORTNAME= idnkit-python
PORTVERSION= 2.3
+PORTREVISION= 1
CATEGORIES= dns
MASTER_SITES= http://jprs.co.jp/idn/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,7 +13,7 @@ COMMENT= Python bindings for Internationalized Domain Name toolkit 2
LIB_DEPENDS= libidnkitlite.so:dns/idnkit2
-USES= python:2 tar:bzip2
+USES= python:2.7 tar:bzip2
USE_PYTHON= distutils autoplist
post-patch:
diff --git a/dns/unbound/Makefile b/dns/unbound/Makefile
index dad692451f85..c3188c7c9f1d 100644
--- a/dns/unbound/Makefile
+++ b/dns/unbound/Makefile
@@ -3,7 +3,7 @@
PORTNAME= unbound
PORTVERSION= 1.6.8
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= dns
MASTER_SITES= http://unbound.net/downloads/
@@ -75,7 +75,7 @@ PYTHON_BUILD_DEPENDS= swig3.0:devel/swig30
PYTHON_CONFIGURE_ON= --with-pyunbound=yes --with-pythonmodule=yes \
LDFLAGS="-L${LOCALBASE}/lib" \
ac_cv_path_SWIG=${LOCALBASE}/bin/swig3.0
-PYTHON_USES= python:2
+PYTHON_USES= python:2.7
PYTHON_VARS= STRIP_FILES+=.libs/_unbound.so
THREADS_CONFIGURE_WITH= pthreads