aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authortruckman <truckman@FreeBSD.org>2015-04-04 06:22:45 +0800
committertruckman <truckman@FreeBSD.org>2015-04-04 06:22:45 +0800
commit56f956bba4925188fe072cc65aa059968337de03 (patch)
tree2dce682451dd4d6ede10cb54cee8aa74b4186ee5 /dns
parent54f5825ec6cd54c6f75ef12868c9f69cafaaa4d7 (diff)
downloadfreebsd-ports-gnome-56f956bba4925188fe072cc65aa059968337de03.tar.gz
freebsd-ports-gnome-56f956bba4925188fe072cc65aa059968337de03.tar.zst
freebsd-ports-gnome-56f956bba4925188fe072cc65aa059968337de03.zip
Add new port dns/dnstable.
dnstable implements an encoding format for passive DNS data. It consists of a C library, libdnstable, and several command line utilities for creating, querying, and merging dnstable data files. It stores key-value records in Sorted String Table (SSTable) files and provides high-level interfaces for querying or iterating over the stored records. dnstable encodes individual records using a format tailored for efficiently storing passive DNS data and can quickly perform both "forward" and "inverse" searches. Differential Revision: https://reviews.freebsd.org/D2214 Approved by: mat (mentor) Sponsored by: Farsight Security, Inc.
Diffstat (limited to 'dns')
-rw-r--r--dns/Makefile1
-rw-r--r--dns/dnstable/Makefile34
-rw-r--r--dns/dnstable/distinfo2
-rw-r--r--dns/dnstable/files/patch-dnstable_query.c11
-rw-r--r--dns/dnstable/files/patch-src_dnstable__convert.c10
-rw-r--r--dns/dnstable/files/patch-src_dnstable__lookup.c10
-rw-r--r--dns/dnstable/pkg-descr11
-rw-r--r--dns/dnstable/pkg-plist21
8 files changed, 100 insertions, 0 deletions
diff --git a/dns/Makefile b/dns/Makefile
index 0cd70d51a428..eae5ba74bca2 100644
--- a/dns/Makefile
+++ b/dns/Makefile
@@ -41,6 +41,7 @@
SUBDIR += dnsperf
SUBDIR += dnsproxy
SUBDIR += dnsreflector
+ SUBDIR += dnstable
SUBDIR += dnstop
SUBDIR += dnstracer
SUBDIR += dnsutl
diff --git a/dns/dnstable/Makefile b/dns/dnstable/Makefile
new file mode 100644
index 000000000000..c4148445e167
--- /dev/null
+++ b/dns/dnstable/Makefile
@@ -0,0 +1,34 @@
+# $FreeBSD$
+
+PORTNAME= dnstable
+PORTVERSION= 0.7.0
+CATEGORIES= dns
+MASTER_SITES= FARSIGHT LOCAL/truckman/farsight
+
+MAINTAINER= truckman@FreeBSD.org
+COMMENT= Encoding format, library, and utilities for passive DNS data
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/COPYRIGHT
+
+BUILD_DEPENDS= sie-nmsg>0:${PORTSDIR}/net/sie-nmsg
+LIB_DEPENDS= libjansson.so:${PORTSDIR}/devel/jansson \
+ libmtbl.so:${PORTSDIR}/devel/mtbl \
+ libwdns.so:${PORTSDIR}/dns/wdns \
+ libnmsg.so:${PORTSDIR}/net/nmsg
+RUN_DEPENDS= sie-nmsg>0:${PORTSDIR}/net/sie-nmsg
+
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+USES= gmake libtool pathfix pkgconfig
+INSTALL_TARGET= install-strip
+
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+post-install:
+.for i in 1 3 5 7
+ ${INSTALL_MAN} ${WRKSRC}/man/*.${i} ${STAGEDIR}/${PREFIX}/man/man${i}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/dns/dnstable/distinfo b/dns/dnstable/distinfo
new file mode 100644
index 000000000000..19d1482dc2d9
--- /dev/null
+++ b/dns/dnstable/distinfo
@@ -0,0 +1,2 @@
+SHA256 (dnstable-0.7.0.tar.gz) = 2035fa74b7f1fd91da846bab810b9ac376f839aaa8cf627dace2a29dee293b2b
+SIZE (dnstable-0.7.0.tar.gz) = 383942
diff --git a/dns/dnstable/files/patch-dnstable_query.c b/dns/dnstable/files/patch-dnstable_query.c
new file mode 100644
index 000000000000..a3b909ab78ed
--- /dev/null
+++ b/dns/dnstable/files/patch-dnstable_query.c
@@ -0,0 +1,11 @@
+--- dnstable/query.c.orig 2014-05-21 21:37:25 UTC
++++ dnstable/query.c
+@@ -15,6 +15,8 @@
+ */
+
+ #include <arpa/inet.h>
++#include <sys/socket.h>
++#include <sys/endian.h>
+
+ #include "dnstable-private.h"
+
diff --git a/dns/dnstable/files/patch-src_dnstable__convert.c b/dns/dnstable/files/patch-src_dnstable__convert.c
new file mode 100644
index 000000000000..c83b1d1672e7
--- /dev/null
+++ b/dns/dnstable/files/patch-src_dnstable__convert.c
@@ -0,0 +1,10 @@
+--- src/dnstable_convert.c.orig 2014-05-21 21:37:25 UTC
++++ src/dnstable_convert.c
+@@ -24,6 +24,7 @@
+ #include <stdio.h>
+ #include <string.h>
+ #include <unistd.h>
++#include <sys/endian.h>
+
+ #include <dnstable.h>
+ #include <mtbl.h>
diff --git a/dns/dnstable/files/patch-src_dnstable__lookup.c b/dns/dnstable/files/patch-src_dnstable__lookup.c
new file mode 100644
index 000000000000..9cda1c2c7206
--- /dev/null
+++ b/dns/dnstable/files/patch-src_dnstable__lookup.c
@@ -0,0 +1,10 @@
+--- src/dnstable_lookup.c.orig 2014-04-02 00:26:43 UTC
++++ src/dnstable_lookup.c
+@@ -23,6 +23,7 @@
+ #include <stdio.h>
+ #include <string.h>
+ #include <unistd.h>
++#include <sys/endian.h>
+
+ #include <dnstable.h>
+ #include <mtbl.h>
diff --git a/dns/dnstable/pkg-descr b/dns/dnstable/pkg-descr
new file mode 100644
index 000000000000..3327ebd32e3e
--- /dev/null
+++ b/dns/dnstable/pkg-descr
@@ -0,0 +1,11 @@
+dnstable implements an encoding format for passive DNS data. It consists of a
+C library, libdnstable, and several command line utilities for creating,
+querying, and merging dnstable data files.
+
+It stores key-value records in Sorted String Table (SSTable) files and provides
+high-level interfaces for querying or iterating over the stored records.
+dnstable encodes individual records using a format tailored for efficiently
+storing passive DNS data and can quickly perform both "forward" and "inverse"
+searches.
+
+WWW: https://github.com/farsightsec/dnstable
diff --git a/dns/dnstable/pkg-plist b/dns/dnstable/pkg-plist
new file mode 100644
index 000000000000..c0c1c9f4c591
--- /dev/null
+++ b/dns/dnstable/pkg-plist
@@ -0,0 +1,21 @@
+bin/dnstable_convert
+bin/dnstable_dump
+bin/dnstable_lookup
+bin/dnstable_merge
+include/dnstable.h
+lib/libdnstable.a
+lib/libdnstable.so
+lib/libdnstable.so.0
+lib/libdnstable.so.0.0.0
+libdata/pkgconfig/libdnstable.pc
+man/man1/dnstable_convert.1.gz
+man/man1/dnstable_dump.1.gz
+man/man1/dnstable_lookup.1.gz
+man/man1/dnstable_merge.1.gz
+man/man3/dnstable_entry.3.gz
+man/man3/dnstable_iter.3.gz
+man/man3/dnstable_merge_func.3.gz
+man/man3/dnstable_query.3.gz
+man/man3/dnstable_reader.3.gz
+man/man5/dnstable-encoding.5.gz
+man/man7/dnstable.7.gz