aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-02-19 20:10:28 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-02-19 20:10:28 +0800
commit69651c7540320b289273325c7a3b9616bb0eea83 (patch)
tree3d334c5960370b9562fd2f8e407321f6f64dacda /dns
parent44894490ab8e7ef5777dafac2e8dcdfa79648b81 (diff)
downloadfreebsd-ports-gnome-69651c7540320b289273325c7a3b9616bb0eea83.tar.gz
freebsd-ports-gnome-69651c7540320b289273325c7a3b9616bb0eea83.tar.zst
freebsd-ports-gnome-69651c7540320b289273325c7a3b9616bb0eea83.zip
- Support staging
- Use shebangfix - Don't install GPLv2 file but define LICENSE
Diffstat (limited to 'dns')
-rw-r--r--dns/hostdb/Makefile26
-rw-r--r--dns/hostdb/pkg-plist1
2 files changed, 12 insertions, 15 deletions
diff --git a/dns/hostdb/Makefile b/dns/hostdb/Makefile
index 27eca8316e43..bb004d7b3386 100644
--- a/dns/hostdb/Makefile
+++ b/dns/hostdb/Makefile
@@ -10,33 +10,31 @@ EXTRACT_SUFX= .tgz
MAINTAINER= rodrigc@FreeBSD.org
COMMENT= Generate DNS and DHCP config files from single source
+LICENSE= GPLv2
+
+USES= shebangfix
+
NO_BUILD= yes
HOSTDB_EXAMPLES_DIRS= example1/out example1/ example2 hiddenmaster
HOSTDB_EXAMPLES_DIRS+= mailserverexample/out mailserverexample
-NO_STAGE= yes
+SHEBANG_FILES= bin/mkdestinations bin/mknamedconf bin/zone2hostdbhelper \
+ bin/mkzones bin/canonzone bin/genrange
OPTIONS_DEFINE= DOCS EXAMPLES
-.include <bsd.port.options.mk>
-
pre-install:
${FIND} ${WRKSRC} -name "*\.orig" -delete
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/bin/* ${PREFIX}/bin
-.if ${PORT_OPTIONS:MEXAMPLES}
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/* ${STAGEDIR}${PREFIX}/bin
.for dir in ${HOSTDB_EXAMPLES_DIRS}
- ${MKDIR} ${EXAMPLESDIR}
- cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} . ${EXAMPLESDIR}/
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR}/
.endfor
-.endif
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}/
- cd ${WRKSRC}/docs/ && ${COPYTREE_SHARE} . ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README.txt ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/COPYING ${DOCSDIR}
-.endif
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}/
+ cd ${WRKSRC}/docs/ && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.txt ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/dns/hostdb/pkg-plist b/dns/hostdb/pkg-plist
index 42b371ed4538..1b768acb7cb3 100644
--- a/dns/hostdb/pkg-plist
+++ b/dns/hostdb/pkg-plist
@@ -15,7 +15,6 @@ bin/zone2hostdbhelper
%%PORTDOCS%%%%DOCSDIR%%/hostdb-options.txt
%%PORTDOCS%%%%DOCSDIR%%/lisa2005-paper.pdf
%%PORTDOCS%%%%DOCSDIR%%/README.txt
-%%PORTDOCS%%%%DOCSDIR%%/COPYING
%%PORTDOCS%%@dirrm %%DOCSDIR%%
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example1/zoneconf.txt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example1/dhcpd.conf-tail