aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authordougb <dougb@FreeBSD.org>2009-12-14 14:25:17 +0800
committerdougb <dougb@FreeBSD.org>2009-12-14 14:25:17 +0800
commit832d65d5b858d3e6a7feee5e7e14df2241c9614f (patch)
tree627e3b82b21d033af26c0cd7c99a89de9c770f1b /dns
parent1d34da21d9de3b7a7854a140e4fda8e6b0331982 (diff)
downloadfreebsd-ports-gnome-832d65d5b858d3e6a7feee5e7e14df2241c9614f.tar.gz
freebsd-ports-gnome-832d65d5b858d3e6a7feee5e7e14df2241c9614f.tar.zst
freebsd-ports-gnome-832d65d5b858d3e6a7feee5e7e14df2241c9614f.zip
Add BIND 9.7.0rc1 with a -devel suffix for now so that people can
start testing it sooner rather than later. When the final version is released the -devel will be removed. Some of the new features of BIND 9.7.x are: - Fully automatic signing of zones by "named" - Simplified configuration of DNSSEC Lookaside Validation (DLV) - Simplified configuration of Dynamic DNS, using the "ddns-confgen" command line tool or the "local" update-policy option - New named option "attach-cache" that allows multiple views to share a single cache - DNS rebinding attack prevention - New default values for dnssec-keygen parameters - Support for RFC 5011 automated trust anchor maintenance (see README.rfc5011 for additional details) - Smart signing: simplified tools for zone signing and key maintenance - Improved PKCS#11 support
Diffstat (limited to 'dns')
-rw-r--r--dns/Makefile1
-rw-r--r--dns/bind97/Makefile229
-rw-r--r--dns/bind97/distinfo6
-rw-r--r--dns/bind97/pkg-descr20
-rw-r--r--dns/bind97/pkg-message18
-rw-r--r--dns/bind97/pkg-plist285
6 files changed, 559 insertions, 0 deletions
diff --git a/dns/Makefile b/dns/Makefile
index 635c59343d14..d84893bc4b4f 100644
--- a/dns/Makefile
+++ b/dns/Makefile
@@ -12,6 +12,7 @@
SUBDIR += bind94-geoip
SUBDIR += bind95
SUBDIR += bind96
+ SUBDIR += bind97
SUBDIR += bindgraph
SUBDIR += c-ares
SUBDIR += checkdns
diff --git a/dns/bind97/Makefile b/dns/bind97/Makefile
new file mode 100644
index 000000000000..5c4990c88cc0
--- /dev/null
+++ b/dns/bind97/Makefile
@@ -0,0 +1,229 @@
+# New ports collection makefile for: BIND 9.7.x
+# Date created: 13 December 2009
+# Whom: dougb
+#
+# $FreeBSD$
+#
+
+PORTNAME= bind97
+PKGNAMESUFFIX= -devel
+PORTVERSION= 9.7.0.rc1
+CATEGORIES= dns net ipv6
+MASTER_SITES= ${MASTER_SITE_ISC} \
+ http://dougbarton.us/Downloads/%SUBDIR%/
+MASTER_SITE_SUBDIR= bind9/${ISCVERSION}
+DISTNAME= bind-${ISCVERSION}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DISTNAME}${EXTRACT_SUFX}.asc
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
+
+MAINTAINER= dougb@FreeBSD.org
+COMMENT= The BIND DNS suite with updated DNSSEC and threads
+
+# ISC releases things like 9.4.0b3, which our versioning doesn't like
+ISCVERSION= 9.7.0rc1
+
+MAKE_JOBS_UNSAFE= yes
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --localstatedir=/var --disable-linux-caps \
+ --with-randomdev=/dev/random
+
+CONFLICTS= bind9*-9.[3456].* bind9-sdb-* host-*
+
+OPTIONS= SSL "Building without OpenSSL removes DNSSEC" on \
+ LINKS "Create conf file symlinks in ${PREFIX}" on \
+ XML "Support for xml statistics output" on \
+ IDN "Add IDN support to dig, host, etc." off \
+ REPLACE_BASE "Replace base BIND with this version" off \
+ LARGE_FILE "64-bit file support" off \
+ SIGCHASE "dig/host/nslookup will do DNSSEC validation" off \
+ IPV6 "IPv6 Support (autodetected by default)" off \
+ DLZ_POSTGRESQL "DLZ Postgres driver" off \
+ DLZ_MYSQL "DLZ MySQL driver (single-threaded BIND)" off \
+ DLZ_BDB "DLZ BDB driver" off \
+ DLZ_LDAP "DLZ LDAP driver" off \
+ DLZ_FILESYSTEM "DLZ filesystem driver" off \
+ DLZ_STUB "DLZ stub driver" off
+
+# Just in case
+USE_OPENSSL= yes
+
+.include <bsd.port.pre.mk>
+
+.if (${ARCH} == "amd64")
+ARCH= x86_64
+.endif
+
+# We are ok by default from 7.0-RELEASE on
+.if ${OSVERSION} >= 700055
+OPTIONS+= THREADS "Compile with thread support" on
+.else
+OPTIONS+= THREADS "Compile w/threads (Not Recommended <FreeBSD-7)" off
+.endif
+
+.if !defined(WITHOUT_SSL)
+CONFIGURE_ARGS+= --with-openssl=${OPENSSLBASE}
+.else
+CONFIGURE_ARGS+= --disable-openssl-version-check
+CONFIGURE_ARGS+= --without-openssl
+.endif
+
+.if !defined(WITHOUT_XML)
+CONFIGURE_ARGS+= --with-libxml2=${LOCALBASE}
+LIB_DEPENDS+= xml2.5:${PORTSDIR}/textproc/libxml2
+.else
+CONFIGURE_ARGS+= --without-libxml2
+.endif
+
+.if defined(WITH_IDN)
+CONFIGURE_ARGS+= --with-idn=${LOCALBASE} --with-libiconv=${LOCALBASE}
+LIB_DEPENDS+= idnkit.1:${PORTSDIR}/dns/idnkit
+.else
+CONFIGURE_ARGS+= --without-idn
+.endif
+
+.if !defined(WITHOUT_LINKS) && !defined(WITH_REPLACE_BASE)
+PLIST_SUB+= LINKS=""
+.else
+PLIST_SUB+= LINKS="@comment "
+.endif
+
+.if defined(WITH_LARGE_FILE)
+CONFIGURE_ARGS+= --enable-largefile
+.endif
+
+.if defined(WITH_SIGCHASE)
+CONFIGURE_ARGS+= STD_CDEFINES="-DDIG_SIGCHASE=1"
+.endif
+
+.if defined(WITH_IPV6)
+CONFIGURE_ARGS+= --enable-ipv6
+.endif
+
+.if defined(WITH_DLZ_POSTGRESQL)
+CONFIGURE_ARGS+= --with-dlz-postgres=yes
+USE_PGSQL= yes
+.endif
+
+.if defined(WITH_DLZ_MYSQL)
+CONFIGURE_ARGS+= --with-dlz-mysql=yes
+USE_MYSQL= yes
+WITHOUT_THREADS= yes
+.endif
+
+.if defined(WITH_DLZ_BDB)
+CONFIGURE_ARGS+= --with-dlz-bdb=yes
+USE_BDB= yes
+.endif
+
+.if defined(WITH_DLZ_LDAP)
+CONFIGURE_ARGS+= --with-dlz-ldap=yes
+USE_OPENLDAP= yes
+.endif
+
+.if defined(WITH_DLZ_FILESYSTEM)
+CONFIGURE_ARGS+= --with-dlz-filesystem=yes
+.endif
+
+.if defined(WITH_DLZ_STUB)
+CONFIGURE_ARGS+= --with-dlz-stub=yes
+.endif
+
+# Has to be after the DLZ_MYSQL option
+.if !defined(WITHOUT_THREADS)
+CONFIGURE_ARGS+= --enable-threads
+.else
+CONFIGURE_ARGS+= --disable-threads
+.endif
+
+.if defined(WITH_REPLACE_BASE)
+PKGNAMESUFFIX= -base
+PREFIX= /usr
+BIND_DESTETC= /etc/namedb
+CONFIGURE_ARGS+= --prefix=${PREFIX} \
+ --sysconfdir=${BIND_DESTETC}
+.else
+BIND_DESTETC= ${PREFIX}/etc
+.endif
+
+PLIST_SUB+= BIND_DESTETC="${BIND_DESTETC}"
+
+MAN1= arpaname.1 dig.1 host.1 isc-config.sh.1 nslookup.1 nsupdate.1
+MAN3= lwres.3 lwres_addr_parse.3 lwres_buffer.3 lwres_buffer_add.3 \
+ lwres_buffer_back.3 lwres_buffer_clear.3 lwres_buffer_first.3 \
+ lwres_buffer_forward.3 lwres_buffer_getmem.3 lwres_buffer_getuint16.3 \
+ lwres_buffer_getuint32.3 lwres_buffer_getuint8.3 lwres_buffer_init.3 \
+ lwres_buffer_invalidate.3 lwres_buffer_putmem.3 \
+ lwres_buffer_putuint16.3 lwres_buffer_putuint32.3 \
+ lwres_buffer_putuint8.3 lwres_buffer_subtract.3 lwres_conf_clear.3 \
+ lwres_conf_get.3 lwres_conf_init.3 lwres_conf_parse.3 \
+ lwres_conf_print.3 lwres_config.3 lwres_context.3 \
+ lwres_context_allocmem.3 lwres_context_create.3 \
+ lwres_context_destroy.3 lwres_context_freemem.3 \
+ lwres_context_initserial.3 lwres_context_nextserial.3 \
+ lwres_context_sendrecv.3 lwres_endhostent.3 lwres_endhostent_r.3 \
+ lwres_freeaddrinfo.3 lwres_freehostent.3 lwres_gabn.3 \
+ lwres_gabnrequest_free.3 lwres_gabnrequest_parse.3 \
+ lwres_gabnrequest_render.3 lwres_gabnresponse_free.3 \
+ lwres_gabnresponse_parse.3 lwres_gabnresponse_render.3 \
+ lwres_gai_strerror.3 lwres_getaddrinfo.3 lwres_getaddrsbyname.3 \
+ lwres_gethostbyaddr.3 lwres_gethostbyaddr_r.3 lwres_gethostbyname.3 \
+ lwres_gethostbyname2.3 lwres_gethostbyname_r.3 lwres_gethostent.3 \
+ lwres_gethostent_r.3 lwres_getipnode.3 lwres_getipnodebyaddr.3 \
+ lwres_getipnodebyname.3 lwres_getnamebyaddr.3 lwres_getnameinfo.3 \
+ lwres_getrrsetbyname.3 lwres_gnba.3 lwres_gnbarequest_free.3 \
+ lwres_gnbarequest_parse.3 lwres_gnbarequest_render.3 \
+ lwres_gnbaresponse_free.3 lwres_gnbaresponse_parse.3 \
+ lwres_gnbaresponse_render.3 lwres_herror.3 lwres_hstrerror.3 \
+ lwres_inetntop.3 lwres_lwpacket_parseheader.3 \
+ lwres_lwpacket_renderheader.3 lwres_net_ntop.3 lwres_noop.3 \
+ lwres_nooprequest_free.3 lwres_nooprequest_parse.3 \
+ lwres_nooprequest_render.3 lwres_noopresponse_free.3 \
+ lwres_noopresponse_parse.3 lwres_noopresponse_render.3 \
+ lwres_packet.3 lwres_resutil.3 lwres_sethostent.3 \
+ lwres_sethostent_r.3 lwres_string_parse.3
+MAN5= named.conf.5 rndc.conf.5
+MAN8= ddns-confgen.8 dnssec-dsfromkey.8 dnssec-keyfromlabel.8 \
+ dnssec-keygen.8 dnssec-revoke.8 dnssec-settime.8 dnssec-signzone.8 \
+ genrandom.8 lwresd.8 named-checkconf.8 named-checkzone.8 \
+ named-journalprint.8 named.8 nsec3hash.8 rndc-confgen.8 rndc.8
+MLINKS= named-checkzone.8 named-compilezone.8
+
+verify: checksum
+ gpg --verify ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}.asc
+
+post-patch:
+.for FILE in check/named-checkconf.8 named/named.8 nsupdate/nsupdate.1 \
+ rndc/rndc.8
+ @${MV} ${WRKSRC}/bin/${FILE} ${WRKSRC}/bin/${FILE}.Dist
+ @${SED} -e 's#/etc/named.conf#${BIND_DESTETC}/named.conf#g' \
+ -e 's#/etc/rndc.conf#${BIND_DESTETC}/rndc.conf#g' \
+ ${WRKSRC}/bin/${FILE}.Dist > ${WRKSRC}/bin/${FILE}
+.endfor
+ @${MV} ${WRKSRC}/Makefile.in ${WRKSRC}/Makefile.in.Dist
+ @${SED} -e 's#.*bind\.keys.*##' ${WRKSRC}/Makefile.in.Dist > \
+ ${WRKSRC}/Makefile.in
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/bin/rndc/rndc.conf \
+ ${BIND_DESTETC}/rndc.conf.sample
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}/arm ${DOCSDIR}/misc
+ ${INSTALL_DATA} ${WRKSRC}/doc/arm/*.html ${DOCSDIR}/arm
+ ${INSTALL_DATA} ${WRKSRC}/doc/arm/Bv9ARM.pdf ${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/doc/misc/[a-z]* ${DOCSDIR}/misc
+ ${CP} ${WRKSRC}/CHANGES ${WRKSRC}/COPYRIGHT ${WRKSRC}/FAQ* \
+ ${WRKSRC}/README* ${DOCSDIR}/
+.endif
+.if !defined(WITHOUT_LINKS) && !defined(WITH_REPLACE_BASE)
+ ${MKDIR} /var/named${PREFIX}/etc
+.for DIR in ${PREFIX}/etc /var/named${PREFIX}/etc
+.for FILE in named.conf rndc.key
+ ${LN} -sf /etc/namedb/${FILE} ${DIR}/${FILE}
+.endfor
+.endfor
+.endif
+
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/dns/bind97/distinfo b/dns/bind97/distinfo
new file mode 100644
index 000000000000..d7b765e158a3
--- /dev/null
+++ b/dns/bind97/distinfo
@@ -0,0 +1,6 @@
+MD5 (bind-9.7.0rc1.tar.gz) = 4f7e99f8aef6b3d19ef86647c183f502
+SHA256 (bind-9.7.0rc1.tar.gz) = 204b809d7e57ffae247994be90eb66ba2fe6e2d9140fc7699ea0a90cb0ae1410
+SIZE (bind-9.7.0rc1.tar.gz) = 7031548
+MD5 (bind-9.7.0rc1.tar.gz.asc) = 1c2e5c4fc47beb2ced0aaffb1fe4da71
+SHA256 (bind-9.7.0rc1.tar.gz.asc) = 287ba7abf0f3aab90957417f04bb813bad55a6743dd8690301adccef6c737b46
+SIZE (bind-9.7.0rc1.tar.gz.asc) = 481
diff --git a/dns/bind97/pkg-descr b/dns/bind97/pkg-descr
new file mode 100644
index 000000000000..068105e10eaf
--- /dev/null
+++ b/dns/bind97/pkg-descr
@@ -0,0 +1,20 @@
+Some of the new features of BIND 9.7.x are:
+
+ - Fully automatic signing of zones by "named"
+ - Simplified configuration of DNSSEC Lookaside Validation (DLV)
+ - Simplified configuration of Dynamic DNS, using the "ddns-confgen"
+ command line tool or the "local" update-policy option
+ - New named option "attach-cache" that allows multiple views to
+ share a single cache
+ - DNS rebinding attack prevention
+ - New default values for dnssec-keygen parameters
+ - Support for RFC 5011 automated trust anchor maintenance
+ (see README.rfc5011 for additional details)
+ - Smart signing: simplified tools for zone signing and key
+ maintenance
+ - Improved PKCS#11 support
+
+WWW: https://www.isc.org/software/bind
+
+- Doug Barton
+DougB@FreeBSD.org
diff --git a/dns/bind97/pkg-message b/dns/bind97/pkg-message
new file mode 100644
index 000000000000..bb713abdd1d3
--- /dev/null
+++ b/dns/bind97/pkg-message
@@ -0,0 +1,18 @@
+*************************************************************************
+* _ _____ _____ _____ _ _ _____ ___ ___ _ _ *
+* / \|_ _|_ _| ____| \ | |_ _|_ _/ _ \| \ | | *
+* / _ \ | | | | | _| | \| | | | | | | | | \| | *
+* / ___ \| | | | | |___| |\ | | | | | |_| | |\ | *
+* /_/ \_\_| |_| |_____|_| \_| |_| |___\___/|_| \_| *
+* *
+* If you are running BIND 9 in a chroot environment, make *
+* sure that there is a /dev/random device in the chroot. *
+* *
+* BIND 9 also requires configuration of rndc, including a *
+* "secret" key. The easiest, and most secure way to configure *
+* rndc is to run 'rndc-confgen -a' to generate the proper conf *
+* file, with a new random key, and appropriate file permissions. *
+* *
+* The /etc/rc.d/named script in the base will do both for you. *
+* *
+*************************************************************************
diff --git a/dns/bind97/pkg-plist b/dns/bind97/pkg-plist
new file mode 100644
index 000000000000..1e39ec9de55d
--- /dev/null
+++ b/dns/bind97/pkg-plist
@@ -0,0 +1,285 @@
+bin/dig
+bin/host
+bin/isc-config.sh
+bin/nslookup
+bin/nsupdate
+%%LINKS%%etc/named.conf
+%%LINKS%%etc/rndc.key
+include/bind9/check.h
+include/bind9/getaddresses.h
+include/bind9/version.h
+include/dns/acl.h
+include/dns/adb.h
+include/dns/byaddr.h
+include/dns/cache.h
+include/dns/callbacks.h
+include/dns/cert.h
+include/dns/compress.h
+include/dns/db.h
+include/dns/dbiterator.h
+include/dns/dbtable.h
+include/dns/diff.h
+include/dns/dispatch.h
+include/dns/dlz.h
+include/dns/dnssec.h
+include/dns/ds.h
+include/dns/enumclass.h
+include/dns/enumtype.h
+include/dns/events.h
+include/dns/fixedname.h
+include/dns/iptable.h
+include/dns/journal.h
+include/dns/keyflags.h
+include/dns/keytable.h
+include/dns/keyvalues.h
+include/dns/lib.h
+include/dns/log.h
+include/dns/master.h
+include/dns/masterdump.h
+include/dns/message.h
+include/dns/name.h
+include/dns/ncache.h
+include/dns/nsec.h
+include/dns/peer.h
+include/dns/portlist.h
+include/dns/private.h
+include/dns/rbt.h
+include/dns/rcode.h
+include/dns/rdata.h
+include/dns/rdataclass.h
+include/dns/rdatalist.h
+include/dns/rdataset.h
+include/dns/rdatasetiter.h
+include/dns/rdataslab.h
+include/dns/rdatastruct.h
+include/dns/rdatatype.h
+include/dns/sdlz.h
+include/dns/request.h
+include/dns/resolver.h
+include/dns/result.h
+include/dns/rootns.h
+include/dns/sdb.h
+include/dns/secalg.h
+include/dns/secproto.h
+include/dns/soa.h
+include/dns/ssu.h
+include/dns/tcpmsg.h
+include/dns/time.h
+include/dns/tkey.h
+include/dns/tsig.h
+include/dns/ttl.h
+include/dns/types.h
+include/dns/validator.h
+include/dns/version.h
+include/dns/view.h
+include/dns/xfrin.h
+include/dns/zone.h
+include/dns/zonekey.h
+include/dns/zt.h
+include/dst/dst.h
+include/dst/gssapi.h
+include/dst/lib.h
+include/dst/result.h
+include/isc/app.h
+include/isc/assertions.h
+include/isc/atomic.h
+include/isc/base64.h
+include/isc/bind9.h
+include/isc/bitstring.h
+include/isc/boolean.h
+include/isc/buffer.h
+include/isc/bufferlist.h
+include/isc/commandline.h
+include/isc/condition.h
+include/isc/dir.h
+include/isc/entropy.h
+include/isc/error.h
+include/isc/event.h
+include/isc/eventclass.h
+include/isc/file.h
+include/isc/formatcheck.h
+include/isc/fsaccess.h
+include/isc/hash.h
+include/isc/heap.h
+include/isc/hex.h
+include/isc/hmacmd5.h
+include/isc/httpd.h
+include/isc/int.h
+include/isc/interfaceiter.h
+include/isc/iterated_hash.h
+include/isc/lang.h
+include/isc/lex.h
+include/isc/lfsr.h
+include/isc/lib.h
+include/isc/list.h
+include/isc/log.h
+include/isc/magic.h
+include/isc/md5.h
+include/isc/mem.h
+include/isc/msgcat.h
+include/isc/msgs.h
+include/isc/mutex.h
+include/isc/mutexblock.h
+include/isc/namespace.h
+include/isc/net.h
+include/isc/netaddr.h
+include/isc/netdb.h
+include/isc/offset.h
+include/isc/once.h
+include/isc/ondestroy.h
+include/isc/os.h
+include/isc/parseint.h
+include/isc/platform.h
+include/isc/print.h
+include/isc/quota.h
+include/isc/radix.h
+include/isc/random.h
+include/isc/ratelimiter.h
+include/isc/refcount.h
+include/isc/region.h
+include/isc/resource.h
+include/isc/result.h
+include/isc/resultclass.h
+include/isc/rwlock.h
+include/isc/serial.h
+include/isc/sha1.h
+include/isc/sha2.h
+include/isc/sockaddr.h
+include/isc/socket.h
+include/isc/stdio.h
+include/isc/stdlib.h
+include/isc/stdtime.h
+include/isc/string.h
+include/isc/symtab.h
+include/isc/syslog.h
+include/isc/task.h
+include/isc/taskpool.h
+include/isc/thread.h
+include/isc/time.h
+include/isc/timer.h
+include/isc/types.h
+include/isc/util.h
+include/isc/version.h
+include/isc/xml.h
+include/isccc/alist.h
+include/isccc/base64.h
+include/isccc/cc.h
+include/isccc/ccmsg.h
+include/isccc/events.h
+include/isccc/lib.h
+include/isccc/result.h
+include/isccc/sexpr.h
+include/isccc/symtab.h
+include/isccc/symtype.h
+include/isccc/types.h
+include/isccc/util.h
+include/isccc/version.h
+include/isccfg/aclconf.h
+include/isccfg/cfg.h
+include/isccfg/grammar.h
+include/isccfg/log.h
+include/isccfg/namedconf.h
+include/isccfg/version.h
+include/lwres/context.h
+include/lwres/int.h
+include/lwres/ipv6.h
+include/lwres/lang.h
+include/lwres/list.h
+include/lwres/lwbuffer.h
+include/lwres/lwpacket.h
+include/lwres/lwres.h
+include/lwres/net.h
+include/lwres/netdb.h
+include/lwres/platform.h
+include/lwres/result.h
+include/lwres/version.h
+lib/libbind9.a
+lib/libdns.a
+lib/libisc.a
+lib/libisccc.a
+lib/libisccfg.a
+lib/liblwres.a
+sbin/arpaname
+sbin/ddns-confgen
+sbin/dnssec-dsfromkey
+sbin/dnssec-keyfromlabel
+sbin/dnssec-keygen
+sbin/dnssec-revoke
+sbin/dnssec-settime
+sbin/dnssec-signzone
+sbin/genrandom
+sbin/lwresd
+sbin/named
+sbin/named-checkconf
+sbin/named-checkzone
+sbin/named-compilezone
+sbin/named-journalprint
+sbin/nsec3hash
+sbin/rndc
+sbin/rndc-confgen
+%%PORTDOCS%%%%DOCSDIR%%/Bv9ARM.pdf
+%%PORTDOCS%%%%DOCSDIR%%/CHANGES
+%%PORTDOCS%%%%DOCSDIR%%/COPYRIGHT
+%%PORTDOCS%%%%DOCSDIR%%/FAQ
+%%PORTDOCS%%%%DOCSDIR%%/FAQ.xml
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/README.dnssec
+%%PORTDOCS%%%%DOCSDIR%%/README.libdns
+%%PORTDOCS%%%%DOCSDIR%%/README.pkcs11
+%%PORTDOCS%%%%DOCSDIR%%/README.rfc5011
+%%PORTDOCS%%%%DOCSDIR%%/arm/Bv9ARM.ch01.html
+%%PORTDOCS%%%%DOCSDIR%%/arm/Bv9ARM.ch02.html
+%%PORTDOCS%%%%DOCSDIR%%/arm/Bv9ARM.ch03.html
+%%PORTDOCS%%%%DOCSDIR%%/arm/Bv9ARM.ch04.html
+%%PORTDOCS%%%%DOCSDIR%%/arm/Bv9ARM.ch05.html
+%%PORTDOCS%%%%DOCSDIR%%/arm/Bv9ARM.ch06.html
+%%PORTDOCS%%%%DOCSDIR%%/arm/Bv9ARM.ch07.html
+%%PORTDOCS%%%%DOCSDIR%%/arm/Bv9ARM.ch08.html
+%%PORTDOCS%%%%DOCSDIR%%/arm/Bv9ARM.ch09.html
+%%PORTDOCS%%%%DOCSDIR%%/arm/Bv9ARM.ch10.html
+%%PORTDOCS%%%%DOCSDIR%%/arm/Bv9ARM.html
+%%PORTDOCS%%%%DOCSDIR%%/arm/man.arpaname.html
+%%PORTDOCS%%%%DOCSDIR%%/arm/man.ddns-confgen.html
+%%PORTDOCS%%%%DOCSDIR%%/arm/man.dig.html
+%%PORTDOCS%%%%DOCSDIR%%/arm/man.dnssec-dsfromkey.html
+%%PORTDOCS%%%%DOCSDIR%%/arm/man.dnssec-keyfromlabel.html
+%%PORTDOCS%%%%DOCSDIR%%/arm/man.dnssec-keygen.html
+%%PORTDOCS%%%%DOCSDIR%%/arm/man.dnssec-revoke.html
+%%PORTDOCS%%%%DOCSDIR%%/arm/man.dnssec-settime.html
+%%PORTDOCS%%%%DOCSDIR%%/arm/man.dnssec-signzone.html
+%%PORTDOCS%%%%DOCSDIR%%/arm/man.genrandom.html
+%%PORTDOCS%%%%DOCSDIR%%/arm/man.host.html
+%%PORTDOCS%%%%DOCSDIR%%/arm/man.named-checkconf.html
+%%PORTDOCS%%%%DOCSDIR%%/arm/man.named-checkzone.html
+%%PORTDOCS%%%%DOCSDIR%%/arm/man.named-journalprint.html
+%%PORTDOCS%%%%DOCSDIR%%/arm/man.named.html
+%%PORTDOCS%%%%DOCSDIR%%/arm/man.nsec3hash.html
+%%PORTDOCS%%%%DOCSDIR%%/arm/man.nsupdate.html
+%%PORTDOCS%%%%DOCSDIR%%/arm/man.rndc-confgen.html
+%%PORTDOCS%%%%DOCSDIR%%/arm/man.rndc.conf.html
+%%PORTDOCS%%%%DOCSDIR%%/arm/man.rndc.html
+%%PORTDOCS%%%%DOCSDIR%%/misc/dnssec
+%%PORTDOCS%%%%DOCSDIR%%/misc/format-options.pl
+%%PORTDOCS%%%%DOCSDIR%%/misc/ipv6
+%%PORTDOCS%%%%DOCSDIR%%/misc/migration
+%%PORTDOCS%%%%DOCSDIR%%/misc/migration-4to9
+%%PORTDOCS%%%%DOCSDIR%%/misc/options
+%%PORTDOCS%%%%DOCSDIR%%/misc/rfc-compliance
+%%PORTDOCS%%%%DOCSDIR%%/misc/roadmap
+%%PORTDOCS%%%%DOCSDIR%%/misc/sdb
+%%PORTDOCS%%%%DOCSDIR%%/misc/sort-options.pl
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/arm
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/misc
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%LINKS%%@unexec rm -f /var/named/%D/etc/named.conf
+%%LINKS%%@unexec rm -f /var/named/%D/etc/rndc.key
+%%LINKS%%@unexec rm -rf /var/named/%D
+%%LINKS%%@unexec rmdir /var/named/usr 2>/dev/null || true
+@unexec rm -f %%BIND_DESTETC%%/rndc.conf.sample
+@dirrm include/bind9
+@dirrm include/dns
+@dirrm include/dst
+@dirrmtry include/isc
+@dirrm include/isccc
+@dirrm include/isccfg
+@dirrm include/lwres