aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authorarrowd <arrowd@FreeBSD.org>2018-07-29 04:05:23 +0800
committerarrowd <arrowd@FreeBSD.org>2018-07-29 04:05:23 +0800
commit83c4ba5bf93a320aa7afa4a664bb7663fb7c0727 (patch)
treed26399422306ebe44657229bf87cd054448b7a73 /dns
parentc8c03399b43034873681f410bc6776792bcce639 (diff)
downloadfreebsd-ports-gnome-83c4ba5bf93a320aa7afa4a664bb7663fb7c0727.tar.gz
freebsd-ports-gnome-83c4ba5bf93a320aa7afa4a664bb7663fb7c0727.tar.zst
freebsd-ports-gnome-83c4ba5bf93a320aa7afa4a664bb7663fb7c0727.zip
dns/dnsrecon: Add missing dependency and patches.
Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D16437
Diffstat (limited to 'dns')
-rw-r--r--dns/dnsrecon/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/dns/dnsrecon/Makefile b/dns/dnsrecon/Makefile
index 1607167eab01..c079cdba1014 100644
--- a/dns/dnsrecon/Makefile
+++ b/dns/dnsrecon/Makefile
@@ -2,6 +2,7 @@
PORTNAME= dnsrecon
DISTVERSION= 0.8.13
+PORTREVISION= 1
CATEGORIES= dns
MAINTAINER= rihaz.jerrin@gmail.com
@@ -10,6 +11,7 @@ COMMENT= DNS enumeration tool
LICENSE= GPLv2
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dnspython>=0:dns/py-dnspython@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}lxml>=0:devel/py-lxml@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}netaddr>=0:net/py-netaddr@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}sqlite3>=0:databases/py-sqlite3@${PY_FLAVOR}
@@ -25,7 +27,9 @@ FILELIST= namelist.txt subdomains-top1mil-20000.txt \
subdomains-top1mil-5000.txt subdomains-top1mil.txt
post-patch:
- @${REINPLACE_CMD} -e 's|from lib|from dnsrecon|g' ${WRKSRC}/${PORTNAME}.py
+ @${REINPLACE_CMD} -e 's|from lib|from dnsrecon|g' ${WRKSRC}/${PORTNAME}.py \
+ ${WRKSRC}/lib/crtenum.py \
+ ${WRKSRC}/lib/gooenum.py
do-install:
${MKDIR} ${STAGEDIR}${DOCSDIR}