aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-10-12 15:04:45 +0800
committerbapt <bapt@FreeBSD.org>2012-10-12 15:04:45 +0800
commit8c866b27f0abee87002268ccc33879a0de3f31ad (patch)
treeb835267db7736a039e0332db9193e0ecf0faec1c /dns
parenta013f24de1a4e45b84f7882b31fdc51f8e8ffd51 (diff)
downloadfreebsd-ports-gnome-8c866b27f0abee87002268ccc33879a0de3f31ad.tar.gz
freebsd-ports-gnome-8c866b27f0abee87002268ccc33879a0de3f31ad.tar.zst
freebsd-ports-gnome-8c866b27f0abee87002268ccc33879a0de3f31ad.zip
Convert to new options framework
Feature safe: yes
Diffstat (limited to 'dns')
-rw-r--r--dns/libbind/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/dns/libbind/Makefile b/dns/libbind/Makefile
index 2a02d6cb496e..aae4996acf2a 100644
--- a/dns/libbind/Makefile
+++ b/dns/libbind/Makefile
@@ -17,18 +17,17 @@ MAKE_JOBS_UNSAFE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=/var --with-randomdev=/dev/random
-OPTIONS= IPV6 "Compile with IPv6 support" on \
- THREADS "Compile with thread support" on
+OPTIONS_DEFINE= IPV6 THREADS
.include <bsd.port.pre.mk>
-.if !defined(WITHOUT_IPV6)
+.if ${PORT_OPTIONS:MIPV6}
CONFIGURE_ARGS+= --enable-ipv6
.else
CONFIGURE_ARGS+= --disable-ipv6
.endif
-.if !defined(WITHOUT_THREADS)
+.if ${PORT_OPTIONS:MTHREADS}
CONFIGURE_ARGS+= --enable-threads
.else
CONFIGURE_ARGS+= --disable-threads