aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2018-06-11 19:56:16 +0800
committermat <mat@FreeBSD.org>2018-06-11 19:56:16 +0800
commita4e6ec5a4ef7d28a21bdbdae62c3427f9f9c3342 (patch)
treea5ea8b8a65ef6a67d6f616ef8c5b5c4133da5142 /dns
parent01f8a0e57ab9489c90d1f3446cc3d7feb68fb084 (diff)
downloadfreebsd-ports-gnome-a4e6ec5a4ef7d28a21bdbdae62c3427f9f9c3342.tar.gz
freebsd-ports-gnome-a4e6ec5a4ef7d28a21bdbdae62c3427f9f9c3342.tar.zst
freebsd-ports-gnome-a4e6ec5a4ef7d28a21bdbdae62c3427f9f9c3342.zip
Update to latest commit.
Sponsored by: Absolight
Diffstat (limited to 'dns')
-rw-r--r--dns/bind9-devel/Makefile4
-rw-r--r--dns/bind9-devel/distinfo6
-rw-r--r--dns/bind9-devel/files/extrapatch-bind-min-override-ttl14
-rw-r--r--dns/bind9-devel/files/patch-configure8
-rw-r--r--dns/bind9-devel/files/patch-lib_isc_include_isc_Makefile.in11
5 files changed, 16 insertions, 27 deletions
diff --git a/dns/bind9-devel/Makefile b/dns/bind9-devel/Makefile
index 724346562542..2fc07566b894 100644
--- a/dns/bind9-devel/Makefile
+++ b/dns/bind9-devel/Makefile
@@ -40,13 +40,13 @@ LIB_DEPENDS= libxml2.so:textproc/libxml2
# XXX: remove tar:bz2
USES= cpe libedit ssl tar:bz2
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.13.0a0.2018.06.03
+ISCVERSION= 9.13.0a0.2018.06.08
# XXX: Remove gitlab
USE_GITLAB= yes
GL_SITE= https://gitlab.isc.org
GL_ACCOUNT= isc-projects
GL_PROJECT= bind9
-GL_COMMIT= 193cc42b442996685caa94ec8aec914ecf6d3357
+GL_COMMIT= b8fbe4aab40f5a41b9b0f00586c972d5afdba05f
CPE_VENDOR= isc
CPE_VERSION= ${ISCVERSION:C/-.*//}
diff --git a/dns/bind9-devel/distinfo b/dns/bind9-devel/distinfo
index b0649e1db114..b88949d08c28 100644
--- a/dns/bind9-devel/distinfo
+++ b/dns/bind9-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1528111031
-SHA256 (isc-projects-bind9-193cc42b442996685caa94ec8aec914ecf6d3357_GL0.tar.gz) = feb295b6806fb4dddc655e85f769236862e0516719def6a272eeb3ffe8d6c44a
-SIZE (isc-projects-bind9-193cc42b442996685caa94ec8aec914ecf6d3357_GL0.tar.gz) = 8930979
+TIMESTAMP = 1528712121
+SHA256 (isc-projects-bind9-b8fbe4aab40f5a41b9b0f00586c972d5afdba05f_GL0.tar.gz) = a1b32af9f19a77b73661ef6690603bb9b011591f700f6e64819fa04e6399cd59
+SIZE (isc-projects-bind9-b8fbe4aab40f5a41b9b0f00586c972d5afdba05f_GL0.tar.gz) = 8925777
diff --git a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
index 978b23a02cd4..9f140ce98996 100644
--- a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
+++ b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
@@ -1,6 +1,6 @@
---- bin/named/config.c.orig 2018-05-25 19:58:32 UTC
+--- bin/named/config.c.orig 2018-06-08 18:48:01 UTC
+++ bin/named/config.c
-@@ -174,12 +174,14 @@ options {\n\
+@@ -176,12 +176,14 @@ options {\n\
max-recursion-queries 75;\n\
max-stale-ttl 604800; /* 1 week */\n\
message-compression yes;\n\
@@ -15,7 +15,7 @@
provide-ixfr true;\n\
query-source address *;\n\
query-source-v6 address *;\n\
---- bin/named/server.c.orig 2018-05-25 19:58:32 UTC
+--- bin/named/server.c.orig 2018-06-08 18:48:01 UTC
+++ bin/named/server.c
@@ -4074,6 +4074,16 @@ configure_view(dns_view_t *view, dns_vie
}
@@ -34,7 +34,7 @@
result = named_config_get(maps, "max-cache-ttl", &obj);
INSIST(result == ISC_R_SUCCESS);
view->maxcachettl = cfg_obj_asuint32(obj);
---- lib/dns/include/dns/view.h.orig 2018-05-25 19:58:32 UTC
+--- lib/dns/include/dns/view.h.orig 2018-06-08 18:48:01 UTC
+++ lib/dns/include/dns/view.h
@@ -149,6 +149,8 @@ struct dns_view {
isc_boolean_t requestnsid;
@@ -45,7 +45,7 @@
dns_ttl_t maxncachettl;
isc_uint32_t nta_lifetime;
isc_uint32_t nta_recheck;
---- lib/dns/resolver.c.orig 2018-05-25 19:58:32 UTC
+--- lib/dns/resolver.c.orig 2018-06-08 18:48:01 UTC
+++ lib/dns/resolver.c
@@ -5748,6 +5748,18 @@ cache_name(fetchctx_t *fctx, dns_name_t
}
@@ -66,9 +66,9 @@
* Enforce the configure maximum cache TTL.
*/
if (rdataset->ttl > res->view->maxcachettl) {
---- lib/isccfg/namedconf.c.orig 2018-05-25 19:58:32 UTC
+--- lib/isccfg/namedconf.c.orig 2018-06-08 18:48:01 UTC
+++ lib/isccfg/namedconf.c
-@@ -1915,6 +1915,8 @@ view_clauses[] = {
+@@ -1916,6 +1916,8 @@ view_clauses[] = {
{ "max-acache-size", &cfg_type_sizenodefault,
CFG_CLAUSEFLAG_OBSOLETE },
{ "max-cache-size", &cfg_type_sizeorpercent, 0 },
diff --git a/dns/bind9-devel/files/patch-configure b/dns/bind9-devel/files/patch-configure
index f7610eaa9794..fe2793a821b7 100644
--- a/dns/bind9-devel/files/patch-configure
+++ b/dns/bind9-devel/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2018-06-04 02:34:28 UTC
+--- configure.orig 2018-06-08 18:48:01 UTC
+++ configure
-@@ -14855,27 +14855,9 @@ done
+@@ -14848,27 +14848,9 @@ done
# problems start to show up.
saved_libs="$LIBS"
for TRY_LIBS in \
@@ -30,7 +30,7 @@
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking linking as $TRY_LIBS" >&5
$as_echo_n "checking linking as $TRY_LIBS... " >&6; }
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
-@@ -14918,47 +14900,7 @@ $as_echo "no" >&6; } ;;
+@@ -14911,47 +14893,7 @@ $as_echo "no" >&6; } ;;
no) as_fn_error $? "could not determine proper GSSAPI linkage" "$LINENO" 5 ;;
esac
@@ -79,7 +79,7 @@
DNS_GSSAPI_LIBS="$LIBS"
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: using GSSAPI from $use_gssapi/lib and $use_gssapi/include" >&5
-@@ -23453,7 +23395,7 @@ $as_echo "" >&6; }
+@@ -23303,7 +23245,7 @@ $as_echo "" >&6; }
# Check other locations for includes.
# Order is important (sigh).
diff --git a/dns/bind9-devel/files/patch-lib_isc_include_isc_Makefile.in b/dns/bind9-devel/files/patch-lib_isc_include_isc_Makefile.in
deleted file mode 100644
index 013dd1db0de0..000000000000
--- a/dns/bind9-devel/files/patch-lib_isc_include_isc_Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/isc/include/isc/Makefile.in.orig 2018-05-18 05:44:02 UTC
-+++ lib/isc/include/isc/Makefile.in
-@@ -21,7 +21,7 @@ VERSION=@BIND9_VERSION@
- HEADERS = aes.h app.h assertions.h backtrace.h base32.h base64.h \
- bind9.h boolean.h buffer.h bufferlist.h \
- commandline.h counter.h crc64.h deprecated.h \
-- entropy.h errno.h error.h event.h eventclass.h \
-+ errno.h error.h event.h eventclass.h \
- file.h formatcheck.h fsaccess.h fuzz.h \
- hash.h heap.h hex.h hmacmd5.h hmacsha.h ht.h httpd.h \
- interfaceiter.h @ISC_IPV6_H@ iterated_hash.h \