aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2014-04-22 00:38:12 +0800
committermat <mat@FreeBSD.org>2014-04-22 00:38:12 +0800
commitc6277f3870524d1fb0f10fd62210102d3c559f09 (patch)
treea0fce925ff74e017298e59803d7a4aa737d92b60 /dns
parent2b29420b5fd071704e7c00d545884e36048b46a1 (diff)
downloadfreebsd-ports-gnome-c6277f3870524d1fb0f10fd62210102d3c559f09.tar.gz
freebsd-ports-gnome-c6277f3870524d1fb0f10fd62210102d3c559f09.tar.zst
freebsd-ports-gnome-c6277f3870524d1fb0f10fd62210102d3c559f09.zip
Add IGNORE if the default python is not the right one.
Sponsored by: Absolight
Diffstat (limited to 'dns')
-rw-r--r--dns/bind10/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/dns/bind10/Makefile b/dns/bind10/Makefile
index 0c748c866b47..97d814b5f849 100644
--- a/dns/bind10/Makefile
+++ b/dns/bind10/Makefile
@@ -27,7 +27,7 @@ LIB_DEPENDS= libbotan-1.10.so:${PORTSDIR}/security/botan110 \
libsqlite3.so:${PORTSDIR}/databases/sqlite3
RUN_DEPENDS= ${PYTHON_LIBDIR}/lib-dynload/_sqlite3.so:${PORTSDIR}/databases/py-sqlite3
-USE_PYTHON= 3.3
+USE_PYTHON= 3
USE_OPENSSL= yes
USE_LDCONFIG= yes
USES= compiler:c++11-lang pathfix pkgconfig
@@ -47,4 +47,10 @@ post-install:
${MV} ${STAGEDIR}${ETCDIR}/cmdctl-certfile.pem ${STAGEDIR}${ETCDIR}/cmdctl-certfile.pem.sample
${MV} ${STAGEDIR}${ETCDIR}/cmdctl-keyfile.pem ${STAGEDIR}${ETCDIR}/cmdctl-keyfile.pem.sample
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_VER} != ${PYTHON_DEFAULT}
+IGNORE= You have python ${PYTHON_DEFAULT} set as the default, and this needs ${PYTHON_VER}
+.endif
+
+.include <bsd.port.post.mk>