aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2006-02-15 20:56:37 +0800
committerehaupt <ehaupt@FreeBSD.org>2006-02-15 20:56:37 +0800
commitcb7a4f85ec9b8ab3339962cd7c1a81433b007ec0 (patch)
tree3b6c7f6a36dcfed5685eaf10863ba9f4cf0a3d1a /dns
parent724a634bcdcd09902b021cb8ccabe2138457d15e (diff)
downloadfreebsd-ports-gnome-cb7a4f85ec9b8ab3339962cd7c1a81433b007ec0.tar.gz
freebsd-ports-gnome-cb7a4f85ec9b8ab3339962cd7c1a81433b007ec0.tar.zst
freebsd-ports-gnome-cb7a4f85ec9b8ab3339962cd7c1a81433b007ec0.zip
- Remove USE_REINPLACE
- Remove trailing whitespaces - Remove depreciated USE_RCORDER - Unquote BROKEN message - Add an extra MASTER_SITE - Change pdns.sh.in and pdns_recursor.sh.in to pdns.in and pdns_recursor.in so it'll work with USE_RC_SUBR - Bump PORTREVISION PR: 93336 Submitted by: Ralf van der Enden <tremere@cainites.net> (maintainer)
Diffstat (limited to 'dns')
-rw-r--r--dns/powerdns-devel/Makefile28
-rw-r--r--dns/powerdns-devel/Makefile.inc1
-rw-r--r--dns/powerdns-devel/files/pdns.in (renamed from dns/powerdns/files/pdns.sh.in)2
-rw-r--r--dns/powerdns-devel/files/pdns_recursor.in (renamed from dns/powerdns/files/pdns_recursor.sh.in)2
-rw-r--r--dns/powerdns/Makefile28
-rw-r--r--dns/powerdns/Makefile.inc1
-rw-r--r--dns/powerdns/files/pdns.in (renamed from dns/powerdns-devel/files/pdns.sh.in)0
-rw-r--r--dns/powerdns/files/pdns_recursor.in (renamed from dns/powerdns-devel/files/pdns_recursor.sh.in)2
8 files changed, 19 insertions, 45 deletions
diff --git a/dns/powerdns-devel/Makefile b/dns/powerdns-devel/Makefile
index d7bcf28e2882..f8a99b79d50a 100644
--- a/dns/powerdns-devel/Makefile
+++ b/dns/powerdns-devel/Makefile
@@ -7,8 +7,10 @@
PORTNAME= powerdns
PORTVERSION= 2.9.19
+PORTREVISION= 1
CATEGORIES= dns ipv6
-MASTER_SITES= http://downloads.powerdns.com/releases/
+MASTER_SITES= http://downloads.powerdns.com/releases/ \
+ http://mirrors.evolva.ro/powerdns.com/releases/
DISTNAME= pdns-${PORTVERSION}
MAINTAINER= tremere@cainites.net
@@ -18,10 +20,9 @@ BUILD_DEPENDS= bjam:${PORTSDIR}/devel/boost
USE_GMAKE= YES
USE_SUBMAKE= YES
-USE_REINPLACE= YES
USE_AUTOTOOLS= libtool:15
INSTALLS_SHLIB= YES
-CXXFLAGS+= -I${LOCALBASE}/include
+CXXFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS+= --with-modules="${CONFIGURE_MODULES} pipe" \
@@ -38,18 +39,7 @@ SUB_FILES= pkg-message
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 500037
-USE_RCORDER= pdns.sh
-RC_DIR= /etc/rc.d
-RC_SUFX=
-.else
-USE_RC_SUBR+= pdns.sh
-RC_DIR= ${PREFIX}/etc/rc.d
-RC_SUFX= .sh
-.endif
-
-PLIST_SUB+= RC_DIR=${RC_DIR} \
- RC_SUFX=${RC_SUFX}
+USE_RC_SUBR+= pdns
# use user config if possible
.if exists(${WRKDIRPREFIX}${.CURDIR}/Makefile.inc)
@@ -102,11 +92,7 @@ PLIST_SUB+= WITHSQLLITE="@comment "
.endif
.if defined(POWERDNS_WITH_RECURSOR)
-.if ${OSVERSION} >= 500037
-USE_RCORDER+= pdns_recursor.sh
-.else
-USE_RC_SUBR+= pdns_recursor.sh
-.endif
+USE_RC_SUBR+= pdns_recursor
CONFIGURE_ARGS+= --enable-recursor
PLIST_SUB+= RECURSOR=""
.else
@@ -118,7 +104,7 @@ PLIST_SUB+= RECURSOR="@comment "
UCONTEXT!= ${AWK} '/setcontext/ { print "YES" }' \
/usr/include/ucontext.h
.if ${UCONTEXT} == ""
-BROKEN= "setcontext for recursor not found or FreeBSD version lower than 5.0"
+BROKEN= setcontext for recursor not found or FreeBSD version lower than 5.0
.endif
.endif
.endif
diff --git a/dns/powerdns-devel/Makefile.inc b/dns/powerdns-devel/Makefile.inc
new file mode 100644
index 000000000000..d7c17dcb1920
--- /dev/null
+++ b/dns/powerdns-devel/Makefile.inc
@@ -0,0 +1 @@
+WITH_POSTGRESQL_DRIVER=YES
diff --git a/dns/powerdns/files/pdns.sh.in b/dns/powerdns-devel/files/pdns.in
index 9eae04153346..63c2a0537df2 100644
--- a/dns/powerdns/files/pdns.sh.in
+++ b/dns/powerdns-devel/files/pdns.in
@@ -1,6 +1,6 @@
#!/bin/sh
#
-# $FreeBSD$
+# $FreeBSD: /tmp/pcvs/ports/dns/powerdns-devel/files/Attic/pdns.in,v 1.1 2006-02-15 12:56:37 ehaupt Exp $
#
# PROVIDE: pdns_server
diff --git a/dns/powerdns/files/pdns_recursor.sh.in b/dns/powerdns-devel/files/pdns_recursor.in
index eb8907e49e60..fc19a1e940af 100644
--- a/dns/powerdns/files/pdns_recursor.sh.in
+++ b/dns/powerdns-devel/files/pdns_recursor.in
@@ -1,6 +1,6 @@
#!/bin/sh
#
-# $FreeBSD$
+# $FreeBSD: /tmp/pcvs/ports/dns/powerdns-devel/files/Attic/pdns_recursor.in,v 1.1 2006-02-15 12:56:37 ehaupt Exp $
#
# PROVIDE: pdns_recursor
diff --git a/dns/powerdns/Makefile b/dns/powerdns/Makefile
index d7bcf28e2882..f8a99b79d50a 100644
--- a/dns/powerdns/Makefile
+++ b/dns/powerdns/Makefile
@@ -7,8 +7,10 @@
PORTNAME= powerdns
PORTVERSION= 2.9.19
+PORTREVISION= 1
CATEGORIES= dns ipv6
-MASTER_SITES= http://downloads.powerdns.com/releases/
+MASTER_SITES= http://downloads.powerdns.com/releases/ \
+ http://mirrors.evolva.ro/powerdns.com/releases/
DISTNAME= pdns-${PORTVERSION}
MAINTAINER= tremere@cainites.net
@@ -18,10 +20,9 @@ BUILD_DEPENDS= bjam:${PORTSDIR}/devel/boost
USE_GMAKE= YES
USE_SUBMAKE= YES
-USE_REINPLACE= YES
USE_AUTOTOOLS= libtool:15
INSTALLS_SHLIB= YES
-CXXFLAGS+= -I${LOCALBASE}/include
+CXXFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS+= --with-modules="${CONFIGURE_MODULES} pipe" \
@@ -38,18 +39,7 @@ SUB_FILES= pkg-message
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 500037
-USE_RCORDER= pdns.sh
-RC_DIR= /etc/rc.d
-RC_SUFX=
-.else
-USE_RC_SUBR+= pdns.sh
-RC_DIR= ${PREFIX}/etc/rc.d
-RC_SUFX= .sh
-.endif
-
-PLIST_SUB+= RC_DIR=${RC_DIR} \
- RC_SUFX=${RC_SUFX}
+USE_RC_SUBR+= pdns
# use user config if possible
.if exists(${WRKDIRPREFIX}${.CURDIR}/Makefile.inc)
@@ -102,11 +92,7 @@ PLIST_SUB+= WITHSQLLITE="@comment "
.endif
.if defined(POWERDNS_WITH_RECURSOR)
-.if ${OSVERSION} >= 500037
-USE_RCORDER+= pdns_recursor.sh
-.else
-USE_RC_SUBR+= pdns_recursor.sh
-.endif
+USE_RC_SUBR+= pdns_recursor
CONFIGURE_ARGS+= --enable-recursor
PLIST_SUB+= RECURSOR=""
.else
@@ -118,7 +104,7 @@ PLIST_SUB+= RECURSOR="@comment "
UCONTEXT!= ${AWK} '/setcontext/ { print "YES" }' \
/usr/include/ucontext.h
.if ${UCONTEXT} == ""
-BROKEN= "setcontext for recursor not found or FreeBSD version lower than 5.0"
+BROKEN= setcontext for recursor not found or FreeBSD version lower than 5.0
.endif
.endif
.endif
diff --git a/dns/powerdns/Makefile.inc b/dns/powerdns/Makefile.inc
new file mode 100644
index 000000000000..d7c17dcb1920
--- /dev/null
+++ b/dns/powerdns/Makefile.inc
@@ -0,0 +1 @@
+WITH_POSTGRESQL_DRIVER=YES
diff --git a/dns/powerdns-devel/files/pdns.sh.in b/dns/powerdns/files/pdns.in
index 9eae04153346..9eae04153346 100644
--- a/dns/powerdns-devel/files/pdns.sh.in
+++ b/dns/powerdns/files/pdns.in
diff --git a/dns/powerdns-devel/files/pdns_recursor.sh.in b/dns/powerdns/files/pdns_recursor.in
index eb8907e49e60..25017f55dcf0 100644
--- a/dns/powerdns-devel/files/pdns_recursor.sh.in
+++ b/dns/powerdns/files/pdns_recursor.in
@@ -1,6 +1,6 @@
#!/bin/sh
#
-# $FreeBSD$
+# $FreeBSD: /tmp/pcvs/ports/dns/powerdns/files/Attic/pdns_recursor.in,v 1.1 2006-02-15 12:56:37 ehaupt Exp $
#
# PROVIDE: pdns_recursor