aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2014-11-18 01:51:51 +0800
committermat <mat@FreeBSD.org>2014-11-18 01:51:51 +0800
commite8290bfc31158238dea8991d0f3d6330003bb740 (patch)
tree1a8742d387fbfb96ae0d2392b3094a947371567e /dns
parent4bd2c86d045ce1637ba6514b1e07ba58be2253c5 (diff)
downloadfreebsd-ports-gnome-e8290bfc31158238dea8991d0f3d6330003bb740.tar.gz
freebsd-ports-gnome-e8290bfc31158238dea8991d0f3d6330003bb740.tar.zst
freebsd-ports-gnome-e8290bfc31158238dea8991d0f3d6330003bb740.zip
Install the bind.keys file with the root and dlv.isc.org keys.
Sponsored by: Absolight
Diffstat (limited to 'dns')
-rw-r--r--dns/bind910/Makefile13
-rw-r--r--dns/bind910/pkg-plist1
-rw-r--r--dns/bind99/Makefile14
-rw-r--r--dns/bind99/pkg-plist2
4 files changed, 10 insertions, 20 deletions
diff --git a/dns/bind910/Makefile b/dns/bind910/Makefile
index 1b91e0cbb34b..f9ab0c374254 100644
--- a/dns/bind910/Makefile
+++ b/dns/bind910/Makefile
@@ -2,6 +2,7 @@
PORTNAME= bind
PORTVERSION= ${ISCVERSION:S/-P/P/}
+PORTREVISION= 1
CATEGORIES= dns net ipv6
MASTER_SITES= ISC/bind9/${ISCVERSION}
PKGNAMESUFFIX?= 910
@@ -196,19 +197,11 @@ PORTDOCS= *
post-patch:
.for FILE in check/named-checkconf.8 named/named.8 nsupdate/nsupdate.1 \
rndc/rndc.8
- @${MV} ${WRKSRC}/bin/${FILE} ${WRKSRC}/bin/${FILE}.Dist
- @${SED} -e 's#/etc/named.conf#${ETCDIR}/named.conf#g' \
+ @${REINPLACE_CMD} -e 's#/etc/named.conf#${ETCDIR}/named.conf#g' \
-e 's#/etc/rndc.conf#${ETCDIR}/rndc.conf#g' \
-e "s#/var\/run\/named\/named.pid#/var/run/named/pid#" \
- ${WRKSRC}/bin/${FILE}.Dist > ${WRKSRC}/bin/${FILE}
+ ${WRKSRC}/bin/${FILE}
.endfor
- @${MV} ${WRKSRC}/Makefile.in ${WRKSRC}/Makefile.in.Dist
- @${SED} -e 's#.*bind\.keys.*##' ${WRKSRC}/Makefile.in.Dist > \
- ${WRKSRC}/Makefile.in
- @${MV} ${WRKSRC}/bin/named/Makefile.in ${WRKSRC}/bin/named/Makefile.in.Dist
- @${SED} -e 's/$${PERL}/#/' -e 's/bind.keys.h/#/g' -e 's/bind9.xsl.h/#/g' \
- ${WRKSRC}/bin/named/Makefile.in.Dist > \
- ${WRKSRC}/bin/named/Makefile.in
post-install:
.if ${PORT_OPTIONS:MDOCS}
diff --git a/dns/bind910/pkg-plist b/dns/bind910/pkg-plist
index 76ccc9e05ab8..ad5f032689ac 100644
--- a/dns/bind910/pkg-plist
+++ b/dns/bind910/pkg-plist
@@ -408,6 +408,7 @@ sbin/rndc
sbin/rndc-confgen
sbin/tsig-keygen
%%ETCDIR%%/rndc.conf.sample
+%%NOBASE%%%%ETCDIR%%/bind.keys
%%NOBASE%%@sample %%ETCDIR%%/named.conf.sample
%%NOBASE%%%%ETCDIR%%/named.root
%%NOBASE%%%%ETCDIR%%/master/empty.db
diff --git a/dns/bind99/Makefile b/dns/bind99/Makefile
index 86cc35c6d489..34ca166bc0c6 100644
--- a/dns/bind99/Makefile
+++ b/dns/bind99/Makefile
@@ -2,6 +2,7 @@
PORTNAME= bind
PORTVERSION= ${ISCVERSION:S/-P/P/}
+PORTREVISION= 1
CATEGORIES= dns net ipv6
MASTER_SITES= ISC/bind9/${ISCVERSION}
PKGNAMESUFFIX= 99
@@ -177,6 +178,7 @@ PKGDEINSTALL= ${PKGINSTALL}
CONFIGURE_ARGS+= --prefix=${PREFIX} \
--sysconfdir=${BIND_DESTETC}
SUB_LIST+= BIND_DESTETC="${BIND_DESTETC}"
+PLIST_SUB+= BIND_DESTETC="${BIND_DESTETC}"
PORTDOCS= *
@@ -197,19 +199,11 @@ WITH_OPENSSL_PORT= yes
post-patch:
.for FILE in check/named-checkconf.8 named/named.8 nsupdate/nsupdate.1 \
rndc/rndc.8
- @${MV} ${WRKSRC}/bin/${FILE} ${WRKSRC}/bin/${FILE}.Dist
- @${SED} -e 's#/etc/named.conf#${BIND_DESTETC}/named.conf#g' \
+ @${REINPLACE_CMD} -e 's#/etc/named.conf#${BIND_DESTETC}/named.conf#g' \
-e 's#/etc/rndc.conf#${BIND_DESTETC}/rndc.conf#g' \
-e "s#/var\/run\/named\/named.pid#/var/run/named/pid#" \
- ${WRKSRC}/bin/${FILE}.Dist > ${WRKSRC}/bin/${FILE}
+ ${WRKSRC}/bin/${FILE}
.endfor
- @${MV} ${WRKSRC}/Makefile.in ${WRKSRC}/Makefile.in.Dist
- @${SED} -e 's#.*bind\.keys.*##' ${WRKSRC}/Makefile.in.Dist > \
- ${WRKSRC}/Makefile.in
- @${MV} ${WRKSRC}/bin/named/Makefile.in ${WRKSRC}/bin/named/Makefile.in.Dist
- @${SED} -e 's/$${PERL}/#/' -e 's/bind.keys.h/#/g' -e 's/bind9.xsl.h/#/g' \
- ${WRKSRC}/bin/named/Makefile.in.Dist > \
- ${WRKSRC}/bin/named/Makefile.in
post-configure:
@${REINPLACE_CMD} -e '/^SO_LDFLAGS/s/-Wl,-rpath,/-rpath /' ${WRKSRC}/bin/tests/system/dlzexternal/Makefile
diff --git a/dns/bind99/pkg-plist b/dns/bind99/pkg-plist
index 2b49573be7cd..4d66d02caa5c 100644
--- a/dns/bind99/pkg-plist
+++ b/dns/bind99/pkg-plist
@@ -374,6 +374,8 @@ sbin/named-journalprint
sbin/nsec3hash
sbin/rndc
sbin/rndc-confgen
+%%BASE%%%%BIND_DESTETC%%/bind.keys
+%%NOBASE%%%%ETCDIR%%/bind.keys
%%NOBASE%%@sample %%ETCDIR%%/named.conf.sample
%%NOBASE%%%%ETCDIR%%/named.root
%%NOBASE%%%%ETCDIR%%/master/empty.db