aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authorsergei <sergei@FreeBSD.org>2004-01-02 07:12:39 +0800
committersergei <sergei@FreeBSD.org>2004-01-02 07:12:39 +0800
commitff7f6c2e1c6361c8a7eb77c466c5e440dd79aeb9 (patch)
tree9ed9aeae4fe5320e5f68b3f5265658e83f53e6d0 /dns
parente2ebe717eb4fbc95d3f4347aa29f2269e4f3d8d4 (diff)
downloadfreebsd-ports-gnome-ff7f6c2e1c6361c8a7eb77c466c5e440dd79aeb9.tar.gz
freebsd-ports-gnome-ff7f6c2e1c6361c8a7eb77c466c5e440dd79aeb9.tar.zst
freebsd-ports-gnome-ff7f6c2e1c6361c8a7eb77c466c5e440dd79aeb9.zip
Add skadns 0.23:
Skadns is a kind of an Asynchronous DNS client software: - Kind of: it's small. Really small. But it just works. - Asynchronous: all DNS operations are non-blocking. - DNS client software: it's a DNS client, what you may know as a "stub resolver". To perform full DNS resolution, you will still need a full resolver like dnscache. The skadns library offers a simple API to make asynchronous DNS queries. The skadnsip, skadnsmx and skadnsfilter commands are examples of how to use that API. They are mainly there for their source code. The skadnsd daemon, usable as a child process or as a separate service, handles the grunt work of DNS querying and makes the network completely invisible to the client. Author: Laurent G. Bercot <ska-skaware@skarnet.org> WWW: http://www.skarnet.org/software/skadns/
Diffstat (limited to 'dns')
-rw-r--r--dns/Makefile1
-rw-r--r--dns/skadns/Makefile53
-rw-r--r--dns/skadns/distinfo1
-rw-r--r--dns/skadns/pkg-descr16
-rw-r--r--dns/skadns/pkg-plist27
5 files changed, 98 insertions, 0 deletions
diff --git a/dns/Makefile b/dns/Makefile
index 632d9d6fc67e..19e5e3abe324 100644
--- a/dns/Makefile
+++ b/dns/Makefile
@@ -57,6 +57,7 @@
SUBDIR += py-adns
SUBDIR += py-dns
SUBDIR += rbldnsd
+ SUBDIR += skadns
SUBDIR += sleuth
SUBDIR += staticcharge
SUBDIR += totd
diff --git a/dns/skadns/Makefile b/dns/skadns/Makefile
new file mode 100644
index 000000000000..b08220d63096
--- /dev/null
+++ b/dns/skadns/Makefile
@@ -0,0 +1,53 @@
+# New ports collection makefile for: skadns
+# Date created: 2004-01-01
+# Whom: Sergei Kolobov <sergei@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= skadns
+PORTVERSION= 0.23
+CATEGORIES= dns devel
+MASTER_SITES= http://www.skarnet.org/software/${PORTNAME}/
+
+MAINTAINER= sergei@FreeBSD.org
+COMMENT= Asynchronous DNS client software and library
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/skalibs/libstddjb.a:${PORTSDIR}/devel/skalibs
+
+USE_REINPLACE= yes
+
+LDFLAGS?= -s
+
+WRKSRC= ${WRKDIR}/web/${DISTNAME}
+
+DOCS= package/CHANGES package/README package/THANKS package/TODO \
+ doc/*.html
+
+do-configure:
+ ${ECHO_CMD} "${CC} ${CFLAGS}" > ${WRKSRC}/src/sys/conf-cc
+ ${ECHO_CMD} "${CC} ${LDFLAGS}" > ${WRKSRC}/src/sys/conf-ld
+ ${ECHO_CMD} "FreeBSD" > ${WRKSRC}/src/sys/systype
+ ${ECHO_CMD} "${LOCALBASE}/include/skalibs" > ${WRKSRC}/package/import
+ ${ECHO_CMD} "${LOCALBASE}/lib/skalibs" >> ${WRKSRC}/package/import
+ ${REINPLACE_CMD} -e 's,/service/skadnsd/.,/var/run/,' \
+ -e 's,/package/web/skadns/command,${PREFIX}/bin,' \
+ ${WRKSRC}/src/skadns/skadns.h
+
+do-build:
+ cd ${WRKSRC} && package/compile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/command/* ${PREFIX}/bin
+ @${MKDIR} ${PREFIX}/include/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/include/* ${PREFIX}/include/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/library/* ${PREFIX}/lib
+ @${MKDIR} ${EXAMPLESDIR}/service
+ cd ${WRKSRC}/service/skadnsd && ${TAR} cf - * | \
+ (cd ${EXAMPLESDIR}/service && ${TAR} xf -)
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/dns/skadns/distinfo b/dns/skadns/distinfo
new file mode 100644
index 000000000000..34247a68306b
--- /dev/null
+++ b/dns/skadns/distinfo
@@ -0,0 +1 @@
+MD5 (skadns-0.23.tar.gz) = 68c018d2e9b7a5b16695643ea1a899f0
diff --git a/dns/skadns/pkg-descr b/dns/skadns/pkg-descr
new file mode 100644
index 000000000000..5d7b5954dc53
--- /dev/null
+++ b/dns/skadns/pkg-descr
@@ -0,0 +1,16 @@
+Skadns is a kind of an Asynchronous DNS client software:
+- Kind of: it's small. Really small. But it just works.
+- Asynchronous: all DNS operations are non-blocking.
+- DNS client software: it's a DNS client, what you may know
+ as a "stub resolver". To perform full DNS resolution,
+ you will still need a full resolver like dnscache.
+
+The skadns library offers a simple API to make asynchronous DNS queries.
+The skadnsip, skadnsmx and skadnsfilter commands are examples
+of how to use that API. They are mainly there for their source code.
+The skadnsd daemon, usable as a child process or as a separate service,
+handles the grunt work of DNS querying and makes the network
+completely invisible to the client.
+
+Author: Laurent G. Bercot <ska-skaware@skarnet.org>
+WWW: http://www.skarnet.org/software/skadns/
diff --git a/dns/skadns/pkg-plist b/dns/skadns/pkg-plist
new file mode 100644
index 000000000000..04e4a76401c7
--- /dev/null
+++ b/dns/skadns/pkg-plist
@@ -0,0 +1,27 @@
+@comment $FreeBSD$
+bin/skadnsd
+bin/skadnsfilter
+bin/skadnsip
+bin/skadnsmx
+include/skadns/skadns.h
+lib/libskadns.a
+%%PORTDOCS%%%%DOCSDIR%%/CHANGES
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/THANKS
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/install.html
+%%PORTDOCS%%%%DOCSDIR%%/libskadns.html
+%%PORTDOCS%%%%DOCSDIR%%/skadnsd.html
+%%PORTDOCS%%%%DOCSDIR%%/skadnsfilter.html
+%%PORTDOCS%%%%DOCSDIR%%/skadnsip.html
+%%PORTDOCS%%%%DOCSDIR%%/skadnsmx.html
+%%PORTDOCS%%%%DOCSDIR%%/upgrade.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%EXAMPLESDIR%%/service/log/run.exl
+%%EXAMPLESDIR%%/service/log/run.sh
+%%EXAMPLESDIR%%/service/run.exl
+%%EXAMPLESDIR%%/service/run.sh
+@dirrm %%EXAMPLESDIR%%/service/log
+@dirrm %%EXAMPLESDIR%%/service
+@dirrm %%EXAMPLESDIR%%