aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authorpetef <petef@FreeBSD.org>2004-05-03 02:06:12 +0800
committerpetef <petef@FreeBSD.org>2004-05-03 02:06:12 +0800
commitb756a39fa650196427d6d8b67f9a252c2132c34b (patch)
tree6cbe954e2c8b511711bebcbb481c2fcc00e778ae /dns
parentc5f24eca85e3c44bcee3c387f70e49394de90140 (diff)
downloadfreebsd-ports-gnome-b756a39fa650196427d6d8b67f9a252c2132c34b.tar.gz
freebsd-ports-gnome-b756a39fa650196427d6d8b67f9a252c2132c34b.tar.zst
freebsd-ports-gnome-b756a39fa650196427d6d8b67f9a252c2132c34b.zip
- update to 0.9.12
- use bzip2 - depend on gcc3 - update pkg-descr and WWW: tag PR: 65949 Submitted by: maintainer
Diffstat (limited to 'dns')
-rw-r--r--dns/firedns/Makefile40
-rw-r--r--dns/firedns/distinfo4
-rw-r--r--dns/firedns/pkg-descr11
-rw-r--r--dns/firedns/pkg-plist10
4 files changed, 42 insertions, 23 deletions
diff --git a/dns/firedns/Makefile b/dns/firedns/Makefile
index 92d23243261c..834b80e35cd9 100644
--- a/dns/firedns/Makefile
+++ b/dns/firedns/Makefile
@@ -6,9 +6,9 @@
#
PORTNAME= firedns
-PORTVERSION= 0.9.7
+PORTVERSION= 0.9.12
CATEGORIES= dns devel
-MASTER_SITES= http://firestuff.org/projects/ \
+MASTER_SITES= http://www.firestuff.org/projects/ \
http://www.wa.apana.org.au/~dean/sources/ \
ftp://ftp.wa.apana.org.au/pub/pc/unix/packages/
@@ -17,25 +17,37 @@ COMMENT= A C library for handling asynchronous DNS queries
BUILD_DEPENDS= ${LOCALBASE}/include/firestring.h:${PORTSDIR}/misc/firestring
+USE_BZIP2= yes
HAS_CONFIGURE= yes
-CONFIGURE_ENV= PREFIX="${PREFIX}"
INSTALLS_SHLIB= yes
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+USE_GCC= 3.2
+.endif
+
WRKSRC= ${WRKDIR}/${PORTNAME}
-MAN3= firedns_aton4.3 firedns_aton6.3 \
- firedns_dnsbl_lookup.3 firedns_getip4.3 \
- firedns_getip6.3 firedns_getmx.3 \
- firedns_getmxlist.3 firedns_getname4.3 \
- firedns_getname6.3 firedns_getresult.3 \
- firedns_gettxt.3 firedns_ntoa4.3 \
- firedns_ntoa6.3 firedns_resolveip4.3 \
- firedns_resolveip6.3 firedns_resolvemx.3 \
- firedns_resolvemxlist.3 firedns_resolvename4.3 \
- firedns_resolvename6.3 firedns_resolvetxt.3 \
+MAN1= fdnscname.1 fdnsip.1 fdnsip6.1 fdnsip6list.1 fdnsiplist.1 fdnsmx.1 \
+ fdnsmxalist.1 fdnsmxlist.1 fdnsname.1 fdnsnamep.1 fdnsspf1.1 \
+ fdnstxt.1 fdnstxtlist.1
+
+MAN3= firedns_aton4.3 firedns_aton6.3 firedns_dnsbl_lookup.3 \
+ firedns_free_mxalist.3 firedns_getcname.3 firedns_getip4.3 \
+ firedns_getip4list.3 firedns_getip6.3 firedns_getip6list.3 \
+ firedns_getmx.3 firedns_getmxlist.3 firedns_getname4.3 \
+ firedns_getname6.3 firedns_getresult.3 firedns_gettxt.3 \
+ firedns_gettxtlist.3 firedns_ntoa4.3 firedns_ntoa6.3 \
+ firedns_resolvecname.3 firedns_resolveip4.3 \
+ firedns_resolveip4list.3 firedns_resolveip6.3 \
+ firedns_resolveip6list.3 firedns_resolvemx.3 \
+ firedns_resolvemxalist.3 firedns_resolvemxlist.3 \
+ firedns_resolvename4.3 firedns_resolvename6.3 \
+ firedns_resolvetxt.3 firedns_resolvetxtlist.3 \
libfiredns.3
pre-configure:
@-${RM} ${WRKSRC}/firemake/*.orig
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/dns/firedns/distinfo b/dns/firedns/distinfo
index ca7cd062203b..539e4f1ca599 100644
--- a/dns/firedns/distinfo
+++ b/dns/firedns/distinfo
@@ -1,2 +1,2 @@
-MD5 (firedns-0.9.7.tar.gz) = dd6fbf0e3a5fbdf5761c7139987d7657
-SIZE (firedns-0.9.7.tar.gz) = 91920
+MD5 (firedns-0.9.12.tar.bz2) = f264cb8ac319d6555986c993dfeca5cf
+SIZE (firedns-0.9.12.tar.bz2) = 96535
diff --git a/dns/firedns/pkg-descr b/dns/firedns/pkg-descr
index a09bd01bf63d..f6e954f3202a 100644
--- a/dns/firedns/pkg-descr
+++ b/dns/firedns/pkg-descr
@@ -1,13 +1,12 @@
libfiredns is a library for handling asynchronous DNS
requests. It provides a very simple interface for sending
requests and parsing reponses, as well as low-timeout
-blocking functions. It can also be compiled to override
-the BIND/LIBC functions with its alternative implementations.
-libfiredns functions have much lower timeouts than the stock
-functions and tend to be faster because they send requests
-to all configured system nameservers at the same time.
+blocking functions. libfiredns functions have much lower
+timeouts than the stock functions and tend to be faster
+because they send requests to all configured system
+nameservers at the same time.
-WWW: http://ares.penguinhosting.net/~ian/
+WWW: http://www.firestuff.org/
- Dean
dean@odyssey.apana.org.au
diff --git a/dns/firedns/pkg-plist b/dns/firedns/pkg-plist
index cdc35b1bc685..222a26a0c439 100644
--- a/dns/firedns/pkg-plist
+++ b/dns/firedns/pkg-plist
@@ -1,11 +1,19 @@
@comment $FreeBSD$
+bin/fdnscname
bin/fdnsip
+bin/fdnsip6
+bin/fdnsip6list
+bin/fdnsiplist
bin/fdnsmx
+bin/fdnsmxalist
bin/fdnsmxlist
bin/fdnsname
+bin/fdnsnamep
+bin/fdnsspf1
bin/fdnstxt
+bin/fdnstxtlist
include/firedns.h
lib/libfiredns.a
lib/libfiredns.so
lib/libfiredns.so.0
-lib/libfiredns.so.0.9.7
+lib/libfiredns.so.0.9.12