aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2014-03-05 01:32:45 +0800
committermat <mat@FreeBSD.org>2014-03-05 01:32:45 +0800
commitc943b08d4b2b00e49fba9ab9cddfd88265911971 (patch)
tree7e94450c2029eefd374bca44d2c17fdb7e12ead2 /dns
parent38c6159a0a2639dba072fb2e2e78870fee854749 (diff)
downloadfreebsd-ports-gnome-c943b08d4b2b00e49fba9ab9cddfd88265911971.tar.gz
freebsd-ports-gnome-c943b08d4b2b00e49fba9ab9cddfd88265911971.tar.zst
freebsd-ports-gnome-c943b08d4b2b00e49fba9ab9cddfd88265911971.zip
Don't polute isc-config.sh with gssapi flags.
Submitted by: hrs Sponsored by: Absolight
Diffstat (limited to 'dns')
-rw-r--r--dns/bind98/Makefile14
-rw-r--r--dns/bind98/files/patch-configure19
-rw-r--r--dns/bind98/files/patch-lib__isc__include__isc__file.h12
-rw-r--r--dns/bind99/Makefile14
-rw-r--r--dns/bind99/files/patch-configure19
-rw-r--r--dns/bind99/files/patch-lib__isc__include__isc__file.h12
6 files changed, 73 insertions, 17 deletions
diff --git a/dns/bind98/Makefile b/dns/bind98/Makefile
index 2dd06e13630b..5e01f8ea67f4 100644
--- a/dns/bind98/Makefile
+++ b/dns/bind98/Makefile
@@ -2,6 +2,7 @@
PORTNAME= bind
PORTVERSION= 9.8.7
+PORTREVISION= 1
CATEGORIES= dns net ipv6
MASTER_SITES= ${MASTER_SITE_ISC}
MASTER_SITE_SUBDIR= bind9/${ISCVERSION}
@@ -99,7 +100,12 @@ DLZ_FILESYSTEM_CONFIGURE_ON= --with-dlz-filesystem=yes
DLZ_STUB_CONFIGURE_ON= --with-dlz-stub=yes
+.if defined(HEIMDAL_HOME)
+GSSAPI_CONFIGURE_ON= --with-gssapi=${HEIMDAL_HOME}
+GSSAPI_CONFIGURE_OFF= --without-gssapi
+.else
GSSAPI_CONFIGURE_WITH= gssapi
+.endif
.include <bsd.port.options.mk>
@@ -117,14 +123,6 @@ CONFIGURE_ARGS+= --enable-threads
CONFIGURE_ARGS+= --disable-threads
.endif
-.if ${PORT_OPTIONS:MGSSAPI}
-.if defined(HEIMDAL_HOME)
-LDFLAGS+= -L${LIBDIR} -lgssapi -lkrb5
-.else
-LDFLAGS+= -L${LIBDIR} -lgssapi_krb5
-.endif
-.endif
-
.if ${PORT_OPTIONS:MREPLACE_BASE}
.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1000100
IGNORE= REPLACE_BASE option is not supported on this release
diff --git a/dns/bind98/files/patch-configure b/dns/bind98/files/patch-configure
new file mode 100644
index 000000000000..961550b47887
--- /dev/null
+++ b/dns/bind98/files/patch-configure
@@ -0,0 +1,19 @@
+--- ./configure.orig 2014-01-27 19:59:48.000000000 +0100
++++ ./configure 2014-03-04 17:46:51.000000000 +0100
+@@ -13936,6 +13936,7 @@
+ "-lgssapi" \
+ "-lgssapi -lkrb5 -ldes -lcrypt -lasn1 -lroken -lcom_err" \
+ "-lgssapi -lkrb5 -lcrypto -lcrypt -lasn1 -lroken -lcom_err" \
++ "-lgssapi -lkrb5 -lgssapi_krb5 -lcrypto -lcrypt -lasn1 -lroken -lcom_err" \
+ "-lgssapi -lkrb5 -lhx509 -lcrypto -lcrypt -lasn1 -lroken -lcom_err" \
+ "-lgss -lkrb5"
+ do
+@@ -13958,7 +13959,7 @@
+ int
+ main ()
+ {
+-gss_acquire_cred();krb5_init_context()
++gss_acquire_cred();krb5_init_context();gsskrb5_register_acceptor_identity();
+ ;
+ return 0;
+ }
diff --git a/dns/bind98/files/patch-lib__isc__include__isc__file.h b/dns/bind98/files/patch-lib__isc__include__isc__file.h
new file mode 100644
index 000000000000..0e757d1f4220
--- /dev/null
+++ b/dns/bind98/files/patch-lib__isc__include__isc__file.h
@@ -0,0 +1,12 @@
+--- ./lib/isc/include/isc/file.h.orig 2014-01-27 19:59:48.000000000 +0100
++++ ./lib/isc/include/isc/file.h 2014-03-04 17:46:51.000000000 +0100
+@@ -25,7 +25,8 @@
+ #include <stdio.h>
+
+ #include <isc/lang.h>
+-#include <isc/stat.h>
++#include <sys/types.h>
++#include <sys/stat.h>
+ #include <isc/types.h>
+
+ ISC_LANG_BEGINDECLS
diff --git a/dns/bind99/Makefile b/dns/bind99/Makefile
index 25e04dbcc1d5..d6d58acefb0b 100644
--- a/dns/bind99/Makefile
+++ b/dns/bind99/Makefile
@@ -2,7 +2,7 @@
PORTNAME= bind
PORTVERSION= 9.9.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= dns net ipv6
MASTER_SITES= ${MASTER_SITE_ISC}
MASTER_SITE_SUBDIR= bind9/${ISCVERSION}
@@ -111,7 +111,11 @@ DLZ_FILESYSTEM_CONFIGURE_ON= --with-dlz-filesystem=yes
DLZ_STUB_CONFIGURE_ON= --with-dlz-stub=yes
+.if defined(HEIMDAL_HOME)
+GSSAPI_CONFIGURE_WITH= gssapi=${HEIMDAL_HOME}
+.else
GSSAPI_CONFIGURE_WITH= gssapi
+.endif
.include <bsd.port.options.mk>
@@ -129,14 +133,6 @@ CONFIGURE_ARGS+= --enable-threads
CONFIGURE_ARGS+= --disable-threads
.endif
-.if ${PORT_OPTIONS:MGSSAPI}
-.if defined(HEIMDAL_HOME)
-LDFLAGS+= -L${LIBDIR} -lgssapi -lkrb5
-.else
-LDFLAGS+= -L${LIBDIR} -lgssapi_krb5
-.endif
-.endif
-
.if ${PORT_OPTIONS:MREPLACE_BASE}
.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1000100
IGNORE= REPLACE_BASE option is not supported on this release
diff --git a/dns/bind99/files/patch-configure b/dns/bind99/files/patch-configure
new file mode 100644
index 000000000000..2c3a2550c507
--- /dev/null
+++ b/dns/bind99/files/patch-configure
@@ -0,0 +1,19 @@
+--- ./configure.orig 2014-01-27 19:58:24.000000000 +0100
++++ ./configure 2014-03-04 17:51:41.000000000 +0100
+@@ -14161,6 +14161,7 @@
+ "-lgssapi" \
+ "-lgssapi -lkrb5 -ldes -lcrypt -lasn1 -lroken -lcom_err" \
+ "-lgssapi -lkrb5 -lcrypto -lcrypt -lasn1 -lroken -lcom_err" \
++ "-lgssapi -lkrb5 -lgssapi_krb5 -lcrypto -lcrypt -lasn1 -lroken -lcom_err" \
+ "-lgssapi -lkrb5 -lhx509 -lcrypto -lcrypt -lasn1 -lroken -lcom_err" \
+ "-lgss -lkrb5"
+ do
+@@ -14183,7 +14184,7 @@
+ int
+ main ()
+ {
+-gss_acquire_cred();krb5_init_context()
++gss_acquire_cred();krb5_init_context();gsskrb5_register_acceptor_identity();
+ ;
+ return 0;
+ }
diff --git a/dns/bind99/files/patch-lib__isc__include__isc__file.h b/dns/bind99/files/patch-lib__isc__include__isc__file.h
new file mode 100644
index 000000000000..6b4387f1446b
--- /dev/null
+++ b/dns/bind99/files/patch-lib__isc__include__isc__file.h
@@ -0,0 +1,12 @@
+--- ./lib/isc/include/isc/file.h.orig 2014-01-27 19:58:24.000000000 +0100
++++ ./lib/isc/include/isc/file.h 2014-03-04 17:51:41.000000000 +0100
+@@ -25,7 +25,8 @@
+ #include <stdio.h>
+
+ #include <isc/lang.h>
+-#include <isc/stat.h>
++#include <sys/types.h>
++#include <sys/stat.h>
+ #include <isc/types.h>
+
+ ISC_LANG_BEGINDECLS