aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2015-04-02 06:36:10 +0800
committermarino <marino@FreeBSD.org>2015-04-02 06:36:10 +0800
commit1445756753855356c953a3777103ddd2c918e17f (patch)
tree01d2226772a1da15f19b99f01120777098b9acd4 /dns
parent1ae1cbfb756e4ee359a94c0a687caf232444bcde (diff)
downloadfreebsd-ports-gnome-1445756753855356c953a3777103ddd2c918e17f.tar.gz
freebsd-ports-gnome-1445756753855356c953a3777103ddd2c918e17f.tar.zst
freebsd-ports-gnome-1445756753855356c953a3777103ddd2c918e17f.zip
dns/bind99, dns/bind910: support no-base option on DragonFly
Approved by: mat (maintainer)
Diffstat (limited to 'dns')
-rw-r--r--dns/bind910/Makefile4
-rw-r--r--dns/bind99/Makefile4
2 files changed, 4 insertions, 4 deletions
diff --git a/dns/bind910/Makefile b/dns/bind910/Makefile
index a6d7f635ee3b..42fa363747bc 100644
--- a/dns/bind910/Makefile
+++ b/dns/bind910/Makefile
@@ -174,7 +174,7 @@ CONFIGURE_ARGS+= --enable-threads
CONFIGURE_ARGS+= --disable-threads
.endif
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1000100
+.if ${OPSYS} == DragonFly || (${OPSYS} == FreeBSD && ${OSVERSION} >= 1000100)
PKGINSTALL= ${NONEXISTENT}
PLIST_SUB+= NOBASE="" BASE="@comment "
SUB_LIST+= NOBASE="" BASE="@comment "
@@ -217,7 +217,7 @@ post-install:
${WRKSRC}/HISTORY ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
.endif
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1000100
+.if ${OPSYS} == DragonFly || (${OPSYS} == FreeBSD && ${OSVERSION} >= 1000100)
${MKDIR} ${STAGEDIR}${PREFIX}/etc/mtree
${MKDIR} ${STAGEDIR}${ETCDIR}
.for i in dynamic master slave working
diff --git a/dns/bind99/Makefile b/dns/bind99/Makefile
index a35a227147a4..bfd302e5cff7 100644
--- a/dns/bind99/Makefile
+++ b/dns/bind99/Makefile
@@ -157,7 +157,7 @@ CONFIGURE_ARGS+= --disable-threads
IGNORE= REPLACE_BASE is no longer supported
.endif # REPLACE_BASE
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1000100
+.if ${OPSYS} == DragonFly || (${OPSYS} == FreeBSD && ${OSVERSION} >= 1000100)
PKGINSTALL= ${NONEXISTENT}
PLIST_SUB+= NOBASE="" BASE="@comment "
SUB_LIST+= NOBASE="" BASE="@comment "
@@ -199,7 +199,7 @@ post-install:
${WRKSRC}/HISTORY ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
.endif
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1000100
+.if ${OPSYS} == DragonFly || (${OPSYS} == FreeBSD && ${OSVERSION} >= 1000100)
${MKDIR} ${STAGEDIR}${PREFIX}/etc/mtree
${MKDIR} ${STAGEDIR}${ETCDIR}
.for i in dynamic master slave working