aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-07-07 21:54:23 +0800
committertijl <tijl@FreeBSD.org>2014-07-07 21:54:23 +0800
commit22672eaa821a58baa7207e3eb19bb96f26364d3b (patch)
tree16cef08e75eddc4fbf457dd23d786ae9cc8faa36 /dns
parentd6c213f3750cfe6039c4ed4ad6fcf8bcb3d41779 (diff)
downloadfreebsd-ports-gnome-22672eaa821a58baa7207e3eb19bb96f26364d3b.tar.gz
freebsd-ports-gnome-22672eaa821a58baa7207e3eb19bb96f26364d3b.tar.zst
freebsd-ports-gnome-22672eaa821a58baa7207e3eb19bb96f26364d3b.zip
- Convert security/libsodium to USES=libtool and bump dependent ports
- Run "make check" from regression-test target - dns/curvedns: white space fixes
Diffstat (limited to 'dns')
-rw-r--r--dns/curvedns/Makefile36
-rw-r--r--dns/dnscrypt-proxy/Makefile2
2 files changed, 18 insertions, 20 deletions
diff --git a/dns/curvedns/Makefile b/dns/curvedns/Makefile
index 24f7056639e4..f7748489df6c 100644
--- a/dns/curvedns/Makefile
+++ b/dns/curvedns/Makefile
@@ -1,14 +1,19 @@
# Created by: Leo Vandewoestijne <freebsd@dns-lab.com>
# $FreeBSD$
-PORTNAME= curvedns
-PORTVERSION= 0.88.b
-PORTREVISION= 3
-CATEGORIES= dns
-DISTNAME= curvedns-0.88-unstable
+PORTNAME= curvedns
+PORTVERSION= 0.88.b
+PORTREVISION= 4
+CATEGORIES= dns
+DISTNAME= curvedns-0.88-unstable
MAINTAINER= vsevolod@FreeBSD.org
-COMMENT= Forwarder adding DNSCurve to an authoritative nameserver
+COMMENT= Forwarder adding DNSCurve to an authoritative nameserver
+
+LIB_DEPENDS= libev.so:${PORTSDIR}/devel/libev \
+ libsodium.so:${PORTSDIR}/security/libsodium
+RUN_DEPENDS= setuidgid:${PORTSDIR}/sysutils/daemontools
+BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
USE_GITHUB= yes
GH_ACCOUNT= vstakhov
@@ -17,22 +22,15 @@ GH_COMMIT= a88e27e
ALL_TARGET= targets
-LIB_DEPENDS= libev.so:${PORTSDIR}/devel/libev \
- libsodium.so:${PORTSDIR}/security/libsodium
-RUN_DEPENDS= setuidgid:${PORTSDIR}/sysutils/daemontools
-BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
-
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-USERS= bind
-GROUPS= bind
-CURVE_UID= 53
-CURVE_GID= 53
-
-SUB_FILES= pkg-message
+USERS= bind
+GROUPS= bind
+CURVE_UID= 53
+CURVE_GID= 53
-.include <bsd.port.pre.mk>
+SUB_FILES= pkg-message
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/curvedns ${WRKSRC}/curvedns-keygen ${STAGEDIR}${PREFIX}/bin/
@@ -43,4 +41,4 @@ do-install:
${ECHO_CMD} ${CURVE_GID} > ${STAGEDIR}${PREFIX}/etc/curvedns/env/GID
${CHMOD} 0700 ${STAGEDIR}${PREFIX}/etc/curvedns/env
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/dns/dnscrypt-proxy/Makefile b/dns/dnscrypt-proxy/Makefile
index f51b53c4e276..a42e0cf9cd57 100644
--- a/dns/dnscrypt-proxy/Makefile
+++ b/dns/dnscrypt-proxy/Makefile
@@ -3,7 +3,7 @@
PORTNAME= dnscrypt-proxy
PORTVERSION= 1.4.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= dns
MASTER_SITES= http://download.dnscrypt.org/dnscrypt-proxy/ \
http://www.dns-lab.com/downloads/dnscrypt-proxy/