aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2018-12-04 22:31:04 +0800
committermat <mat@FreeBSD.org>2018-12-04 22:31:04 +0800
commit4d974157e1d403512b966dc0274803ac2c4aa166 (patch)
treea8c35590a4c9c80803176d9e3fe5f90381b52054 /dns
parentf7343c02d386c78cf389ede121e7e8712b44a528 (diff)
downloadfreebsd-ports-gnome-4d974157e1d403512b966dc0274803ac2c4aa166.tar.gz
freebsd-ports-gnome-4d974157e1d403512b966dc0274803ac2c4aa166.tar.zst
freebsd-ports-gnome-4d974157e1d403512b966dc0274803ac2c4aa166.zip
Update to latest commit.
Diffstat (limited to 'dns')
-rw-r--r--dns/bind9-devel/Makefile4
-rw-r--r--dns/bind9-devel/distinfo6
-rw-r--r--dns/bind9-devel/files/extrapatch-bind-min-override-ttl12
-rw-r--r--dns/bind9-devel/files/patch-configure8
4 files changed, 15 insertions, 15 deletions
diff --git a/dns/bind9-devel/Makefile b/dns/bind9-devel/Makefile
index b40e697d5061..1082dcd6973f 100644
--- a/dns/bind9-devel/Makefile
+++ b/dns/bind9-devel/Makefile
@@ -40,13 +40,13 @@ LIB_DEPENDS= libxml2.so:textproc/libxml2
# XXX: remove tar:bz2
USES= compiler:c11 cpe libedit ssl tar:bz2
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.13.4a0.2018.11.20
+ISCVERSION= 9.13.4a0.2018.12.04
# XXX: Remove gitlab
USE_GITLAB= yes
GL_SITE= https://gitlab.isc.org
GL_ACCOUNT= isc-projects
GL_PROJECT= bind9
-GL_COMMIT= bf519a3574acb6153d53756485c9fe567cd32c6b
+GL_COMMIT= 8743a853d2afe4bddb8f4d314f2fa8a7bbeb4025
CPE_VENDOR= isc
CPE_VERSION= ${ISCVERSION:C/-.*//}
diff --git a/dns/bind9-devel/distinfo b/dns/bind9-devel/distinfo
index 43da49cc3dc0..68ba43089244 100644
--- a/dns/bind9-devel/distinfo
+++ b/dns/bind9-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1543232582
-SHA256 (isc-projects-bind9-bf519a3574acb6153d53756485c9fe567cd32c6b_GL0.tar.gz) = 8f4c8bc2a47bec44b109b5103db8d3e4402a54bbcf8029e4f76e7eaf27b06ba3
-SIZE (isc-projects-bind9-bf519a3574acb6153d53756485c9fe567cd32c6b_GL0.tar.gz) = 6307901
+TIMESTAMP = 1543933450
+SHA256 (isc-projects-bind9-8743a853d2afe4bddb8f4d314f2fa8a7bbeb4025_GL0.tar.gz) = 32d034e17714a286860e53c5b93d7f50032423a87608d6ea7ee3b98187953934
+SIZE (isc-projects-bind9-8743a853d2afe4bddb8f4d314f2fa8a7bbeb4025_GL0.tar.gz) = 6309946
diff --git a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
index caa3388fb896..d1f84cd708c9 100644
--- a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
+++ b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
@@ -1,4 +1,4 @@
---- bin/named/config.c.orig 2018-11-19 17:02:41 UTC
+--- bin/named/config.c.orig 2018-12-04 09:57:38 UTC
+++ bin/named/config.c
@@ -182,6 +182,7 @@ options {\n\
notify-source *;\n\
@@ -8,9 +8,9 @@
provide-ixfr true;\n\
qname-minimization relaxed;\n\
query-source address *;\n\
---- bin/named/server.c.orig 2018-11-19 17:02:41 UTC
+--- bin/named/server.c.orig 2018-12-04 09:57:38 UTC
+++ bin/named/server.c
-@@ -4116,6 +4116,11 @@ configure_view(dns_view_t *view, dns_vie
+@@ -4124,6 +4124,11 @@ configure_view(dns_view_t *view, dns_vie
}
obj = NULL;
@@ -22,7 +22,7 @@
result = named_config_get(maps, "max-cache-ttl", &obj);
INSIST(result == ISC_R_SUCCESS);
view->maxcachettl = cfg_obj_asuint32(obj);
---- lib/dns/include/dns/view.h.orig 2018-11-19 17:02:41 UTC
+--- lib/dns/include/dns/view.h.orig 2018-12-04 09:57:38 UTC
+++ lib/dns/include/dns/view.h
@@ -153,6 +153,7 @@ struct dns_view {
bool requestnsid;
@@ -32,7 +32,7 @@
dns_ttl_t maxncachettl;
dns_ttl_t mincachettl;
dns_ttl_t minncachettl;
---- lib/dns/resolver.c.orig 2018-11-19 17:02:41 UTC
+--- lib/dns/resolver.c.orig 2018-12-04 09:57:38 UTC
+++ lib/dns/resolver.c
@@ -5967,6 +5967,12 @@ cache_name(fetchctx_t *fctx, dns_name_t
}
@@ -47,7 +47,7 @@
* Enforce the configure maximum cache TTL.
*/
if (rdataset->ttl > res->view->maxcachettl) {
---- lib/isccfg/namedconf.c.orig 2018-11-19 17:02:41 UTC
+--- lib/isccfg/namedconf.c.orig 2018-12-04 09:57:38 UTC
+++ lib/isccfg/namedconf.c
@@ -1921,6 +1921,7 @@ view_clauses[] = {
{ "max-acache-size", &cfg_type_sizenodefault,
diff --git a/dns/bind9-devel/files/patch-configure b/dns/bind9-devel/files/patch-configure
index 68008c5f3da6..dc6855bd683b 100644
--- a/dns/bind9-devel/files/patch-configure
+++ b/dns/bind9-devel/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2018-11-26 10:22:36 UTC
+--- configure.orig 2018-12-04 09:57:38 UTC
+++ configure
-@@ -16386,27 +16386,9 @@ done
+@@ -16308,27 +16308,9 @@ done
# problems start to show up.
saved_libs="$LIBS"
for TRY_LIBS in \
@@ -30,7 +30,7 @@
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking linking as $TRY_LIBS" >&5
$as_echo_n "checking linking as $TRY_LIBS... " >&6; }
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
-@@ -16449,47 +16431,7 @@ $as_echo "no" >&6; } ;;
+@@ -16371,47 +16353,7 @@ $as_echo "no" >&6; } ;;
no) as_fn_error $? "could not determine proper GSSAPI linkage" "$LINENO" 5 ;;
esac
@@ -79,7 +79,7 @@
DNS_GSSAPI_LIBS="$LIBS"
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: using GSSAPI from $use_gssapi/lib and $use_gssapi/include" >&5
-@@ -21008,7 +20950,7 @@ $as_echo "" >&6; }
+@@ -20931,7 +20873,7 @@ $as_echo "" >&6; }
# Check other locations for includes.
# Order is important (sigh).