aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-02-19 20:47:06 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-02-19 20:47:06 +0800
commit7fe918c1458141feb299c3f89d46b1459181a933 (patch)
tree66d3193538d17fb24b8434e4d3e958d5352a1f28 /dns
parent4e42ebcf15b8eed44927ba68d284dbfe2e584756 (diff)
downloadfreebsd-ports-gnome-7fe918c1458141feb299c3f89d46b1459181a933.tar.gz
freebsd-ports-gnome-7fe918c1458141feb299c3f89d46b1459181a933.tar.zst
freebsd-ports-gnome-7fe918c1458141feb299c3f89d46b1459181a933.zip
- Support staging
- Define EXAMPLES - Don't install license file but define LICENSE - also don't install THANKS file as documentation - Add an additional mirror - Indent - Now that this port looks shiny clean take maintainership
Diffstat (limited to 'dns')
-rw-r--r--dns/tinystats/Makefile39
1 files changed, 19 insertions, 20 deletions
diff --git a/dns/tinystats/Makefile b/dns/tinystats/Makefile
index 2e41094999ff..7dc24225f1bb 100644
--- a/dns/tinystats/Makefile
+++ b/dns/tinystats/Makefile
@@ -4,26 +4,23 @@
PORTNAME= tinystats
PORTVERSION= 1.1
CATEGORIES= dns ipv6
-MASTER_SITES= http://www.morettoni.net/bsd/
+MASTER_SITES= http://www.morettoni.net/bsd/ \
+ CRITICAL
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ehaupt@FreeBSD.org
COMMENT= DJB's tinydns statistics generator
+LICENSE= BSD2CLAUSE
+
WRKSRC= ${WRKDIR}/${PORTNAME}
ALL_TARGET=
-OPTIONS_DEFINE= IPV6 DOCS
+OPTIONS_DEFINE= IPV6 EXAMPLES DOCS
-PLIST_FILES= bin/tinystats \
- %%EXAMPLESDIR%%/tinydns.log.run.sample \
- %%EXAMPLESDIR%%/tinydns.sh.sample \
- %%EXAMPLESDIR%%/update_slave.sh.sample \
- %%EXAMPLESDIR%%/start_slave.sh.sample \
- %%EXAMPLESDIR%%/Makefile.sample
-PLIST_DIRS= %%EXAMPLESDIR%%
-PORTDOCS= README LICENSE THANKS
+PLIST_FILES= bin/tinystats
+PORTEXAMPLES= *
+PORTDOCS= README
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MIPV6}
@@ -31,13 +28,15 @@ MAKE_ARGS+= -DWITH_IPV6
.endif
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/tinystats ${PREFIX}/bin
- ${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/tinydns.sh.sample ${WRKSRC}/tinydns.log.run.sample \
- ${WRKSRC}/update_slave.sh.sample ${WRKSRC}/start_slave.sh.sample ${WRKSRC}/Makefile.sample ${EXAMPLESDIR}
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${WRKSRC}/LICENSE ${WRKSRC}/THANKS ${DOCSDIR}
-.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/tinystats ${STAGEDIR}${PREFIX}/bin
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/tinydns.sh.sample \
+ ${WRKSRC}/tinydns.log.run.sample \
+ ${WRKSRC}/update_slave.sh.sample \
+ ${WRKSRC}/start_slave.sh.sample \
+ ${WRKSRC}/Makefile.sample \
+ ${STAGEDIR}${EXAMPLESDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>