aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-12-02 19:58:21 +0800
committermat <mat@FreeBSD.org>2016-12-02 19:58:21 +0800
commit8f4d478e0d67ed7e9570dc79cf876a62a43a852b (patch)
tree4a28bf50f532fa82a149cbc3f9c041d48a23921b /dns
parent5b951b259299b903bd0cae554230906f70c4fe94 (diff)
downloadfreebsd-ports-gnome-8f4d478e0d67ed7e9570dc79cf876a62a43a852b.tar.gz
freebsd-ports-gnome-8f4d478e0d67ed7e9570dc79cf876a62a43a852b.tar.zst
freebsd-ports-gnome-8f4d478e0d67ed7e9570dc79cf876a62a43a852b.zip
Do not use post-stage. Use post-install instead.
The only reason to use post-stage is because the port needs to do "things" at a later time, like some plist manipulation. While there, fold post-install in do-install targets when they are defined. PR: 214780 Submitted by: mat Exp-run by: antoine Sponsored by: Absolight
Diffstat (limited to 'dns')
-rw-r--r--dns/adns/Makefile2
-rw-r--r--dns/powerdns/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/dns/adns/Makefile b/dns/adns/Makefile
index 68d05dba0d73..a5c1c75a7c34 100644
--- a/dns/adns/Makefile
+++ b/dns/adns/Makefile
@@ -39,7 +39,7 @@ post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
(cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${STAGEDIR}${DOCSDIR})
-post-stage:
+post-install:
.for f in ${TOSTRIP}
${STRIP_CMD} ${STAGEDIR}${PREFIX}/${f}
.endfor
diff --git a/dns/powerdns/Makefile b/dns/powerdns/Makefile
index b913c910091c..0f5fd24b6e27 100644
--- a/dns/powerdns/Makefile
+++ b/dns/powerdns/Makefile
@@ -123,7 +123,7 @@ TINYDNS_DESC= TinyDNS backend
TOOLS_DESC= Build extra tools
ZEROMQ_DESC= Enable ZeroMQ connector (Implies REMOTE enabled)
-post-stage::
+post-install::
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
@${STAGEDIR}${LOCALBASE}/sbin/pdns_server --module-dir=${STAGEDIR}${LOCALBASE}/lib/pdns --launch="pipe bind ${MODULES}" --config > ${STAGEDIR}${EXAMPLESDIR}/pdns.conf
@${REINPLACE_CMD} -e 's;${STAGEDIR};;' -i '' ${STAGEDIR}${EXAMPLESDIR}/pdns.conf