aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2018-02-22 22:29:57 +0800
committermat <mat@FreeBSD.org>2018-02-22 22:29:57 +0800
commitccbcf9322355c25574c8e464aebdc23594b9607e (patch)
tree42721f3067a6392b7b851385a4d9607f89d71508 /dns
parentde3c9a60473d1852978d28bae0715fa4c97a264e (diff)
downloadfreebsd-ports-gnome-ccbcf9322355c25574c8e464aebdc23594b9607e.tar.gz
freebsd-ports-gnome-ccbcf9322355c25574c8e464aebdc23594b9607e.tar.zst
freebsd-ports-gnome-ccbcf9322355c25574c8e464aebdc23594b9607e.zip
Add py-cloudflare, a wrapper for the Cloudflare v4 API.
Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D14262
Diffstat (limited to 'dns')
-rw-r--r--dns/Makefile1
-rw-r--r--dns/py-cloudflare/Makefile20
-rw-r--r--dns/py-cloudflare/distinfo3
-rw-r--r--dns/py-cloudflare/pkg-descr3
4 files changed, 27 insertions, 0 deletions
diff --git a/dns/Makefile b/dns/Makefile
index b080c47ed309..cd19fce20482 100644
--- a/dns/Makefile
+++ b/dns/Makefile
@@ -174,6 +174,7 @@
SUBDIR += powerdns-recursor
SUBDIR += powerdns-recursor40
SUBDIR += public_suffix_list
+ SUBDIR += py-cloudflare
SUBDIR += py-dns
SUBDIR += py-dns-lexicon
SUBDIR += py-dnschain
diff --git a/dns/py-cloudflare/Makefile b/dns/py-cloudflare/Makefile
new file mode 100644
index 000000000000..1a15879f1a76
--- /dev/null
+++ b/dns/py-cloudflare/Makefile
@@ -0,0 +1,20 @@
+# $FreeBSD$
+
+PORTNAME= cloudflare
+PORTVERSION= 1.8.1
+CATEGORIES= dns python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= python@FreeBSD.org
+COMMENT= wrapper for the Cloudflare v4 API
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/dns/py-cloudflare/distinfo b/dns/py-cloudflare/distinfo
new file mode 100644
index 000000000000..11e13bf0df95
--- /dev/null
+++ b/dns/py-cloudflare/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1518080731
+SHA256 (cloudflare-1.8.1.tar.gz) = 3d73cb071a14d443a8d3ef19a0c6a4cbbfea784de3144666ecbcd35ddfc9b5c2
+SIZE (cloudflare-1.8.1.tar.gz) = 48493
diff --git a/dns/py-cloudflare/pkg-descr b/dns/py-cloudflare/pkg-descr
new file mode 100644
index 000000000000..d728b55d02de
--- /dev/null
+++ b/dns/py-cloudflare/pkg-descr
@@ -0,0 +1,3 @@
+Python wrapper for the DNS Cloudflare v4 API
+
+WWW: https://github.com/cloudflare/python-cloudflare