aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2015-02-08 10:42:51 +0800
committererwin <erwin@FreeBSD.org>2015-02-08 10:42:51 +0800
commitfc4bdc8940e2d2c175848ab56b762bbe3a0a84fa (patch)
tree3c74d4dd728837bce858dd0b71f6fdc297849e55 /dns
parentee7abc33e0d862d17b8ef47b9f5d142a92317ad1 (diff)
downloadfreebsd-ports-gnome-fc4bdc8940e2d2c175848ab56b762bbe3a0a84fa.tar.gz
freebsd-ports-gnome-fc4bdc8940e2d2c175848ab56b762bbe3a0a84fa.tar.zst
freebsd-ports-gnome-fc4bdc8940e2d2c175848ab56b762bbe3a0a84fa.zip
update to 4.1.1
Major Features: - RFC 7344: CDS and CDNSKEY (read record types). - per zone statistics with --enable-zone-stats - Disabled use of SSLv3 in nsd-control. - Synthesize CNAMEs with same TTL as DNAME. - nsd-checkconf -f prints out full name of pidfile (with dir). [1] PR: 197291, 196449 [1] Submitted by: Jaap Akkerhuis <jaap@NLnetLabs.nl>, Adam Zaleski <adam@zaleski.org> [1]
Diffstat (limited to 'dns')
-rw-r--r--dns/nsd/Makefile7
-rw-r--r--dns/nsd/distinfo4
-rw-r--r--dns/nsd/files/nsd.in2
3 files changed, 7 insertions, 6 deletions
diff --git a/dns/nsd/Makefile b/dns/nsd/Makefile
index 0518bd548bfa..d838c7419567 100644
--- a/dns/nsd/Makefile
+++ b/dns/nsd/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= nsd
-PORTVERSION= 4.1.0
-PORTREVISION= 1
+PORTVERSION= 4.1.1
CATEGORIES= dns ipv6
MASTER_SITES= http://www.nlnetlabs.nl/downloads/nsd/ \
ftp://ftp.rhnet.is/pub/nsd/
@@ -48,7 +47,7 @@ PORTDOCS= CREDITS ChangeLog LICENSE NSD-DATABASE NSD-DIFFFILE \
differences.tex
OPTIONS_DEFINE= ROOT_SERVER LARGEFILE IPV6 BIND8_STATS CHECKING \
- MINRESPSIZE NSEC3 MMAP MAXIPS DOCS RRL
+ MINRESPSIZE NSEC3 MMAP MAXIPS DOCS RRL ZONE_STATS
OPTIONS_DEFAULT= LARGEFILE IPV6 NSEC3 MINRESPSIZE RRL
ROOT_SERVER_DESC= Configure as a root server
@@ -60,6 +59,7 @@ MINRESPSIZE_DESC= Minimial response sizing
MMAP_DESC= Use mmap instead of malloc (experimental)
MAXIPS_DESC= Raise max-ips from 8 to ${NSDMAX_IPS}
RRL_DESC= Response Rate Limiting
+ZONE_STATS_DESC= Separate statistics for each zone
LIB_DEPENDS+= libevent.so:${PORTSDIR}/devel/libevent2
@@ -73,6 +73,7 @@ MINRESPSIZE_CONFIGURE_ENABLE= minimal-responses
MMAP_CONFIGURE_ENABLE= mmap
MAXIPS_CONFIGURE_ON= --with-max-ips=${NSDMAX_IPS}
RRL_CONFIGURE_ENABLE= ratelimit
+ZONE_STATS_CONFIGURE_ENABLE= zone-stats
post-install:
${INSTALL_DATA} ${WRKSRC}/nsd.conf.sample \
diff --git a/dns/nsd/distinfo b/dns/nsd/distinfo
index 5ed3d96a19d7..dcd1bebd7e6c 100644
--- a/dns/nsd/distinfo
+++ b/dns/nsd/distinfo
@@ -1,2 +1,2 @@
-SHA256 (nsd-4.1.0.tar.gz) = ec3f6902f6f26a6b9248dcd7e9f42472fa52755740b4ba6b9d3bd08910b39b62
-SIZE (nsd-4.1.0.tar.gz) = 1056649
+SHA256 (nsd-4.1.1.tar.gz) = b0c3fab40ac7a8b5ffca642bc9e1b424aa72aebd03adf13a1f24ab4874734640
+SIZE (nsd-4.1.1.tar.gz) = 1063955
diff --git a/dns/nsd/files/nsd.in b/dns/nsd/files/nsd.in
index 0c77fde18915..d8efc9e58cde 100644
--- a/dns/nsd/files/nsd.in
+++ b/dns/nsd/files/nsd.in
@@ -23,7 +23,7 @@ load_rc_config "${name}"
config=${nsd_config:=%%PREFIX%%/etc/nsd/nsd.conf}
required_files=${config}
-pidfile=`%%PREFIX%%/sbin/nsd-checkconf -o pidfile ${config}`
+pidfile=`%%PREFIX%%/sbin/nsd-checkconf -f -o pidfile ${config}`
command="%%PREFIX%%/sbin/${name}"
command_args="-c ${required_files}"
extra_commands="reload"