aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2005-11-15 14:52:12 +0800
committerade <ade@FreeBSD.org>2005-11-15 14:52:12 +0800
commit8d9d5197561118544281733430b48b0b60884450 (patch)
tree45e5dcd7c2206fce8b01186555aac96b6292c602 /dns
parent081b17449bd91bcac5390cd0d8a63ed3914df51d (diff)
downloadfreebsd-ports-gnome-8d9d5197561118544281733430b48b0b60884450.tar.gz
freebsd-ports-gnome-8d9d5197561118544281733430b48b0b60884450.tar.zst
freebsd-ports-gnome-8d9d5197561118544281733430b48b0b60884450.zip
Mass-conversion to the USE_AUTOTOOLS New World Order. The code present
in bsd.autotools.mk essentially makes this a no-op given that all the old variables set a USE_AUTOTOOLS_COMPAT variable, which is parsed in exactly the same way as USE_AUTOTOOLS itself. Moreover, USE_AUTOTOOLS has already been extensively tested by the GNOME team -- all GNOME 2.12.x ports use it. Preliminary documentation can be found at: http://people.FreeBSD.org/~ade/autotools.txt which is in the process of being SGMLized before introduction into the Porters Handbook. Light blue touch-paper. Run.
Diffstat (limited to 'dns')
-rw-r--r--dns/fastresolve/Makefile3
-rw-r--r--dns/idnkit/Makefile2
-rw-r--r--dns/libidn/Makefile2
-rw-r--r--dns/mydns-ng/Makefile2
-rw-r--r--dns/mydns/Makefile2
-rw-r--r--dns/posadis/Makefile4
-rw-r--r--dns/powerdns-devel/Makefile2
-rw-r--r--dns/powerdns/Makefile2
8 files changed, 8 insertions, 11 deletions
diff --git a/dns/fastresolve/Makefile b/dns/fastresolve/Makefile
index 8277a216d129..6c1bc4696bad 100644
--- a/dns/fastresolve/Makefile
+++ b/dns/fastresolve/Makefile
@@ -23,8 +23,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib" \
CXXFLAGS="-I${LOCALBASE}/include" \
PERL=${PERL}
-USE_AUTOMAKE_VER= 14
-USE_AUTOCONF_VER= 213
+USE_AUTOTOOLS= automake:14 autoconf:213
# Default to db3
WITH_BDB_VER?= 3
diff --git a/dns/idnkit/Makefile b/dns/idnkit/Makefile
index 6b8e5f9ad26c..6060ec531802 100644
--- a/dns/idnkit/Makefile
+++ b/dns/idnkit/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A library to handle internationalized domain names
USE_ICONV= yes
-USE_INC_LIBTOOL_VER= 13
+USE_AUTOTOOLS= libtool:13:inc
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-libiconv=${LOCALBASE} \
--enable-runidn \
diff --git a/dns/libidn/Makefile b/dns/libidn/Makefile
index 1f122d7e5418..fd8f259a24bd 100644
--- a/dns/libidn/Makefile
+++ b/dns/libidn/Makefile
@@ -18,7 +18,7 @@ COMMENT= Internationalized Domain Names command line tool
USE_GETOPT_LONG= yes
USE_GNOME= gnomehack gnometarget pkgconfig
USE_ICONV= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
USE_PERL5_BUILD= yes
USE_REINPLACE= yes
diff --git a/dns/mydns-ng/Makefile b/dns/mydns-ng/Makefile
index 90632e6a13e8..1114b588e3fa 100644
--- a/dns/mydns-ng/Makefile
+++ b/dns/mydns-ng/Makefile
@@ -16,7 +16,7 @@ COMMENT= DNS server designed to utilize the MySQL database
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-confdir=${PREFIX}/etc
USE_ICONV= yes
-USE_LIBTOOL_VER= 15
+USE_AUTOTOOLS= libtool:15
USE_BZIP2= yes
USE_RC_SUBR= mydns.sh
diff --git a/dns/mydns/Makefile b/dns/mydns/Makefile
index 90632e6a13e8..1114b588e3fa 100644
--- a/dns/mydns/Makefile
+++ b/dns/mydns/Makefile
@@ -16,7 +16,7 @@ COMMENT= DNS server designed to utilize the MySQL database
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-confdir=${PREFIX}/etc
USE_ICONV= yes
-USE_LIBTOOL_VER= 15
+USE_AUTOTOOLS= libtool:15
USE_BZIP2= yes
USE_RC_SUBR= mydns.sh
diff --git a/dns/posadis/Makefile b/dns/posadis/Makefile
index bcd290a24dbf..6eb2ea9cf6ee 100644
--- a/dns/posadis/Makefile
+++ b/dns/posadis/Makefile
@@ -17,9 +17,7 @@ COMMENT= Domain Name Server (DNS) implementation
LIB_DEPENDS= poslib.0:${PORTSDIR}/devel/poslib
-USE_AUTOCONF_VER= 259
-USE_LIBTOOL_VER= 15
-USE_LIBLTDL= yes
+USE_AUTOTOOLS= autoconf:259 libltdl:15 libtool:15
INSTALLS_SHLIB= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/dns/powerdns-devel/Makefile b/dns/powerdns-devel/Makefile
index dad98825b1a4..14aa741862d4 100644
--- a/dns/powerdns-devel/Makefile
+++ b/dns/powerdns-devel/Makefile
@@ -19,7 +19,7 @@ BUILD_DEPENDS= bjam:${PORTSDIR}/devel/boost
USE_GMAKE= YES
USE_SUBMAKE= YES
USE_REINPLACE= YES
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
INSTALLS_SHLIB= YES
CXXFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/dns/powerdns/Makefile b/dns/powerdns/Makefile
index dad98825b1a4..14aa741862d4 100644
--- a/dns/powerdns/Makefile
+++ b/dns/powerdns/Makefile
@@ -19,7 +19,7 @@ BUILD_DEPENDS= bjam:${PORTSDIR}/devel/boost
USE_GMAKE= YES
USE_SUBMAKE= YES
USE_REINPLACE= YES
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
INSTALLS_SHLIB= YES
CXXFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib