aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2015-01-03 00:55:26 +0800
committeradamw <adamw@FreeBSD.org>2015-01-03 00:55:26 +0800
commit11dd2c769fb0b9e307b64c2359d5bd39ce26497a (patch)
tree31ba103fc84ffead4081acf55d641670f0f35b93 /dns
parentc2c315d82117b0d0863a2912ca1904d13dee91a4 (diff)
downloadfreebsd-ports-gnome-11dd2c769fb0b9e307b64c2359d5bd39ce26497a.tar.gz
freebsd-ports-gnome-11dd2c769fb0b9e307b64c2359d5bd39ce26497a.tar.zst
freebsd-ports-gnome-11dd2c769fb0b9e307b64c2359d5bd39ce26497a.zip
Remove portions of patch relying upon faith(4) that are no longer necessary.
PR: 195002 Submitted by: Stanislaw Halik (maintainer) Patch by: Ben Woods Approved by: maintainer
Diffstat (limited to 'dns')
-rw-r--r--dns/noip/Makefile2
-rw-r--r--dns/noip/files/patch-noip2.c25
2 files changed, 1 insertions, 26 deletions
diff --git a/dns/noip/Makefile b/dns/noip/Makefile
index dd7fa65cc8d8..6dabe252ca30 100644
--- a/dns/noip/Makefile
+++ b/dns/noip/Makefile
@@ -3,7 +3,7 @@
PORTNAME= noip
PORTVERSION= 2.1.9
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= dns
MASTER_SITES= http://www.no-ip.com/client/linux/ \
CRITICAL
diff --git a/dns/noip/files/patch-noip2.c b/dns/noip/files/patch-noip2.c
index f8f70e4b5c8b..9d020076fadc 100644
--- a/dns/noip/files/patch-noip2.c
+++ b/dns/noip/files/patch-noip2.c
@@ -27,28 +27,3 @@
fprintf(stderr, "Options: -C create configuration data\n");
fprintf(stderr, " -F force NAT off\n");
fprintf(stderr, " -Y select all hosts/groups\n");
-@@ -2316,17 +2316,14 @@
- dq = (unsigned char *)devs; // point at name list
- for (ifa = ifap; ifa; ifa = ifa->ifa_next) {
- if (ifa->ifa_addr->sa_family == AF_LINK) {
--// FreeBSD doesn't define some of these!
--#ifdef IFT_PFLOG
- struct if_data *ifd = (struct if_data *) ifa->ifa_data;
-- if (ifd->ifi_type == IFT_PFLOG
-- || ifd->ifi_type == IFT_PFSYNC
-- || ifd->ifi_type == IFT_ENC
-- || ifd->ifi_type == IFT_BRIDGE
-- || ifd->ifi_type == IFT_OTHER
-- || ifd->ifi_type == IFT_GIF)
-- continue;
--#endif
-+
-+ if (ifd->ifi_type == IFT_OTHER
-+ || ifd->ifi_type == IFT_GIF
-+ || ifd->ifi_type == IFT_LOOP
-+ || ifd->ifi_type == IFT_FAITH)
-+ continue;
-+
- q = dq; // add new name into list
- p = ifa->ifa_name;
- devnum++;