aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-06-23 14:04:01 +0800
committerijliao <ijliao@FreeBSD.org>2002-06-23 14:04:01 +0800
commit2e5a089158bc145f89582021e74d01797d009897 (patch)
treef579cbe02fdbd28a1f909c61649a01ccee65bb50 /dns
parentf3cdfeb23d80a8c403d671681536a62f5c7dd3b0 (diff)
downloadfreebsd-ports-gnome-2e5a089158bc145f89582021e74d01797d009897.tar.gz
freebsd-ports-gnome-2e5a089158bc145f89582021e74d01797d009897.tar.zst
freebsd-ports-gnome-2e5a089158bc145f89582021e74d01797d009897.zip
Replace ${PERL} with ${REINPLACE_CMD}
PR: 39668 Submitted by: Oliver Braun <obraun@informatik.unibw-muenchen.de>
Diffstat (limited to 'dns')
-rw-r--r--dns/dlint/Makefile3
-rw-r--r--dns/maradns/Makefile6
2 files changed, 6 insertions, 3 deletions
diff --git a/dns/dlint/Makefile b/dns/dlint/Makefile
index 9de4133041d6..34e7b55028b7 100644
--- a/dns/dlint/Makefile
+++ b/dns/dlint/Makefile
@@ -14,11 +14,12 @@ DISTNAME= dlint${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
+USE_REINPLACE= yes
NO_BUILD= yes
MAN8= dlint.8
do-configure:
- @${PERL} -pi.orig -e 's:/usr/local/bin:${PREFIX}/sbin:g' ${WRKSRC}/dlint
+ @${REINPLACE_CMD} -e 's:/usr/local/bin:${PREFIX}/sbin:g' ${WRKSRC}/dlint
@${SED} -e 's:DLINT 1:DLINT 8:g' ${WRKSRC}/dlint.1 >${WRKSRC}/dlint.8
do-install:
diff --git a/dns/maradns/Makefile b/dns/maradns/Makefile
index 7ca726bca563..20c2ef5a0796 100644
--- a/dns/maradns/Makefile
+++ b/dns/maradns/Makefile
@@ -14,6 +14,8 @@ MASTER_SITES= http://www.maradns.org/download/ \
MAINTAINER= ports@FreeBSD.org
+USE_REINPLACE= yes
+REINPLACE_ARGS= -i ""
USE_BZIP2= yes
MAKE_ENV= FLAGS="${CFLAGS} ${PTHREAD_CFLAGS}"
@@ -22,9 +24,9 @@ MAN5= mararc.5
MAN8= maradns.8 zoneserver.8
post-patch:
- @${FIND} ${WRKSRC} -type f | ${XARGS} ${PERL} -pi -e \
+ @${FIND} ${WRKSRC} -type f | ${XARGS} ${REINPLACE_CMD} -e \
's|/etc/mara|${PREFIX}/etc/mara|g'
- @${FIND} ${WRKSRC} -name '*Makefile*' | ${XARGS} ${PERL} -pi -e \
+ @${FIND} ${WRKSRC} -name '*Makefile*' | ${XARGS} ${REINPLACE_CMD} -e \
's|make|\$$\{MAKE\}|g ; \
s|^FLAGS =|#FLAGS =|g ; \
s|-lpthread|${PTHREAD_LIBS}|g'