aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-10-15 14:25:21 +0800
committeredwin <edwin@FreeBSD.org>2003-10-15 14:25:21 +0800
commit2fd539dd828da3326eabe241e74e9303dc5e60b7 (patch)
tree588a58cb5262ccc1896762ac82879c95dacc6ce8 /dns
parent5e91120bbf67c538da572f78fa283158bc58bbfa (diff)
downloadfreebsd-ports-gnome-2fd539dd828da3326eabe241e74e9303dc5e60b7.tar.gz
freebsd-ports-gnome-2fd539dd828da3326eabe241e74e9303dc5e60b7.tar.zst
freebsd-ports-gnome-2fd539dd828da3326eabe241e74e9303dc5e60b7.zip
Only throw the error when RUBY_VER != RUBY_DEFAULT_VER.
Diffstat (limited to 'dns')
-rw-r--r--dns/zonecheck/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/dns/zonecheck/Makefile b/dns/zonecheck/Makefile
index 26d35639cf28..469c6c490fd6 100644
--- a/dns/zonecheck/Makefile
+++ b/dns/zonecheck/Makefile
@@ -15,8 +15,6 @@ EXTRACT_SUFX= .tgz
MAINTAINER= janos.mohacsi@bsd.hu
COMMENT= Perform consistency checks on DNS zone files
-BROKEN= Broken dependency
-
RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/gtk.so:${PORTSDIR}/x11-toolkits/ruby-gtk
WRKSRC= ${WRKDIR}/${PORTNAME}
@@ -26,4 +24,10 @@ NO_BUILD= yes
RUBY_VER= 1.8
MAN1= zonecheck.1
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${RUBY_DEFAULT_VER} != ${RUBY_VER}
+BROKEN= Broken dependency. This might be only a package building issue. The problem is that the default Ruby version for i386 is ${RUBY_DEFAULT_VER}, while the default version for the other architectures is ${RUBY_VER}. This port requires Ruby ${RUBY_VER}. If you are using the right Ruby version, please remove the BROKEN line from the Makefile and try again.
+.endif
+
+.include <bsd.port.post.mk>