aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2014-10-22 19:59:49 +0800
committerpi <pi@FreeBSD.org>2014-10-22 19:59:49 +0800
commit4ff9fec01fadb87f56c368bf624d1a34afd1f1f5 (patch)
tree2c43526bc85d5e90dff6e44725f4936cbfeada1d /dns
parent6f7a3681d88f41f55d55c6ad414edd4aca2e555e (diff)
downloadfreebsd-ports-gnome-4ff9fec01fadb87f56c368bf624d1a34afd1f1f5.tar.gz
freebsd-ports-gnome-4ff9fec01fadb87f56c368bf624d1a34afd1f1f5.tar.zst
freebsd-ports-gnome-4ff9fec01fadb87f56c368bf624d1a34afd1f1f5.zip
dns/powerdns: fix for check-plist with non-standard options
The pkg-plist was broken with non-default backends enabled. PR: 194505 Submitted by: Ralf van der Enden <tremere@cainites.net> (maintainer)
Diffstat (limited to 'dns')
-rw-r--r--dns/powerdns/Makefile4
-rw-r--r--dns/powerdns/files/patch-modules__luabackend__lua_functions.cc18
-rw-r--r--dns/powerdns/files/patch-modules__luabackend__luabackend.hh12
3 files changed, 32 insertions, 2 deletions
diff --git a/dns/powerdns/Makefile b/dns/powerdns/Makefile
index 7d1f6bddd31b..bae3d0aff225 100644
--- a/dns/powerdns/Makefile
+++ b/dns/powerdns/Makefile
@@ -25,6 +25,7 @@ LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --disable-static \
--with-modules="" \
--with-dynmodules="pipe bind ${MODULES}" \
+ --docdir="${PREFIX}/share/doc/powerdns" \
--sysconfdir="${PREFIX}/etc/pdns" \
--with-boost="${LOCALBASE}"
SCRIPTS_ENV= WRKDIRPREFIX="${WRKDIRPREFIX}" \
@@ -32,7 +33,6 @@ SCRIPTS_ENV= WRKDIRPREFIX="${WRKDIRPREFIX}" \
MKDIR="${MKDIR}" \
DISTNAME="${DISTNAME}" \
POWERDNS_OPTIONS="${POWERDNS_OPTIONS}"
-# DOCSDIR= ${PREFIX}/share/doc/pdns
SUB_FILES= pkg-message
@@ -60,7 +60,7 @@ REMOTE_DESC= Remote backend
TINYDNS_DESC= TinyDNS backend
TOOLS_DESC= Build extra tools
-OPTIONS_DEFAULT= PGSQLDB DNSSEC BOTAN110 POLARSSL
+OPTIONS_DEFAULT= PGSQL DNSSEC BOTAN110 POLARSSL
OPTIONS_SUB= yes
diff --git a/dns/powerdns/files/patch-modules__luabackend__lua_functions.cc b/dns/powerdns/files/patch-modules__luabackend__lua_functions.cc
new file mode 100644
index 000000000000..fcb87906ee34
--- /dev/null
+++ b/dns/powerdns/files/patch-modules__luabackend__lua_functions.cc
@@ -0,0 +1,18 @@
+--- modules/luabackend/lua_functions.cc.orig 2014-09-23 06:27:34 UTC
++++ modules/luabackend/lua_functions.cc
+@@ -238,6 +238,7 @@
+ return ret;
+ }
+
++#ifndef __i386__
+ bool LUABackend::getValueFromTable(lua_State *lua, const std::string& key, time_t& value) {
+ lua_pushstring(lua, key.c_str());
+ lua_gettable(lua, -2);
+@@ -253,6 +254,7 @@
+
+ return ret;
+ }
++#endif
+
+ bool LUABackend::getValueFromTable(lua_State *lua, const std::string& key, uint32_t& value) {
+ lua_pushstring(lua, key.c_str());
diff --git a/dns/powerdns/files/patch-modules__luabackend__luabackend.hh b/dns/powerdns/files/patch-modules__luabackend__luabackend.hh
new file mode 100644
index 000000000000..df2fb1d8fd21
--- /dev/null
+++ b/dns/powerdns/files/patch-modules__luabackend__luabackend.hh
@@ -0,0 +1,12 @@
+--- modules/luabackend/luabackend.hh.orig 2014-09-23 06:27:34 UTC
++++ modules/luabackend/luabackend.hh
+@@ -155,7 +155,9 @@
+ // FUNCTIONS TO THIS BACKEND
+ bool getValueFromTable(lua_State *lua, const std::string& key, string& value);
+ bool getValueFromTable(lua_State *lua, uint32_t key, string& value);
++#ifndef __i386__
+ bool getValueFromTable(lua_State *lua, const std::string& key, time_t& value);
++#endif
+ bool getValueFromTable(lua_State *lua, const std::string& key, uint32_t& value);
+ bool getValueFromTable(lua_State *lua, const std::string& key, uint16_t& value);
+ bool getValueFromTable(lua_State *lua, const std::string& key, int& value);
1-10-19 23:38:10 +0800'>2011-10-191-2903/+2985 * Trivial little cleanups.Matthew Barnes2011-10-197-7/+2 * Updated Spanish translationDaniel Mustieles2011-10-181-65/+80 * Bug #661549 - Avoid fetching from backend when calculating summaryMilan Crha2011-10-181-16/+24 * Fix invalid read on vCard dropMilan Crha2011-10-181-1/+2 * Updated Galician translationsFran Diéguez2011-10-181-2/+12 * Updated Hungarian translationGabor Kelemen2011-10-171-7/+7 * Realized I broke APOP authentication.Matthew Barnes2011-10-151-12/+3 * Adapt to Camel's new authentication API.Matthew Barnes2011-10-151-0/+129 * Updaged Galician translationsFran Dieguez2011-10-151-1850/+1978 * [l10n] Updated German doc translationMario Blättermann2011-10-151-274/+302 * Bug #660530 - Improve folder Subscription interfaceMilan Crha2011-10-141-87/+588 * Downstream bug Bnc#688711 unable to book resourceVeerapuram Varadhan2011-10-141-1/+18 * Updated Spanish translationDaniel Mustieles2011-10-141-93/+46 * Updated Spanish translationDaniel Mustieles2011-10-141-182/+190 * Bug 661650 - "Certificate Authority Trust" strings miss mnemonicsMatthew Barnes2011-10-141-3/+3 * Bug #576478 - [Windows] Redirect Help->Contents to a web pageMilan Crha2011-10-131-0/+9 * User Docs: Harmonize naming of PST file format. Fixes bug #588568Andre Klapper2011-10-131-3/+3 * User Docs: Explain how to set Certificates to Trusted. Fixes bug #658813Andre Klapper2011-10-131-1/+4 * Bug #455271 - A moved/renamed mail folder loses focusMilan Crha2011-10-131-1/+37 * Bug #660721 - Online Account services not always activatingMilan Crha2011-10-132-2/+6 * Fix typos in user visible stringsAndre Klapper2011-10-131-4/+4 * Require libgdata >= 0.10.Matthew Barnes2011-10-132-14/+2 * Updated Spanish translationDaniel Mustieles2011-10-121-28/+32 * Bug 661534 - "Current View" tooltip untranslatedMatthew Barnes2011-10-121-1/+1 * Bug 661542 - Weird "Cannot upgrade from version 0.xxxx" on first useVincent Untz2011-10-121-6/+4 * Bug 661399 - Crash when hovering over calendar entryMatthew Barnes2011-10-122-8/+11 * Bug #661434 - Unfriendly search resultMilan Crha2011-10-112-1/+6 * Bug #661404 - Adding multiple e-mails to contact list is too hardMilan Crha2011-10-111-25/+26 * Use gtk_check_button_new_with_mnemonic() with a mnemonic stringMilan Crha2011-10-111-1/+1 * Bug #660829 - Allow 'Mark as read' in right click menu on spam folderMilan Crha2011-10-111-18/+12 * Bug #660861 - Avoid mark-all-read on a non-folder selectionMilan Crha2011-10-111-1/+2 * Bug #660850 - Missing set mnemonic widgets in composer preferencesMilan Crha2011-10-111-0/+2 * Bug #660782 - [pst-import] Missing tasks after importMilan Crha2011-10-111-16/+105 * Updated Lithuanian translationAlgimantas Margevičius2011-10-091-2914/+2990 * [l10n] Updated German translationMario Blättermann2011-10-091-2063/+2093 * Updated Spanish translationJorge González2011-10-081-26/+43 * Updated Spanish translationJorge González2011-10-082-267/+230 * Fix typo in schema file in commit d2232a7Dan Vrátil2011-10-071-1/+1 * Bug #235665 - Heavy hard disk access when resizing columns in viewsMilan Crha2011-10-075-2/+86 * Bug #659876 - Make automatic contact address formatting optionalDan Vrátil2011-10-074-4/+50 * Bug #658066 - Security dialog is too bigDan Vrátil2011-10-072-75/+21 * Updated Vietnamese translationNguyễn Thái Ngọc Duy2011-10-071-41/+66 * Updated Spanish translationDaniel Mustieles2011-10-071-325/+605 * Fixed typo in stringDaniel Mustieles2011-10-071-1/+1 * Updated Spanish translationDaniel Mustieles2011-10-071-990/+1024 * Remove redundant ETypeFunc definition.Matthew Barnes2011-10-071-2/+0 * Adapt to CamelFolderSummary API changesMilan Crha2011-10-066-38/+31 * Prefer g_simple_async_result_take_error().Matthew Barnes2011-10-069-122/+61 * Let GtkFileChooser track its own last-used-folder.Matthew Barnes2011-10-0613-262/+42 * Remove EHintedEntry.Matthew Barnes2011-10-065-383/+18 * EAttachmentPaned: Add "resize-toplevel" property.Matthew Barnes2011-10-063-18/+116 * GtkApplication has some new EShell-like features.Matthew Barnes2011-10-0624-323/+190 * Increase dependency on gtk+ to 3.2.0Milan Crha2011-10-061-1/+1 * Bug #660878 - Account configuration options are not auto-filledDan Vrátil2011-10-051-11/+12 * Oops, missed one.Matthew Barnes2011-10-051-1/+4 * Simplify library dependency flags.Matthew Barnes2011-10-0579-451/+365 * Bug #657374 - mailto: attachment parameter can lead to accidental data exfilt...Vibha Yadav2011-10-042-0/+35 * Bug 660799 - Bad GOptionEntry in evolution-addressbook-exportMatthew Barnes2011-10-041-1/+1 * Updated .page file list in help/Makefile.amClaude Paroz2011-10-031-3/+3 * publish-calendar: correct Secure FTP abbreviation to SFTPNguyễn Thái Ngọc Duy2011-10-031-1/+1 * itip-formatter: end some strings with colon instead of full stopNguyễn Thái Ngọc Duy2011-10-031-3/+3 * Updated Vietnamese translationNguyễn Thái Ngọc Duy2011-10-021-655/+410 * LC_ADDRESS is no posix and may not be defined.Antoine Jacoutot2011-10-011-0/+4 * Updated Vietnamese translationNguyễn Thái Ngọc Duy2011-10-011-135/+70 * po/vi: import from Damned LiesNguyễn Thái Ngọc Duy2011-10-011-5937/+5660 * Fix two little memory leaksDan Vrátil2011-10-012-1/+7 * Bug 660584 - Fix crash when removing user certificateDan Vrátil2011-10-011-14/+13 * Bug 659486 - EAlert default response is ignored by EAlertDialogMatthew Barnes2011-10-012-7/+23 * ETableHeader: Nuke unused code.Cosimo Cecchi2011-09-301-147/+2 * ETableHeader: Rework the header button drawing code for GTK+ 3Cosimo Cecchi2011-09-305-120/+93 * backup-restore cleanups.Matthew Barnes2011-09-302-122/+247 * Fix few 'may be used uninitialized' compiler warningsMilan Crha2011-09-3011-16/+16 * Bug #601898 - SOCKS proxy does not work with mailerMilan Crha2011-09-304-103/+128 * Bug #656378 attachment name corruptionPunit Jain2011-09-301-2/+4 * Remove Ctrl + l ( ) character from source filesPaul Menzel2011-09-3046-134/+9 * Prefer G_VALUE_INIT over memset().Matthew Barnes2011-09-301-5/+2 * Require GLib 2.30.Matthew Barnes2011-09-303-19/+1 * Bug #632619 - Recurring events can clutter month viewMilan Crha2011-09-295-5/+40 * Bug #659517 - Calendar reminds of old events following upgradeMilan Crha2011-09-291-8/+17 * Updated Telugu Translationskrishnababu k2011-09-291-7498/+8788 * User Docs: Remove three pages covering common errors that should be fixed in 3.3Andre Klapper2011-09-293-133/+0 * User Docs: Mention that spam settings are not included in backup. Fixes bug #...Andre Klapper2011-09-291-1/+2 * User Docs: Improve markupAndre Klapper2011-09-291-5/+5 * User Docs: Fix several typos and issues. Fixes bug #658651.Michael Hill2011-09-2917-25/+25 * User Docs: Fix issues pointed out by Michael Hill in bug #658651 comment 3Andre Klapper2011-09-293-5/+5 * User Docs: Add gvfs package hint for default browser page. Fixes bug #658809Andre Klapper2011-09-291-1/+4 * User Docs: Fix typo. Fixes bug #659058Andre Klapper2011-09-291-2/+2 * Updated Spanish translationJorge González2011-09-281-2/+100 * Updated Spanish translationJorge González2011-09-281-1/+127 * Updated Spanish translationJorge González2011-09-281-4/+49 * Updated Spanish translationJorge González2011-09-281-599/+600 * Updated Spanish translationJorge González2011-09-282-2338/+2454 * Bug 659726 - Search Folders contain ambiguous reference to accountsMatthew Barnes2011-09-284-41/+76 * Bug #659874 - Address Cards Render extra Phone NumberMilan Crha2011-09-281-1/+14 * Adapt to camel-provider-1.2.pc going away.Matthew Barnes2011-09-282-9/+5 * Miscellaneous cleanups from the account-mgmt branch.Matthew Barnes2011-09-27101-847/+1110 * Bug #660224 - Assertion failure when forwarding messageMilan Crha2011-09-273-20/+39 * Updated Irish translationSeán de Búrca2011-09-271-4427/+4412 * Remove missing fileSeán de Búrca2011-09-271-1/+0 * Updated Spanish translationJorge González2011-09-271-28/+17 * Updated Spanish translationJorge González2011-09-271-79/+158 * EMFolderTreeModel: Don't use parameters in "get_default" functions.Matthew Barnes2011-09-2615-206/+186 * itip-formatter: Adapt to CamelDB API changes.Matthew Barnes2011-09-261-3/+3 * The EExtension framework is now in libebackend.Matthew Barnes2011-09-2663-1229/+245 * Adapt to CamelURL API changes.Matthew Barnes2011-09-262-2/+2 * EMFormatHTML: Configure CamelHttpStreams with proxy authpass.Matthew Barnes2011-09-263-86/+45 * [l10n]Updated Catalan (Valencian) translationCarles Ferrando2011-09-261-4077/+4308 * Bug #659568 - One day delay in calendar viewMilan Crha2011-09-263-27/+47 * Bug #655625 - Crash in atk_state_set_contains_stateMilan Crha2011-09-262-7/+12 * Bug #659828 - Selecting a message with a sound attached loses focusMilan Crha2011-09-262-2/+2 * Bug #659440 - Doesn't mark messages as replied when sending offlineMilan Crha2011-09-261-0/+21 * Bug #656473 - Store server folder cache in user's cache directoryMilan Crha2011-09-262-1/+17 * Bug #351025 - Make the order of the mail accounts configurableMilan Crha2011-09-2624-108/+1628 * Bug #659558 - Missing set mnemonic widgetsMilan Crha2011-09-261-0/+3 * Update Czech translation by Jiri EischmannPetr Kovar2011-09-26