aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-10-09 15:45:54 +0800
committerkrion <krion@FreeBSD.org>2004-10-09 15:45:54 +0800
commit5a704938ab0c0820b2bd944f05cedf2919c4bf89 (patch)
tree2b5ced2bc3203067b42997407d4a06437ac3c332 /dns
parent80d70aab8e6d28c28f7756d39632a61066059257 (diff)
downloadfreebsd-ports-gnome-5a704938ab0c0820b2bd944f05cedf2919c4bf89.tar.gz
freebsd-ports-gnome-5a704938ab0c0820b2bd944f05cedf2919c4bf89.tar.zst
freebsd-ports-gnome-5a704938ab0c0820b2bd944f05cedf2919c4bf89.zip
Fix build with gcc-3.4
PR: ports/72302 Submitted by: maintainer Approved by: portmgr (implicit)
Diffstat (limited to 'dns')
-rw-r--r--dns/fastresolve/Makefile4
-rw-r--r--dns/fastresolve/files/patch-dns-terror::dns-terror.cc12
2 files changed, 12 insertions, 4 deletions
diff --git a/dns/fastresolve/Makefile b/dns/fastresolve/Makefile
index 34027b02b9f3..41fe08be6dff 100644
--- a/dns/fastresolve/Makefile
+++ b/dns/fastresolve/Makefile
@@ -51,10 +51,6 @@ MAN1= dns-terror.1 btree-dump.1 convert-dom-db.1 convert-ip-db.1 \
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 502126
-BROKEN= "Does not compile on FreeBSD >= 5.x"
-.endif
-
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
diff --git a/dns/fastresolve/files/patch-dns-terror::dns-terror.cc b/dns/fastresolve/files/patch-dns-terror::dns-terror.cc
new file mode 100644
index 000000000000..d7c881f32122
--- /dev/null
+++ b/dns/fastresolve/files/patch-dns-terror::dns-terror.cc
@@ -0,0 +1,12 @@
+--- dns-terror/dns-terror.cc.orig Mon Oct 4 13:28:02 2004
++++ dns-terror/dns-terror.cc Mon Oct 4 13:28:53 2004
+@@ -331,8 +331,7 @@
+ }
+
+ r = adns_submit(ads, rev, adns_r_ptr_raw,
+- (enum adns_queryflags)
+- (adns_qf_quoteok_cname|adns_qf_quoteok_anshost), lp, &qu);
++ adns_queryflags (adns_qf_quoteok_cname|adns_qf_quoteok_anshost), lp, &qu);
+ if (r)
+ fatal_errno("adns_submit", r);
+ if (verbose)