aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authordougb <dougb@FreeBSD.org>2010-03-02 12:06:10 +0800
committerdougb <dougb@FreeBSD.org>2010-03-02 12:06:10 +0800
commita54266814595b198d9b7393457f8712b9e7171a3 (patch)
tree5a1b501427ccb8d0061a48005614ca1fa1921947 /dns
parent8ccad89fe421981fbb812380d4b73ddfd8c7e6a8 (diff)
downloadfreebsd-ports-gnome-a54266814595b198d9b7393457f8712b9e7171a3.tar.gz
freebsd-ports-gnome-a54266814595b198d9b7393457f8712b9e7171a3.tar.zst
freebsd-ports-gnome-a54266814595b198d9b7393457f8712b9e7171a3.zip
Upgrade to version 9.6.2. This version includes all previously released
security patches to the 9.6.1 version, as well as many other bug fixes. Due to the fact that the DNSSEC algorithm that will be used to sign the root zone is only included in this version and in 9.7.x those who wish to do validation MUST upgrade to one of these prior to July 2010. Feature safe: yes
Diffstat (limited to 'dns')
-rw-r--r--dns/bind96/Makefile4
-rw-r--r--dns/bind96/distinfo12
-rw-r--r--dns/bind96/files/patch-bin_dig_dighost.c19
3 files changed, 8 insertions, 27 deletions
diff --git a/dns/bind96/Makefile b/dns/bind96/Makefile
index 291333d0c263..4e6ced5677b8 100644
--- a/dns/bind96/Makefile
+++ b/dns/bind96/Makefile
@@ -12,7 +12,7 @@
# release you can generally build it cleanly from the source - Doug
PORTNAME= bind96
-PORTVERSION= 9.6.1.3
+PORTVERSION= 9.6.2
CATEGORIES= dns net ipv6
MASTER_SITES= ${MASTER_SITE_ISC} \
http://dougbarton.us/Downloads/%SUBDIR%/
@@ -25,7 +25,7 @@ MAINTAINER= dougb@FreeBSD.org
COMMENT= The BIND DNS suite with updated DNSSEC and threads
# ISC releases things like 9.4.0b3, which our versioning doesn't like
-ISCVERSION= 9.6.1-P3
+ISCVERSION= 9.6.2
MAKE_JOBS_UNSAFE= yes
diff --git a/dns/bind96/distinfo b/dns/bind96/distinfo
index 1dea3dc4fd68..57c87c7ba84e 100644
--- a/dns/bind96/distinfo
+++ b/dns/bind96/distinfo
@@ -1,6 +1,6 @@
-MD5 (bind-9.6.1-P3.tar.gz) = a0952d589b3051538033387be4c983f9
-SHA256 (bind-9.6.1-P3.tar.gz) = 869f5079a900b280c051d4c9cf7eefea000a0e70ccec9e6fcddd79e3caa10198
-SIZE (bind-9.6.1-P3.tar.gz) = 6508797
-MD5 (bind-9.6.1-P3.tar.gz.asc) = 3a8a0b5b1b342903f5ee661bceee4057
-SHA256 (bind-9.6.1-P3.tar.gz.asc) = 150217597c1ca61dc50ce46392e81f7533f9bf1031b41dd2dd387750ab61b583
-SIZE (bind-9.6.1-P3.tar.gz.asc) = 481
+MD5 (bind-9.6.2.tar.gz) = e3054a98a55095c666d73177908d63c6
+SHA256 (bind-9.6.2.tar.gz) = 97f4d4fcaf1b5c884cdc3a8dc79551fd3807a0869095b2cf18c30cd5101b1cf6
+SIZE (bind-9.6.2.tar.gz) = 6537951
+MD5 (bind-9.6.2.tar.gz.asc) = af611aeea153b48ce35fbe04917c9ef4
+SHA256 (bind-9.6.2.tar.gz.asc) = 891e76af5ca0a32d9d03148a54c0bbae9dd95fbe675e82b67468f57a8653dad9
+SIZE (bind-9.6.2.tar.gz.asc) = 480
diff --git a/dns/bind96/files/patch-bin_dig_dighost.c b/dns/bind96/files/patch-bin_dig_dighost.c
deleted file mode 100644
index 19cbde833cfc..000000000000
--- a/dns/bind96/files/patch-bin_dig_dighost.c
+++ /dev/null
@@ -1,19 +0,0 @@
---- bin/dig/dighost.c.orig 2009-02-24 18:39:21.000000000 -0800
-+++ bin/dig/dighost.c 2009-11-07 11:03:16.000000000 -0800
-@@ -2604,10 +2604,12 @@
-
- if (sevent->result == ISC_R_CANCELED) {
- debug("in cancel handler");
-- isc_socket_detach(&query->sock);
-- sockcount--;
-- INSIST(sockcount >= 0);
-- debug("sockcount=%d", sockcount);
-+ if (query->sock != NULL) {
-+ isc_socket_detach(&query->sock);
-+ sockcount--;
-+ INSIST(sockcount >= 0);
-+ debug("sockcount=%d", sockcount);
-+ }
- query->waiting_connect = ISC_FALSE;
- isc_event_free(&event);
- l = query->lookup;